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1 Welcome to the Approved Workman Database

The Approved Workman Database (AWdb) is a recordkeeping system for Awana
clubs. It helps Awana leaders be more accurate and time efficient so they can do
what’s really important – m inister to children.

The Legacy version of AWdb stores data on a personal computer or device.
There is also a Web version of the AWdb that stores the data "in the cloud". This
guide is for the Legacy version and is designed as both a course in using the
database and as ongoing reference while working with the application. It
assumes familiarity with how to run an Awana club and focuses on how to
integrate AWdb into it.

Conventions used in this User Guide

Important warnings! Pay attention!!

Additional information for clarification.

Tips that might be helpful.

How to get started...

Review the Getting Started and Learning the Basics sections for an introduction to the database.

Visit the Approved Workman Forum to find helpful training videos.

http://www.approvedworkman.com/forum
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2 Getting Started

Install a Free Trial Verson of AWdb from our website (www.approvedworkman.com). The trial version
is a fully functional installation of the program except access is limited to 30-days.

Use the trial version to learn the basics of navigating the database and explore all of the features using
sample data. The sample data will eventually be erased, so don't worry about altering or deleting
records.

After becoming comfortable with AWdb, purge the sample data and then begin entering real club data.

Purchase a license to activate the database for continued use without reinstalling and without losing
any data.

2.1 Minimum System Requirements

System configurations should meet these requirements:

Operating Systems:  Microsoft Windows 10, 8, 7, Vista, or XP (Apple and Linux OS's are not supported)

Minimum RAM:  Windows XP requires 512 MB, but 1 GB is recommended. Windows 10, 8, 7 and Vista
require 1 GB, but 2 GB or more is recommended

Free Disk Space:  200 MB

Display:  A minimum screen resolution of 1024x600 is required, 1024x768 or higher is recommended

Internet Connection: AWdb can be run without any Internet connection. However, periodically checking
for updates does require an Internet connection

2.2 Possible configurations

Depending on club size and organization, there are a variety of ways to configure a system to run AWdb.
Below are some suggestions; however, adjustments can be made as needed.

In addition to the options listed below, there is also a Web version of AWdb available which allows access for

multiple users.  See our website (www.approvedworkman.com) for additional information.

Single License

This simple setup works for small clubs where a single Awana secretary handles all of the recordkeeping.
With a single license, AWdb can be installed on a PC or laptop computer for one user at a time to access
the data. (The Database Check-out/Check-in feature is not available with a single license. See below.)

In cases where the single user needs to work on the database from more than one computer (for
example, a home PC and one at church), AWdb can be run directly from a USB flash drive for portability.
Simply eject the flash drive with AWdb and take it to another computer.

When using a USB flash drive, it is critical to exit the database and then use the proper technique to shut
down the USB storage device before removing it from the computer.  Not waiting for the confirmation
from Windows that it is safe to remove the device might cause file corruption.  Also, since all of the data
will be on the flash drive, be sure to make backups!

http://www.approvedworkman.com/awdb/desktop-app
http://www.approvedworkman.com/awdb/web-app
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If one person does the data entry and is essentially in charge of the database, then a single user license
is all that is needed.  However, if another person, such as the Commander or Pastor, also wants a copy
of the database, then it is appropriate to have an additional license. (See www.approvedworkman.com
for pricing of additional licenses).

Multiple Licenses, using Database Check-out / Check-in

Larger clubs that have a secretary for each club might want multiple licenses.  One solution for using
multiple licenses is the Database Check-out / Check-in feature.  This provides non-networked, multi-user
functionality through the use of USB flash drives. Here's how it works: 

1. In the Primary database, under Admin > Database Utilities > Check-out/Check-in, Check OUT
one or more clubs onto a USB flash drive. During this process the Primary database creates a
special copy of itself, called a Secondary database, on the USB flash drive. The checked out records
will only be editable from the Secondary database. They will be locked in the Primary database until
they are checked back in.

2. Eject and safely remove the USB flash drive with the Secondary database.  It can then be given to
another person to use on a different computer. The Secondary database is launched and run
directly from the flash drive. The records for the checked out club(s) can be updated. Meanwhile,
the records that were not checked out can be updated in the Primary database.

3. At some point in time, such as the end of club night or the following week, when the USB flash drive
with the Secondary database is returned, plug it into the computer with the Primary database and
perform the database Check-IN.  During this process the Primary database imports all of the new
and modified records from the Secondary database and merges them back into the Primary
database.

Multiple Licenses, using a Server

Another solution for multiple users is to install AWdb on a server.  Each user then logs in to the single
instance of AWdb located on the server. (No AWdb software is installed on the workstation.) The number
of users that can be logged in simultaneously is determined by the number of licenses. Running AWdb
over a local area network is slower than running it on a local hard drive or from a USB flash drive, but it
eliminates the Check-out / Check-in steps.  A reliable network connection is a must, and a wired
connection is faster than a wireless connection.

Record entry, regardless of configuration

With any of these configurations, there are various approaches to entering the attendance and handbook
data, such as:

1. Print worksheets from the Reports tab for leaders to use and return to the secretary to be entered
into AWdb after club time.

2. Enter data directly into the computer as clubbers arrive and complete handbook sections.

3. Use a combination of worksheets and live data entry.

Discussions on the AWdb Forum offer additional ideas on ways to use the database. The forum is a great
place to ask questions and get feedback. A member of the support team can also answer questions.

http://www.approvedworkman.com/awdb/desktop-app
http://www.approvedworkman.com/forum
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2.3 Installing AWdb

Use the download link provided by customer support to install the Trial version of the database.  After 
learning about the database, purge the sample data to begin entering live data. Purchase a license to
convert it to a fully-registered version.

Follow the steps below to download and install the Trial version of AWdb:

Downloading the Setup Executable

1. Click the link provided by customer support to download a copy of the Trial database.

2. In the File Download dialog, click Save. If a Save As dialog appears, select Desktop and click Save.
 The file download progress is displayed.

If no dialog appears asking where to save the download, it is probably saved automatically in a folder
like 'My Downloads'.

Installing the Database

Once the setupAWdb____.exe file has been successfully downloaded:

1. Double click the setupAWdb____.exe icon (either on the Desktop or in the Downloads folder) to
launch the installation wizard.

If a “File Security Warning” dialog appears, click Run.

2. When the Installation Setup dialog opens, click Next to continue.

3. Read the License Agreement. Agree to it by scrolling to the bottom. Click Next.

4. Read the Late Breaking Information for helpful information and resources. Click Next.
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5. Choose a folder for installation. We recommend a Personal folder or the root of the C drive
(C:), not on the Desktop. Click Next.

6. The installation wizard will create a desktop shortcut for all users or just for you. Click Next.

7. When the installation completes, click Finish. There will be a new icon for the Approved Workman
Database on your desktop.
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2.4 Activating the Database

When a license for the software is purchased, an e-mail that includes a license key will be sent. To install
the permanent license key, follow these instructions (also included in the e-mail attachment):

1. Log in to AWdb.

2. Select Help > License Info from the Main Window's menu bar to open the License dialog.

3. Select the Registration tab.

4. Select and Copy the license key text from the e-mail attachment.

Don't try to type it in manually!  Typing it will not work because there are hidden characters.

5. Right click in the License Key field and select Paste from the pop-up menu.

6. Click Apply. A confirmation message should display saying: "The License Key has been successfully
applied." The database is then a fully registered version. The title bar will no longer show "Trial
License - Days Remaining". If there is a message saying: "The License Key is invalid" ensure the key
was copied correctly. If there is still a problem, contact Customer Support.
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2.5 Updating the Database

After activating the database, check for updates occasionally to get the latest bug fixes and
enhancements.

Set a prompt to check for updates when starting the application under Admin > Options > System
Reminders.

Follow the steps below to download the Update Executable:

1. From the Main Window's menu bar, select Help > Check for updates... (Admin users only).

Non-Admin users will not get the pop-up reminder or see the "Check for updates..." menu item.

2. In the confirmation dialog, click Check for updates now to communicate with Leffler Systems to
see if updates are available. (An Internet connection is required.)

If a warning appears from a firewall software, such as Norton, McAfee, or Microsoft, choose Always
Allow from the options to allow AWdb to access the Internet now and on future occasions.

3. The Account and Update Information dialog opens. The Account Information shows the Account 
Status and the Contact Information on file. To change the contact information, use the Comments
field to indicate changes. For older versions of the database, instructions are provided for
downloading and applying the update. For newer versions, simply click Apply the Update.

Detailed instructions, including a video, are available on the forum.

http://www.approvedworkman.com/forum/index.php?topic=1742.0
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2.6 Contacting Customer Support

Supporting You is Important to Us!

We are committed to providing great support to Approved Workman Database users! Although much
time, effort, and care has gone into the development and testing of this application, we acknowledge that
no software is ever totally bug free. 

For problems not addressed in the included documentation, please contact Customer Support:

E-mail: Support@LefflerSystems.com

Phone: (see the AWdb website for our support number). Please limit calls to: Monday - Friday, 8:00
AM - 5:00 PM Central Time Zone.  If evening or weekend support is required, please arrange an
appointment by e-mail, or by calling during normal business hours first. Thank you. 

Remote Support: For some issues, a Customer Support representative might request a remote
support session. This allows the support representative to share your computer screen to help
resolve a problem.

The Approved Workman Forum provides helpful information and tips. It provides a way to get the latest
news, submit reports of problems and enhancement requests, review Frequently Asked Questions and
watch training videos. It's also a great place to ask and answer questions and share ideas with other
AWdb users.

mailto:Support@LefflerSystems.com
http://www.approvedworkman.com/awdb/desktop-app#support
http://www.approvedworkman.com/forum
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3 Logging into AWdb

Follow the steps below to log in to AWdb:

1. Double click the AWdb shortcut icon on your desktop to open the Log-in dialog.

2. Type the User Name and Password for a user account. For a Trial database, use "demo" for both
the User Name and Password.

The purge sample data process provides a prompt to set up a new Admin user account.

The advanced actions of the Utilities button are discussed in the Utilities section.

For fun, update the photo on the Log-in dialog.

3. The Local Data Path field is filled in automatically. Under normal circumstances, it does not need
to be changed.

The default path would need to be changed after restoring a backup into a different folder to access it
instead of the live data.
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4. Click Log In.  In a few seconds, the Main Window opens.  The database's functionality is organized
into distinct modules which are accessible by clicking the tabs. This makes it very easy to move
from one area of functionality to another.

Several self-explanatory reminder messages could appear before the Main Window.  Read them and
understand the purpose of each before proceeding.



Chapter

4



Approved Workman Database 5.9 - User Guide22

© 2021 Leffler Systems

4 Learning the Basics

AWdb consists of different modules that work together to maintain records for an Awana program. Each
tab on the Main AWdb window represents a module. Each module has a chapter in the User Guide
explaining its functionality. This chapter collects the basic information into one place to quickly learn about
AWdb. Use the navigation tools (forward and back links, topic links, and topic navigator) to keep coming
back to this "Learning the Basics" page to continue with the next step.

Introductory Walk-through

1. Log in to the database.

2. Get familiar with the Main Window, including an overview of the different Modules.

3. After becoming familiar with AWdb, purge the sample data; then run the New Year Setup.

4. Review the Club Setup to adjust point values for the weekly attendance categories and personalize
items like Custom Field headings and Team Names.

5. Enter your church and club information so it prints on reports and can be used on order forms.

6. Review customizations under the Options tab.

7. For fun, personalize the database's look and feel with photos on the Home Page or Log-in dialog.

8. Begin entering member records.

9. Assign members to teams and assign handbooks and uniforms.

10. To convert the Trial Version to a fully registered version, purchase a license.

11. Preview reports that might be useful getting started:

Registration Forms - for clubbers or leaders; blank or pre-filled

Name Tags - with or without photos

Medical list - communicate medical conditions and allergy information with leaders

Worksheets - record attendance if no computer is available at check-in time

Detailed Handbook Status report or Check-in and Progress Report Worksheet - mark
completed sections if no computer is available for the leaders during handbook time

Household and Member ID List - get a parent's initials when picking up a clubber

Birthday list, Visitor list, and Award list - use during the closing ceremony

Clubber Contact Information - facilitate sending encouragement and birthday wishes

12. Use the Check-in Module to keep track of attendance, points,and dues.

13. Mark handbook sections as completed and pull awards.

14. Learn how to to work with the grids to generate ad-hoc reports.

15. Run the backup utility (under Admin > Database Utilities) each week to protect your data!

After learning the basics, continue to learn more!

http://www.approvedworkman.com/awdb/desktop-app/purchase
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4.1 Customizing the Database

AWdb can be customized both in the way it looks and in how it functions, such as:

Changing the “skin” and the tab positions

Replacing the sample photos on the Log-in dialog and Home Page

Adjusting options and setting defaults in The Admin Module

4.1.1 Choosing a Database Skin

  A “skin” is a collection of style settings that affect the look and feel of the AWdb windows.  Each skin
has a different color scheme and might slightly alter the proportions of tabs, buttons, and text.

Most of the screen-captures in this manual use the "London Liquid Sky" style.

To change the skin, select View > Style from the Main Window's menu bar.  A submenu opens with a
list of all the styles.  Select a style. The look and feel of AWdb will be immediately updated.

4.1.2 Choosing the Main Window's Tab Position

  The Main Window’s tabs can be displayed along the top or bottom, or along the left or right side.

The default tab position is a horizontal row at the top of the Main Window. 
Most of the screen-captures in this manual show the tabs along the left side.

To change the tab position, select View > Tab position from the Main Window's menu bar.  Select a
tab position from the submenu. AWdb will be immediately updated.
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4.1.3 Screenshot Examples

"McSkin" with Tabs on Left

 "Spring" with Tabs on Top
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"Coffee" with Tabs on Right

"Stardust" with Tabs on Bottom
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4.2 Entering Clubbers and Leaders

Purge the sample data before beginning to enter live member data. To create a new member (Clubber or
Leader), use one of the following to open the Member Window:

Main Window's File menu: New > Member menu item

Clubbers Module toolbar: New Clubber button

Leaders Module toolbar: New Leader button

Member Window toolbar: New Member or New in Household button

Check-in Module toolbar: New Member button

Start at the top of the Member section and begin entering data. Some fields are automatically filled in as
data is entered (i.e. selecting a Title fills in the Gender; entering a Birth Date calculates the Age and
Grade. With gender and grade, a Club Name is assigned.)

It is generally easier to Assign a team from the main Clubbers list for multiple members at once.

4.2.1 Entering Contact Info

  Capturing contact information such as phone numbers and e-mail addresses for members facilitates
communication.  This information is entered for the entire household. To create a new contact record,
from the Main page of a member's record, use one of the following to open the E-Contacts dialog:

Toolbar: Phone/E-mail button

 Contact Info grid: double click in the grid or right click and select Open Phone/E-mail.
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Phone numbers and e-mail addresses are shared by all members of the household so only need to be
entered once. [The exception to this is if the Member Link is used, see below.]

To add a contact, click New. A blank, editable row is added to the grid.  Enter the following:

o Type - selection options are determined by Admin > Generic Lookups > Comm Types. 

AWdb can automatically add rows for specific types of communication records. Under Admin >
Generic Lookups > Comm Type, choose to "automatically add this row when creating new
members".  This is useful if certain contact information is required for all members, like an
Emergency Phone number.

o Phone number or E-mail address - phone numbers are automatically formatted. Simply type

the numbers without dashes or parentheses.

There is an option to automatically add a default area code under Admin> Options > Members.

o Member Link - links a phone or e-mail to a specific person. The link is used by the Gather E-

mail Addresses and Textible Phone Numbers tool to identify only phone numbers or addresses
associated to specific Member Types or Club Names.

o Contact Person - person associated to the contact record.

o Contact Relationship - indicates the relationship of the contact person to the member/s;

selection options are determined by Admin > Generic Lookups > Contact Relationships.

o Cell Carrier - domain to append when sending SMS text messages from an e-mail client to a

cell phone. Selection options are determined by Admin > Generic Lookups > Cell Phone
Carriers.

o OK to Text - indicates a cell phone IS textible AND permission has been given to text.

To send text messages to a cell phone through e-mail, the carrier must be known.  When
requesting permission to send messages, also ask for the carrier.

o Primary - one phone number and one e-mail address for the household to use in the Clubber,

Leader, and Household Lists.

o Private - indicates the record will not be printed on any formal report.

To remove a contact from the list, select a row in the grid, then click the Delete button.

To show/hide information about the dialog, click the Info button.
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4.2.2 Setting Registration to Current

  The Registration current check box on the Member Window's Misc tab tracks which members
have turned in the registration forms. This field can be shown in the main Clubber list or Leader list under
the Registration header band. Select it directly on the Misc Tab or use the Register and Post a Payment
dialog or The Registration Window dialog which will mark it automatically. Use one of the following:

Clubbers Module toolbar: Action > Register and Post Payment or Action > Open
Registration Window menu items; or Begin the Registration Process button

Leaders Module toolbar: Action > Register and Post Payment menu item

Households Module toolbar: Open Registration Window button

Check-in Module toolbar: Action > Register and Post Payment menu item; or Begin the
Registration Process button

Each of the above modules also has a right click pop-up menu with registration options.

Register and Post a Payment provides a date selection to use when marking the selected member's
registration as current and allows an unapplied payment to be posted.  It sets the member's status to
"Active" and creates the fee record for annual dues (if applicable).

The Registration Window provides a single place to review member information, select members to
register, assign books and uniforms, review fees, post payments, and print registration reports.

4.2.2.1 The Register and Post a Payment Dialog

  The Register and Post a Payment dialog provides a convenient way to quickly mark one or more
members as registered and enter a payment that was made during registration.

The payment portion is disabled when invoked for more than one member.

Set the Registration Date - defaults to the Current Club Date, but can be changed.

Post an Unapplied Payment to the Household Ledger (optional) - checking the box enables
the payment options. The payment can be applied to specific fees later using the Household Ledger.
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The payors in each household are remembered and displayed in the drop-down for future use.

OK - sets Registration Current and registered date in the Member Window's Misc tab. It also
sets the Permissions-related fields (based on Admin > Options > Registration Form and Reports >
Permission Defaults), the member's Status to "Active" and creates a fee record for the Annual
Dues (if applicable).

Cancel - exits the registration process without saving it.

Use the Registration Window dialog to perform additional tasks such as editing member data, assigning
books and uniforms, or posting payments directly to fees.

4.2.2.2 The Registration Window Dialog

 The Registration Window provides a single point of access for the multiple tasks related to
registration. Review and edit household and individual member information, select members to register,
assign books and uniforms, review fees, post payments, and print registration related reports.

Step 1: Review Household and Member Info

Step 1 is divided into three sections: Household, Contact Info and the Individual Member section.

Household - current household information is shown and can be edited directly.

Contact Info - current contact information is shown. To add/edit/delete contacts, double click a
row to open the E-Contacts dialog.
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Individual Member - separate tabs for Clubbers and Leaders.  Each tab has two read-only grids
that provide information useful when registering members. To make changes, open the Member
Window by double clicking on a row or using the Open Member button on the toolbar. Update
information, then Save and Close the member record to return to the Registration Window.

Icon Action Description

Registration
Date

The date defaults to the current club date but can be changed.

Show Filters the data in the grid based on Status. Select the boxes in the
drop-down list to indicate the status(es) to display.

Open Member Opens the selected member in the Member Window.  (Pressing the
Enter key with a row selected or double clicking the row also opens
the member record.)

New Clubber (in
this Household)

Opens a new member form pre-filled with the selected household's
information.

Assign Handbook Opens the Assign Handbook dialog to assign a new handbook to the
selected member.

Assign Uniform Opens the Assign Uniform dialog to assign a new uniform to the
selected member.

Register - sets Registration Current and registered date in the Member Window's Misc
tab when the record is saved. It also sets the Permissions-related fields, the member's Status
to "Active" and creates a fee for the Annual Dues (if applicable).

Review Club Assignment, Current Book Assignment and Current Uniform. If new items are
needed, use the buttons above the grid to open the appropriate assignment dialog.
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Step 2: Review Fees and Post Payments

Step 2 shows the Household Ledger. See the Household Ledger section for additional information.

Review fees that were created automatically. Use the New Fee button to add additional items.  Post
payments, then print a Household Account Statement or a Household Registration Form.  The
registration form includes an option to "Display a summary of Fees and Payments in the Office Use
area" to use it as a receipt of payment or a bill for an unpaid amount.

Icon Action Description

Save and Close Saves the changes and then closes the Registration window.

Print the
Household
Account
Statement

Opens the Household Account Statement report dialog for the
selected household.

Print the
Household
Registration Form

Opens the Registration Form report dialog for the selected
household.

Refresh Refreshes the data in the window.

Stay on Top Toggles whether or not the window stays on top of the main window.
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4.2.3 Assigning Handbooks

  Each active and visiting clubber should have at least one handbook assigned. (Visitors should be
assigned an entrance booklet based on grade.) When initially adding clubbers to the database, assign
completed handbooks for historical purposes and then mark each as Done. See the Member Window's
Handbooks page for more details on managing handbooks.

When adding a visitor during a club night, the easiest way to assign an entrance booklet is to check
Prompt to Assign an Entrance Booklet at the bottom of the Add a Visitor dialog which opens the
Assign Handbooks dialog when the Add a Visitor dialog is saved and closed.

The Assign Handbooks dialog can be invoked as follows:

Member Window > Handbooks tab toolbar: Assign Handbook button

Clubbers Module toolbar: Action > Assign Handbook menu item

Handbooks can be assigned using the multi-select ability on the clubber or check-in grid.

Check-in Module toolbar: Assign Handbook button or Action > Assign Handbook menu item

Registration Window, Step 1 grid toolbar: Assign Handbook button

Choosing Yes when prompted to assign the next handbook after a clubber completes a book.

Each of the above modules also has a right click pop-up menu option to Assign Handbook.

Display Options - filter selections for the list of handbooks shown in the grid. By default, only
books used by the current club and marked as In Use in the Inventory Item Window are displayed.

Translation - further filters the list of handbooks in the grid based on the translation.  This defaults
to the individual's Preferred Translation.
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Set the default translation under Admin > Options > Misc.  This default translation is used when a
new member is created. The individual's Preferred Translation can be changed on the Misc tab of
the Member Window. The individual preference is what is used on the Assign Handbooks dialog.

While most handbooks are available in all of the translations, there are some exceptions.  If the book
isn't initially displayed, try selecting the (All) option.

Actions - determine additional steps taken when assigning this handbook.

o Create a Fee record for each book assigned

o Mark each book as having been received (if a fee is created)

o Reduce the Inventory Qty in Stock for each book assigned (do NOT check when entering

historical data)

Change the default settings for the actions under Admin > Options > Misc.

Select - the handbook to assign by clicking on the record.

Set this book as:

o The Primary book - indicates this is the clubber's main book. (A Primary book will also be

marked as a Current book.)  If the clubber will work in the book, but it is NOT the main book,
clear this box.

o A Current book - indicates the clubber is working in the book. A book may be current without it

being primary. (For example, a separate Bible reading plan begin completed in addition to the
main handbook for Trek or Journey.)

These check boxes are helpful at the start of the club year when assigning both entrance books and
main handbooks.

Handbooks already assigned - for reference only; the list of handbooks to select for assignment
will not include books already assigned.

OK - adds the book to the member's Handbook list and completes any selected actions.

Cancel - exits the handbook assignment dialog without saving.

4.2.4 Assigning Uniforms

  When a clubber completes an entrance booklet, a "reminder award" is triggered indicating the
clubber is eligible for a handbook and a uniform.

The Assign Uniform dialog can be invoked in the following ways:

Member Window > Misc tab: Assign Uniform button (under Permissions and Registration)

Clubbers Module toolbar: Action > Assign Uniform menu item

Check-in Module toolbar: Assign Uniform button or Action > Assign Uniform menu item

Registration Window, Step 1 grid toolbar: Assign Uniform button

Choosing Yes when prompted to assign a uniform after a clubber completes an entrance book.
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Display Options - filter selections for the list of uniforms shown in the grid. By default, only
uniforms used by the current club and marked as In Use in the Inventory Item Window are
displayed. With the first option selected, the list is further filtered based on whether the member is
a leader, a clubber, or a Student Leader (LIT).

Actions - determine additional steps taken when assigning this uniform.

o Create a Fee record for each uniform assigned

o Mark each uniform as having been received (if a fee is created)

o Reduce the Inventory Qty in Stock for each uniform assigned - (do NOT check when

entering historical data)

Change the default settings for the actions under Admin > Options > Misc.

OK - checks the Has Uniform box on the Member Window's Misc tab and fills in the description.

Cancel - exits the uniform assignment dialog without saving.

4.2.5 Assigning to a Team

    All clubs organize clubbers by assigning them to a specific Club Name. To group clubbers into
smaller subgroups, assign a Team Color and/or a Team Name.

Color - includes the common Awana team colors: Red, Yellow, Green and Blue.  Additionally, AWdb
provides: Purple, Silver, Aqua, Orange, Pink, Gold, Gray and Brown

Name - additional groupings with unique team names can be used in addition to the club name and
team color. Enter team names under Admin > Club Setup > Team Names. Once the team
names are created, members can be assigned to a team.

 A team's meeting location can be set when defining the Team Names. It will be displayed on the
Main tab of the Member Window as well as in the the Clubber, Leader or Check-in grids.



Learning the Basics 35

© 2021 Leffler Systems

Team Color and/or Team Name can be assigned in the following way:

Member Window > Main tab: Team Name or Team Color field

Clubbers Module toolbar: Action > Set Team Color or Set Team Name menu item

Leaders Module toolbar: Action > Set Team Color or Set Team Name menu item

Check-in Module toolbar: Action > Set Team Name menu item

The quickest way to set the Team Color and/or Team Name for multiple clubbers/leaders is by using the 
Clubbers , Leaders or Check-in Module.  Work with the grid to show members in a way that allows easy
selection of multiple rows, then select Set Team Color or Set Team Name from the toolbar's Action drop-
down menu (or the right click pop-up menu in the grid). This will update the color or name for all selected
members.

If the team colors are changed each week, there are also options to Clear all Team Colors for this week and
Reset all Team Colors for this week from the toolbar's Action drop-down menu (or the grid's right click
pop-up menu).

4.2.6 Managing Member Photos

  Member photos are especially helpful in large clubs where it might be hard to remember names. 
There are several reports that can use the photos, plus photos are displayed whenever the Member
Window is opened.  The Photo Manager provides an easy way to review and load photos for any member
in the database.  It can be invoked from the:

Main Window Tools menu: Tools > Manage Photos menu item

Member Window: on the toolbar, View/Edit the Photo(s) button; or Double click on the photo

Clubbers Module toolbar: View/Edit the Photo(s) button; Action > View/Edit the Photo(s)
menu item

Leaders Module toolbar: View/Edit the Photo(s) button

Check-in Module toolbar: View/Edit the Photo(s) button; Action > View/Edit the Photos(s)
menu item

Each of the above modules also has a right click pop-up menu that includes View/Edit the Photos(s). 
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Select a member's name in the grid on the left.  If a Photo exists it is displayed in the frame.

Manipulate this grid as explained in Working with Grids.

Multiple photos can be saved for each member.  Normally, there would be one for each year, but there is
nothing to prevent having more.  Select the photo to display in the Member Window by marking it as 
Primary. If there are multiple photos for a member, click the left and right arrows beneath the photo to
see all of the photos stored for the selected member, sorted by the photo's date.

To add a new photo: click Plus (+) beneath the photo.  This puts an empty placeholder in the photo
frame, then use one of the following:

Right click on the empty frame and select Load... from the pop-up menu.  Locate and select the
photo file for the selected clubber, then click Open. This works well if you have photos of each
clubber (such as "head shots") in external files.

if you have a photo of a group of clubbers, open it in photo editing software. Select and copy the
clubber's face, then right click and select Paste from the pop-up menu.
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Icon Action Description

Close Closes the Photo Manager without saving current changes.

Save and Close Saves the changes and then closes the Photo Manager.

Save Saves the changes and leaves the Photo Manager open.

Open Member
and Close

Opens the Member Window for the selected member and closes the
Photo Manager.

New Photo Adds a new photo to the selected member. [Functions the same as the 
Plus (+) button beneath the photo.]

Resize Resizes the member's photo if it is larger than the frame. This saves
storage space and improves performance.

Resize All Resizes all of the photos as needed.

Undo Cancels the last change.

Delete Photo Removes the current photo.  [Functions the same as the Minus (-)
button beneath the photo.]

4.3 Basic Check-In

The Check-in Module includes the functionality most used on a club night. It is the data entry screen for
all of the attendance, dues, and handbook information.  It calculates points and triggers awards. This
section provides basic information about checking in clubbers and leaders on a club night. For more
details, see The Check-in Module.

To begin, make sure the Club Date is set correctly on the Main Window, then:

1. Click the Check-in tab to display the large grid of leaders and/or clubbers.

2. Click on a member’s row.  Mark the check boxes for the various items related to Attendance, Dues,
Offering, Miscellaneous, and Visitors. 

As check boxes are marked, the Points column shows the automatically calculated total points earned.
The "Other" cell allows typing in a positive or negative number to add or subtract points (for example,
rewarding good behavior or disciplining bad behavior, respectively).

For quicker data entry, select multiple members and use the Action drop-down or right click pop-up
menu option of Set Attendance > Present/Not Present  to mark (or clear) attendance for a group. 
Filtering, sorting and/or grouping the records first will help with selections.

Use the Speed Check (the double checkmark icon on the toolbar) option to mark additional items

when the attendance box is marked. Set preferences under Admin > Options  > Check-In.
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Attend - indicate Club and Church (Sunday School) attendance as well as Excuse Club and Church
attendance.

The display name for the Church/SS attendance column can be customized under Admin > Club
Setup > Custom Fields.

Dues  - indicate dues were Paid.  When the box is checked, the Amt Pd value is populated with
the default weekly dues amount. If an amount is paid that is different from the normal weekly dues
amount, type over the value in the Amt Pd field to indicate the actual amount received.

Only money paid for DUES should be entered in the Dues Amt Pd field.  These amounts are
automatically entered as a cash payment for the DUES FEE on the Household Ledger.  To enter a
payment for anything other than Dues, open the Household Ledger to record the payment.

Offering - Amount of money given that is not for dues or other fees.  Money collected for
offerings is credited to the Offering Fund designated for the selected week and club. These
designations are set under Admin > Club Setup > Club Calendars. There can be different
Offering Funds for each club and the fund can be changed from week to week. A Donation record
is automatically created for money entered here as an offering.

Miscellaneous - indicate if a member wore a uniform, brought a Bible or handbook, or earned the
bonus (such as participating in a theme night).

Two additional check boxes can be customized under Admin > Club Setup > Custom Fields.
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Visitors - Yes is automatically marked and the # of visitors is calculated based on visitors added
for the selected member using the Add a Visitor button in the toolbar above the grid.

Handbook Sections grid - the right side of the Check-in screen shows the details of the clubber's
current handbook(s) to track completed sections. When the Done box is checked the Date of
completion defaults to the Current Club Date, but can be changed if needed. Awards earned by
completing the section(s) are triggered automatically and a message is displayed.

For quicker data entry for clubs that all work on the same section, like Cubbies or T&T, select multiple
members that all completed the same section and then mark the section completed.  All of the
selected members' handbooks will be updated.

Status bar -  located below the grid, it provides information for the selected member including
the registration date, attendance ratio, and the Household Balance. Click on the Household
Balance information to open the Household Ledger for more details.  There is also a check box to
indicate AWdb should "Suppress Award Messages".

For more information about suppression of award messages, see the section on creating and
assigning Awards.

4.4 Adding a Visitor

  Visitors can be added to the database from one of the following:

Check-in Module toolbar: Add a Visitor button

Member Window toolbar:  Add a Visitor button

Member Window's Misc tab, lower Visitor Information grid (labeled "The following Visitors were
Guests of..."): Add a Visitor right click pop-up menu item

Using any of these actions opens the Add a Visitor dialog:
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Identify the visitor as being a guest of... - indicates the visitor was brought by a member and
provides a drop-down list of names. It defaults to checked and uses the member that was selected
when the dialog was opened as the member who brought the visitor. A different member can be
selected. For a visitor who comes without being brought by a member, clear the box. 

The visitor is not currently / is already in the database - provides the option to add a
member record for a first time visitor (not in the database) or give a member credit for bringing a
guest a second time (already in the database). When the visitor is in the database, the adjacent
drop-down list of members is enabled. The Visitor Info fields are then filled in automatically.

Date Visited - defaults to the current club date, but can be changed.

The Visitor Info - same as information entered for a new member. See the Member Window's
Main tab for more details.

Entering a Title will select the Gender automatically.  Entering a Birth Date calculates the Age and
derives the Grade.  With the Grade and Gender, AWdb will automatically set the Club Assigned field.

In the lower left of the dialog, choose Prompt to Assign an Entrance Booklet when the dialog closes.

4.5 Working with Dues

Details and settings for working with dues are found throughout AWdb. This section provides an overview
of how to assign dues amounts, mark dues as paid, and record payments for annual dues fees.

Assigning Dues Amounts

Although perhaps not common, it is possible for each club to charge different amounts for dues. For
example, Nursery might have zero dues, Sparks $12/year, and T&T $15/year. Also, clubbers might pay
dues once for the entire year or pay a little each week. AWdb can accommodate a variety of ways to
handle dues.

To assign the amount of money each clubber should pay for dues:

1. On the Main Window, click Admin > Club Setup > Club Names, Logos, Dues and Points.  In
the grid, there are two rows which deal with dues assignments for each club.

2. Enter the Weekly Dues Amount for each club and the Annual Dues Amount.

The weekly dues amount is used when the Dues Pd check box is marked on the Check-in grid.

The annual dues amount determines the amount of the dues fee created when a clubber is 
registered (or a weekly dues payment is made).

Try to use values that make mathematical sense. For example, if weekly dues are $0.50 and there are 32
weeks, then the annual dues should be $16.00.
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Marking the Weekly Dues as Paid

The easiest way to mark weekly dues as paid is to use the Check-in Module as follows:

1. Make sure the Current Club Date is set correctly.

2. Check the Paid box. A CASH payment is created for the clubber in the Household Ledger. The
amount remaining is shown in the Balance column.

3. The Amt Pd defaults to the amount set for weekly dues under Admin > Club Setup > Club
Names, Logos, Dues and Points but can be changed by typing over the amount.

Making a Payment on the Annual Dues Fee

 The method described above enters a CASH payment exclusively for dues for the selected clubber. If
a payment is received to cover dues for more than one clubber, and/or it is not only for dues but also for
books and uniforms, then the payment must be entered through the Household Ledger as follows:
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1. Open the relevant family's Household Ledger.

2. Select the Payment Type (cash, check, etc), then enter the Amount, Date Received (defaults to
current club date), Reference/Check#, Payor, and Note (if desired).

3. From the Apply this payment drop-down list, select “ONLY to the fee(s) selected below”.

If more money is received than the amount needed to cover the cost of dues, select "STARTING with
the fee(s) selected below" so the remaining money goes towards other fees.

4. On the Fees tab, check the box next to the dues fee(s) to which the payment should be applied. 

Post-paid and pre-paid dues are handled automatically when a payment for Dues is posted in the
Household Ledger by updating the Dues Pd field on the Check-in screen for the appropriate number
of weeks. 

5. Click Post the Payment to apply the payment.

The Post the Payment button is enabled only after selecting one or more of the fee check boxes.

4.6 Working with Points

AWdb helps alleviate the hassle normally associated with keeping track of points for an Awana Store or
to determine team winners. Set points to be awarded for: attending club, wearing the uniform, bringing a
Bible, handbook, or a visitor, etc. AWdb does all the calculating as items and sections are marked.

Initial Setup 

Setup/review point values for attendance related items under Admin > Club Setup.

Review/modify the point values of handbook sections under Admin > Curriculum.

Total Points

During Check-in, attendance and other items are marked.  During or after handbook time, the completed
handbooks sections are marked.  At the end of the night, the total points each clubber earned can be
reviewed or compared.

There are several formal reports that provide information about member's points, such as the 
Achievement report and the Point List and Worksheet.

The Check-in grid can be used to analyze point data. Sorting, filtering and grouping the data in the grid
can identify the clubber with the highest total points within each Club, within each Team within each Club,
or which Team had the highest points; all at a glance without using a calculator!  The example below
shows grouping by Team Color.  The highlighted row shows statistics for the group.
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4.7 Working with Awards

Most awards are generated automatically as handbook sections are marked. The award that is triggered
when a section, or a group of sections, is completed is determined by the records on the Section
Groups and Awards tab of each Generic Handbook record (under Admin > Curriculum). The award
that is triggered when a book is completed is determined by the records under Admin > Awards >
Book Awards.

Award record descriptions and photos come from corresponding Inventory Items.  An Inventory item is
listed as an award option when Use this item as a choice in any AWARD related drop-down list is
selected on the Club Usage tab of the Inventory Item window. AWdb is initially configured to use the
section and book awards suggested by Awana Clubs International.  However, for clubs that choose to use
different awards, AWdb allows adding items to the Inventory records so those items are available to use
as awards.

This section covers the basic information related to awards.  See the Awards Module for more details.

Creating and Assigning Awards

When sections are marked as completed, either from the Check-in Module or the Member Window's
Handbooks tab, awards are automatically created and assigned to a member.  When a section or book is
completed that triggers an award, the Award Message dialog opens.
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Award Name - description from the Inventory record. A different award can be selected.

Received - indicates the award was given to the clubber; defaults as set up under Admin >
Options > Misc, but can be changed.

If the award is pulled and either given to the clubber or labeled for the clubber, mark it as received.  If
awards are pulled at a later time, don't mark it as received. For book awards that are handed out at the
end of the year, leave them as not received. The Award List report can be run or the Awards grid
filtered to show all awards that are not yet received to easily identify those that still need to be given
out. These are suggestions.  We recommend establishing a system that is meaningful and can be
implemented consistently. 

List awards from both Ultimate Challenge books - allows selection of awards from either of
the two groups of awards associated with the UA books. To assign a different award, click the 
Award Name cell and select from the drop-down list.

For All Clubs, do not show these Award Messages any more during this session - allows
suppression of all award dialog messages. When Cubbies awards are triggered, there are additional
options that will apply to Cubbies only.

Suppression of the award messages can also be done from the Check-in Module. In the Status bar
below the grid, check the box to "Suppress Award Messages".

Suppression of the award messages does not affect the automatic triggering of the award and
creation of the award record.

Marking Awards as Received

If an award was not marked as received at the time it was generated, the easiest way to mark it
afterward is from the Awards Module grid. Select the desired record(s), then click the Rcvd button (or
use the right click pop-up menu item). When marking awards Received, set Date Rcvd to date
field defaults to the current club date, but can be changed if needed before clicking the Rcvd button.

Mark multiple award records as received all at once by multi-selecting records.
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4.8 Working with Grids

Grids are found throughout AWdb. They are very powerful. Data entry can be conducted more efficiently
and data can be quickly and easily analyzed by sorting, selecting which columns are visible, filtering,
grouping, and searching, as well as printing, and exporting data. It is important to understand how to
customize a grid to maximize the use of all of the grids in AWdb.

The following grid related buttons and menu items appear on many toolbars throughout AWdb:

Icon Action Description

Refresh Grid Refreshes the data in the grid. This is especially important
when AWdb is run over a network where other users might
have updated records. If there is a concern about viewing the
latest data, simply click this button.

Print Preview Grid Displays a preview screen of the data currently in the grid. This
then allows printing the grid data.

Expand All Rows Expands all of the rows when a grid is grouped or has multiple
levels of information.

Collapse All Rows Collapses all of the rows when a grid is grouped or has
multiple levels of information.

Grid Options Access to other grid related options by a drop-down menu.

Selecting multiple records

Many girds allow selecting multiple rows before performing an action. Once the rows are selected,
choose an action item or button on the toolbar that will then be applied to all selected rows. Use the
following to select multiple records:

Contiguous rows: click on a row, then use SHIFT+Click on another row.  All of the rows in between
will be selected.

Non-contiguous rows: click on a row, then use CTRL+Click on any other row(s). The additional rows
will be added to the selection.

All rows: click on a row, then use CTRL+A. All of the rows in the grid will be selected.

4.8.1 Sorting

Clicking on a column header sorts the data in the grid based on that column. One click sorts in ascending
order. Clicking again on the same column sorts it in descending order. A triangle appears in the column
header to indicate it is sorted and the sort order (up for ascending and down for descending).
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Data can be sorted on more than one column at a time. To create an additional sort, hold down the Shift
Key while clicking in a second column header. For example, to see how the Sparks Teams are
progressing in their handbooks: on the Clubbers grid, click the Club Name column header, then hold
down the Shift Key and click the Team Color and then the % Completed headers. Each Sparks team is
together ordered by the % completed in the handbook.

Sorting leaves all the rows of data in the grid. To limit the records in the grid, apply a filter.

If you always sort the same way, save the grid layout with the sorting options.

4.8.2 Customizing Visible Columns

Choosing which columns are visible helps reduce or eliminate horizontal scrolling and removes visual
clutter so only the desired data is shown. 

Save the layout with the preferred columns so AWdb uses that selection as the default. Temporarily hide
columns to create an ad-hoc report; then when finished, quickly restore the last saved layout.

Setting a Column's Visibility

Some grids have two header rows, such as the Clubbers and Check-in grids. The top one is a header
band. It is a parent container for individual columns below it.

There are two ways to update the visibility of a column:

1. Set the visibility of the Column Header Band for the associated column. Click the  button to the
far left of the header bands.  In the list, check the box to show a header band. Clear the box to hide
it. Example: in the Clubbers Module, the Person ID, Filing Name, First Name, Last Name, and
Preferred Name columns are associated with the Name header band. If the Name header band is
hidden, the listed columns will also be hidden.
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2. Set the visibility of the Column Header (the label above each column.) Click the  button to the
far left of the headers. In the list, check the box to show a column. Clear the box to hide it.

Moving Visible Bands and Columns

Besides controlling which columns are visible, columns can be rearranged.  An entire band can be moved,
or a column can be moved within the band.  Drag a column or header band to the desired location and
drop it when the green arrows appear showing it is a valid drop location. 

The width of header bands and columns can also be adjusted. Drag the right side of a header band or a
column to adjust the width. When adjusting the width of a column, the width of the header band might
need to be adjusted first.

4.8.3 Applying a Filter

Filters selectively limit the rows that are displayed in the grid. Narrowing down the data helps in viewing
pertinent information at a glance while disregarding more peripheral data. To apply a filter to a grid:

1. Hover over a column header. A filter menu button appears on its right side. Click on the button. A
check list of the unique values for the column is displayed.

2. Select one or more check boxes to indicate which records to display. For example, clicking "Sparks"
will show only clubbers who are in Sparks. Clicking both "Sparks" and "T&T Adventure" will show
clubbers who are in either club.

3. When finished, click out of the check list drop-down. The filter is displayed above the grid and the
rows of data showing in the grid are adjusted.

4. To remove the filter, click the red 'X' button next to the filter display above the grid.
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Additional filters can be added by selecting another column value.  For example, to see a list of only
the Female clubbers in Sparks and T&T Adventure, click on the filter button in the Gender column
header, then use the drop-down check list to select "Female".

To temporarily disable the filter, click the check box toggle next to the filter display above the grid.

To customize the filter beyond what is available in the header drop-down menus, click the
Customize... button found on the right side of the area above the grid (when a filter is already in
use).

Some filters are so common within a Module that they are included as Show drop-down menus above
the grid.  For example, in the Check-in Module, there is a drop-down menu that allows selection to
show Clubbers, Leaders, or Clubbers & Leaders.  These Show menus are for convenience and actually
provide the same functionality as the column header filters.

4.8.4 Customizing a Filter

Any column header which contains “(Custom…)” in a drop-down menu can be customized beyond the
options available in its drop-down check list. This provides great power in filtering the grid to show only
select rows of data.  When initially creating the filter, one or two simple conditions can be specified.

To add more conditions, or to make changes to an existing filter, use the more advanced Filter Builder
tool. Filters can also be saved to use again without recreating them.  To open the advanced Filter Builder
tool, click the Grid button in the toolbar (the one with a gear) and select Custom Filter Dialog from the
drop-down menu. (Refer to Changing a Customized Filter below.)



Learning the Basics 49

© 2021 Leffler Systems

Creating a Customized Filter

1. Select the column to filter by and click the filter button to view the drop-down menu.

2. Click the (Custom…) option to open a Custom Filter window.

3. Select the operator for the condition from the top left drop-down list.

4. In the field to the right of the operator, if applicable, type the value for the condition.

5. Once this top condition is completed, either click OK to run the filter, or add another condition.

6. To set more than one condition for the filter, select the AND or OR radio button.

Using AND for the conditions will show only rows of data that meet both conditions.  Using OR for
the conditions will show all rows that meet either the first condition or the second condition.

7. Fill in the operator and value for the second condition.

8. Click OK. The filter conditions are shown above the grid and the data shown in the grid is adjusted.
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Changing a Customized Filter

  To make further changes to this customized filter (to add or remove conditions, or tweak the
existing ones), click the Customize... button in the right hand corner of the area above the grid or select
Custom Filter Dialog from the Grid menu to open the Filter Builder window.

To remove a filter condition, click the '...' button and select Remove Row from the drop-down
menu.

To add a new filter condition, either click the '...' button and select Add Condition from the drop-
down menu, or click press the button to add a new condition.

o The new row will contain a default condition that, in most cases, should be modified.

o Click on each piece of the condition to modify it.

o Either click OK to apply the filter and close the window, or click Apply to check that the filter acts

as expected, then Save it before dismissing the window.

To save the customized filter, click Save As... and then select where to save this filter, just as with
another document.

To open/reuse a saved filter, first Create a filter (see above), then use the Custom Filter... button
to open the Filter Builder window. Click the Open... button and select a saved filter.

4.8.5 Applying a Grouping

Another powerful tool for organizing and analyzing data within grids is grouping.  Grouping records can
be done using a single column or multiple columns.  It is especially useful for getting record counts for
individual groups. For example: How many Sparks are in your club?  How many of each gender are in
each grade?  Using the grouping operation provides these answers in seconds!

To save a small amount of screen space when not using the grouping feature, go to the Grid Menu  and
uncheck the option to Show Group By Box.

If grouping is possible for a grid, the area above the grid will say "Drag a column header here to group by
that column".  If that is not showing, check the Grid drop-down menu to see if it has been hidden.
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Drag a column header to use for grouping (the Check-in grid's Team Color, for example) and drop it in
the area above the grid. The data in the grid will then be grouped according to the column header.

If a desired column is not currently displayed in the grid, learn how to make it visible.

To view the individual members within the groups, click the  toggle to the left of the group to
Expand the records. Click the  toggle to Collapse the details of the group.

To add a grouping within a grouping, drag another column header up to the grouping area. (For
example, putting the Gender column under the Club Name column shows how many of each
gender are in each club.)

To disable a grouping, drag the column header anywhere outside the grouping area. When a large
black X is shown, then drop it. The column will reappear at its original location within the grid.

Dropping the column header on top of other column headers in the grid will insert the column at that
location (which might or might not be desired!)

4.8.6 Searching for Records

  There are two methods that can be used to search records within a grid:

The Search tool (available within certain Modules)

Incremental Search (available within certain columns of certain grids)

To search the entire database, use the Search tool on  the Main Window's Toolbar.

Using a Module's Search Tool

There are four modules with Search tools: Clubbers, Leaders, Check-in and Inventory. The Search tool
allows easy filtering of the grid to show only rows that match what is typed in the Search field. In the
Clubbers, Leaders and Check-in Modules, the filter works on the First, Last, or Preferred name fields.
In the Inventory Module's Item grid, it works on the Item # or Description fields. To use the tool:

1. Type the text to search for in the Search text field.

When searching for a clubber, type the surname (last), then the first name (i.e. Uppenheim, Kim).  The
search will not work if the first name then the surname is entered. (i.e. Kim Uppenheim).



Approved Workman Database 5.9 - User Guide52

© 2021 Leffler Systems

2. Press Enter or click the Perform the Search button.  All matching rows are displayed in the grid.

3. To restore the grid, clear the text from the Search tool, then press Enter or click the Perform the
Search button.

Doing an Incremental Search

Many grids allow quickly jumping to a record by typing while in the grid. The Clubbers, Leaders,
Households, Ledger, and Awards grids allow incremental searching by Last Name (but not First Name).
The Check-in grid allows incremental searching by Last Name or First Name based on which column
has focus. The Inventory grid allows incremental searching by Item #. To do an incremental search:

1. Click anywhere in a grid that has incremental searching capabilities.

On the Check-in List grid, click in the First Name column or the Last Name column.

2. Start typing either a name or an item number, depending on the grid.  The grid will scroll to the
first row that matches and the row will be selected.

3. To start a different incremental search, press Esc before typing again.

4.8.7 Printing Grids

  The Reports Module includes many useful reports. However, something different than what the
formal reports provide might be needed. In this case, the powerful features of the major grids provide
access to additional data analysis and output. To print data from a grid as an ad-hoc report:

1. Sort, customize visible columns, and apply filters or groupings to the grid. Only records visible in
expanded nodes will be printed.

2. Click the Print Preview button in the toolbar to open the Print Preview dialog.

3. Use the Format button to add a Report Title, Footnotes, Page Numbering, etc. The toolbar
also has other typical tools for managing the printer and page settings before printing the
document.

4. After making desired selections, click the Print button or use the Export to PDF button to create
an external file to attach to an e-mail.
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4.8.8 Exporting Data from Grids

  Save the grid's data to an external file format by exporting data from a grid.  Currently, the
following formats are supported: Microsoft Excel, HTML, and Text files with ' ~ ', ' | ' or ' , ' used as field
separators.  Exporting grid data could be useful to start with AWdb data and use it for something like a
mail-merge data file for MS Word, importing data into another application or generating a very specific
looking report.

To export a grid:

1. Sort, customize visible columns, and apply filters or groupings to the grid.

If groupings are applied, only those records visible in the expanded nodes will be exported.

2. Select Export...  from the Grid menu to open the Data Export dialog.

3. Select the output file format from the drop-down menu.

4. Select the folder where the exported file will be saved.

5. Either accept the default filename or enter a preferred filename to use when saving the file.

Do not add an extension to the filename since AWdb will do that.

6. Click Run.  The grid's data is exported to a file with the specified name in the specified folder.
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4.8.9 The Grid Menu

  This menu provides additional items related to the grid.

Working with Grid Layouts

Once a preferred grid setup is created, save the layout so those customizations do not have to be
repeated each time that grid is used.

Grid layouts are saved per user. Make sure each person has a unique AWdb user account so users don't
change each other's preferred settings!

From the Grid menu, use the following options to maintain the grid layouts:

Save Current Grid Layout - for the grid layout view that is typically used.  When AWdb starts, the
grid defaults to this layout.

Reset Grid Layout - return to the normal/saved layout after the grid layout is temporarily adjusted
for a specific task.

Restore Default Grid Layout - return to the layout that AWdb used when first installed.

Other Menu Items

Custom Filter Dialog... opens the Filter Builder dialog to create, modify, save or open customized
filters.

Export... starts the process of exporting a grid's data to an external file.

Grid Display

These options affect how the grid is displayed:

Show Group By Box - show/hide the grouping area displayed above the grid.

Use Alternate Grouping Style - alternate between two styles available for displaying grids with
groupings.

Use Alternate Color Scheme for Rows - use a different color scheme for alternating rows in the
grid

Use Alternate Grouping Style and Use Alternate Color Scheme for Rows options are only available
when viewing AWdb in the "Native" Style.
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5 Beyond the Basics

Besides tracking the basics like member contact information, attendance, dues, handbooks, sections and
points, AWdb can also track leader service and training, inventory, donations, household account
balances, events, contacts, and more.  This section assumes understanding of the topics covered under 
learning the basics to delve deeper into the robust features of AWdb.

1. Record service history and training events for leaders to determine if requirements have been
met. AWdb can evaluate attendance requirements to determine if a leader has attended enough
weeks to count towards a year of service.

2. Start to track Inventory by entering your club's current inventory into the database. Once it's
initialized, the inventory Quantity in Stock values can be automatically decreased as awards are
earned and books are assigned and increased as items on an Order are marked as Received.
AWdb can even automatically add items to an order when the quantity in stock gets low. For this
all to work, make sure that the Inventory Tracking options are turned on. 

3. Maintain details about orders placed with Awana Clubs International including which items have
been received or back-ordered. Although AWdb does not actually make a connection to Awana,
the completed order form makes phoning, faxing, mailing or entering the order into the Awana
website very simple.

4. Post payments for dues, uniforms, books, etc. to the applicable fees and track which items have
been received. By sorting and filtering the Ledger Module grids, totals for received payments,
amounts still outstanding, or the total cost incurred to the club for waived fees can be determined.

5. Periodically print Household Account Statements to remind members of the total balance for the
items they have received. The statement is customizable, so you can give contact information or
information about possible scholarships. Specific Household Account Statements can be printed
directly from any family's Household Ledger.

6. Use the Offering field of the Check-in grid or the Donations Module to keep track of extra money
that is given for any reason. The names of the accounts to which donations can be made can be
customized. If a donation earned an award, that can be indicated.

7. Enter a record in the Contacts Module when a leader sends a postcard, makes a phone call or
otherwise contacts a clubber.

8. Use the Events Module to track members who attended events and if an award was earned. This
is handy for Bible Quizzing and Awana Games participants, for example.

There are often multiple ways to perform the same action. For example, new records can be created
using the File > New menu, by using a New button on a toolbar, or pressing Ctrl+N within appropriate
grids. Also, a record can be opened using the Open button, double clicking a row in a grid, using the
right click pop-up menu, or by pressing the Enter key or the Ctrl-O keys while a row is selected. It is not
important to know ALL of the ways to perform an action, just the technique that makes sense for you!
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5.1 The Main Window

AWdb's functionality is organized into distinct modules which are accessible by clicking the Main Window's
tabs (Clubbers, Leaders, Households, Check-in, etc.). This makes it very easy to navigate and move from
one area of functionality to another.  The Main Window also contains the Main Menu bar, Toolbar and
Status bar. Features on each of these can be accessed from any module.

The Menu Bar

Provides access to common menu functions such as File, View, Tools, Window, and Help.

Displays the Current User, the Current Date and the type of Database (Primary or Secondary).
 If clubs are checked out, those are listed.

The Toolbar

Provides quick access to any Clubber or Leader record by using the Search Members field. Type a
few characters of a member's first or last name and press Enter.

Displays a count of Open Windows. Switch to any open window by using the drop-down list. 

Displays the Current Club Year and Current Club Date as well as providing drop-down lists to
change the selections.

Displays the Current Week Number (and "last week of quarter", if applicable).

The Status Bar

Displays Version information, the Path to the current data, and a progress bar when needed.



Approved Workman Database 5.9 - User Guide58

© 2021 Leffler Systems

5.1.1 The File Menu

The following items are included in the Main Window's File menu:

Icon Action Description

New Opens the relevant dialog with blank/default values to create a new record.

Close All Closes all open windows.

Switch Users Logs out the current user and provides a log-in screen for another user to
log in without exiting the database.

Exit (Ctrl+Q) Shuts down the database.

5.1.2 The Tools Menu

The following items are included in the Main Window's Tools menu.

Icon Action Description

Attendance
Awards

Generates church and club attendance awards.

Club Store Provides a tool to manage Club Store tasks such as looking up
accumulated points and entering points spent.

Gather E-mail
Addresses... 

Collects e-mail addresses or textible phone numbers based on selection
criteria.

Inventory Quick
Reference

Provides a resource to quickly search for an inventory item that is "In
Use".

Manage Photos Provides a way to work with the photos for all members.

Recalculate Total
Points

Recalculates the total number of points and Required and Extra Credit
sections for all members or a specific member.

Show Users.. Displays a list of all users that are currently logged in to the database.

Invoke Maint.
Mode

Sends a message to all users and forces them to log off within 5
minutes so maintenance can be performed on the database.

Change
Password

Allows the current password to be changed to a new one.

Show OS Version Displays the version number of the computer's Operating System.
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5.1.2.1 Attendance Awards

 On the last week of each quarter or semester, a reminder to generate Club and SS/Church
Attendance Awards is triggered. Use the Attendance Awards procedure to easily do this, as follows:

The awards are generated based on the settings under Admin > Awards > Attendance Awards.

1. Select Tools > Attendance Awards from the Main Window's menubar.

2. Set the Selection Criteria - select values for: Member Type, and Club Quarter. The Club Year
shows the Current Club Year from the Main Toolbar and is read-only.

3. Set the following values for all new records:

Date Earned - defaults to the current week, but can be changed.

Award Received - indicates if the awards should be marked as being Received by the
members when the award is created. Checking the box enables the date Received field.

If not marking awards as received, easily mark them as received later from the Awards module.

4. Click Generate Awards. Awards are created for members that meet the criteria. Names are
shown in the Award Recipients area. Message dialogs indicate the number of recipients and the
number of records created.

The procedure will not generate duplicate awards even if it is run multiple times.

Excused absences:  To review attendance for a member, open the individual Member record and look
at the Attendance tab. To excuse an absence, make Attend Excused and SS Attend Excused columns
visible (they are normally hidden).  Check the box to excuse attendance, then rerun the procedure.
Attendance can also be excused from the Check-in grid.

5. Click Award List Report if a formal report is desired and Close when finished.
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5.1.2.2 Club Store

  Use this tool to see how many points a clubber has to spend and to deduct points that are spent, as
follows:

The Point List and Worksheet can be used for reference and to track points spent for later data entry.

1. Select Tools > Club Store from the Main Window's Menu bar.

2. Set the Club Date when points spent. It defaults to the current club date, but can be changed.

3. Use the Show: drop-down lists to filter by Status, Member Type and/or Club. The grid can also
be manipulated as explained in working with grids.

4. Select a clubber in the grid on the left. The clubber's information will be shown on the right.

5. Enter the Item Point Cost (or total points spent) for the items purchased.

6. Press Enter or click Sale. The clubber's Net Points are decreased and Points Spent are
increased. Click Void (reset) to revert to the original Net Points with zero Points Spent.

The following common functions can be accessed using buttons on the window's toolbar:

Open Clubber - opens the Member Window for the selected clubber to get more details

Options - choose to Set focus to Item Point Cost after selecting clubber, and/or Set focus
back to the grid after pressing Enter

Stay On Top - a toggle button that is either selected or not. When it is selected, the Club Store
window remains in front of the Main Window. When not selected, use the Window menu or the
Window Manager list in the Main Window's toolbar to return the hidden window to the front.
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5.1.2.3 Gather E-mail Addresses and Textible Phone Numbers

  Use this tool to gather e-mail addresses or textible phone numbers (that are converted to e-mail
addresses). The carrier domain name is appended to each textible phone number. The results can be
copied to clipboard memory, then pasted into the BCC field of an e-mail client. To use the Gather E-mail
Addresses and Textible Phone Numbers tool:

1. Select Tools > Gather E-Mail Addresses...... from the Main Window's Menu bar.

2. Set the Selection Criteria:

E-mail Addresses or Textible Phone Numbers

If selecting from Textible Phone Numbers, the Carrier name must be known and only numbers
marked as "Ok to Text" are considered.  See the E-Contacts dialog for more details.

Household Status or Club Name, Member Type, Member Status, and/or Member Code

For selection based on Club Name, etc, a Member Link must exist on the Phone/E-mail dialog.

Choose to Insert a blank line and set the number to include in each group.

3. Click Run. The results are displayed in the E-mail Addresses/Textible Phone Numbers area.

4. Choose Copy All to Clipboard or select a group and choose Cut Selection to Clipboard or Copy
Selection to Clipboard. Switch to an e-mail client and Paste.

Do NOT paste all the addresses into the To: field; instead, paste them into the BCC: field.

The preferred type of e-mail separator can be set for each user under Admin > Users.
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5. Click Close when finished.

E-mail addresses or textible phone numbers can also be collected from the Clubbers or Leaders grids. Turn
on Calculations to populate the Primary E-mail column and filter as desired. Multi-select rows and use
Action > Copy E-mail Addresses or Copy Textible Phone Numbers.

5.1.2.4 Inventory Quick Reference

  Use this tool to quickly find an Inventory Item.

To use the Inventory Quick Reference tool:

1. Select Tools > Inventory Quick Reference on the Main Window's Menu bar.

2. In the Search box, type a few characters from the Description, such as "unif" for uniforms, or "bag"
for handbook bags. Matching records are shown in the list. To make it even easier to find favorite
items, add a Note (like "club favorite!") to the Inventory Item records.

3. Once the particular item is located, use the right click pop-up menu to Copy the Item Number, Copy
the Description or Open the Inventory Item

The Inventory Quick Reference dialog can be re-sized so it is narrow.  Also, it is not modal, so it can be
moved over to the side and left open while continuing to work on other screens.

When opened from the Search button on the Fee dialog, Select and Cancel buttons are also displayed.

5.1.2.5 Recalculate Total Points

  Use this tool to recalculate Total Points and the number of Required and Extra Credit Sections
completed for each member for each week in the selected Club Year. It also updates the Home page's
Club Calendar Statistics. It is automatically invoked after modifying handbook section point values. If
glitches occur during data entry, it is possible that calculations in memory might not be posted correctly.
This provides a way to be sure all records are correct.
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Only members with a status of Active or Visitor will be included in the recalculations.

It is best to run it when no other users are logged in. If (All Members) is selected it can take a minute to
finish.

5.1.2.6 Invoke Maintenance Mode

  This feature applies only to those who are running AWdb over a local area network, or who have
been set up with Remote Desktop access and therefore the possibility of multiple users being logged in
simultaneously exists.  For users with a single-user license, or with multiple licenses but are not
operating over a LAN this topic is not applicable.

Those with Administrator permission will see the Tools > Invoke the Maintenance Mode menu item.
Users with a normal "User" account will not see this menu item.  Before performing some maintenance
operations such as applying an update or running the Backup, Restore, Repair or Optimization utilities,
first select Tools > Invoke Maintenance Mode to force everyone else to log out before proceeding
with the maintenance.  The following confirmation dialog gives an explanation of what will take place:
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Any user who is logged in when maintenance mode is invoked will get a pop-up message (within about 1
minute) saying that the database must be temporarily shut down for maintenance and to save any work
and exit. Here is an example of the message:

No other users will be able to log in while the administrator who invoked maintenance mode is logged in.
A user that tries to log in will get a message explaining that maintenance is underway and to wait a few
minutes to try again.

Once maintenance operations are completed, the Maintenance Mode should be released using the same
tool.  When the Admin who invoked the Maintenance Mode logs out, the Maintenance Mode is
automatically released. Therefore, if an update needs to be applied, it should be done immediately after
logging out.

5.1.3 The Help Menu

The following items are included in the Main Window's Help menu.

Icon Action Description

User Guide Opens the AWdb User Guide located in the Approved Workman
folder.

Online User Guide Links to the online User Guide. An internet connection is needed.

Download User
Guide

Links to the support page of the Approved Workman website to
access a download of a PDF version of the latest User Guide.

License Info Opens the license information including Customer ID and number of
licenses.

Check for Updates Begins the process of checking for updates for the database.

Approved
Workman Forum

Links to the Forum which is an excellent place to get questions
answered and see how others use AWdb.

Approved
Workman Website

Links to the home page of the Approved Workman website.

Remote Support
Portal

Links to the remote support portal to connect with Customer Support
for scheduled remote sessions so a support team representative can
view your machine to answer questions or troubleshoot problems.

About... Provides a bit of information about AWdb.

http://www.approvedworkman.com/awdb/desktop-app#support
http://www.approvedworkman.com/forum
http://www.approvedworkman.com
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5.1.4 The Toolbar

Search Members

 Use this tool to quickly locate and open a member from anywhere in AWdb. It is located on the left
side of the Main Window's toolbar and is available from any module. To use the Search Members tool:

1. Type a few characters of the first or last name of any member in the Search Members text box.

2. Press Enter or click the Perform Search button. If a single member matches the criteria, that
member's record is opened in the Member window. If there are multiple matches, the Select A
Member dialog opens showing all members whose first or last names contain the entered text.

3. If the desired member is listed, open the member record by double clicking or selecting the name
and clicking OK.  If there are still many names displayed, narrow the list by continuing to type in the 
Search for Filing Names that contain: field. The list will update as characters are typed.

4. Click Cancel to discontinue the search without selecting a member.

Window Manager

  The following records open in separate windows and can remain open while using AWdb:
Members, Household Ledgers, Items and Orders. These windows are sometimes hidden by other
windows on the screen. The Window Manager drop-down menu helps navigate them easily. It shows No
files are open or [#] windows are open and lists each one in the drop-down menu. Select a window
from the list to bring it to the front of the screen.

The Main Menu bar's Window menu also lists the opened windows along with options for organizing the
windows, such as: Cascade All, Minimize All, Restore All.

Current Club Year

The Current Club Year should be set to the desired year for viewing or creating data.  Only the data
pertaining to that year is displayed throughout the database. This is normally the current calendar club
year, but to view or modify historical data, switch to a prior club year.
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Club Date

The Club Date should be set to the current date to enter data during club time. For a club date in the
past, change to the applicable date. This date is used as the default value in many modules where a date
is a required field. For example, in the Check-in Module when a handbook section is completed.

5.2 The Member Window

The Member Window provides a way to view and modify all a member's data in a single window. Multiple
Member Windows can be open at one time. Easily switch between them using the Main Window toolbar
or Window menu. Stay on Top (the red push pin) keeps a window on top of the Main Window.

There is a lot of information packed into this one window, so it is divided into tabbed pages:

Main - basic information, such as personal, household and contact information.

Misc - other useful information about the member, such as registration, permission and medical
info, visitor records, school name, etc.

Attendance - all attendance related information for each club date, such as club and church
attendance, weekly dues, offerings, etc. 

Handbooks - all handbooks assigned to the member. Manage handbooks and mark sections
complete. Review percentage completed and date completed for each handbook.

Awards - all awards earned by the member. Open, delete, or create awards (most awards are
created automatically when marking sections complete) as well as set the received status.

Events - all events attended by the member. Open, delete, or create new event records.
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Contacts - all records of contacts made with the member. Open, delete, or create contact records.

Fees - all fees for the member. Open, delete, or create new fee records.

Fees for Dues are created automatically when Registration is set to "Current".  Fees can be set to be
created automatically when assigning a book or a uniform.

Donations - all donations for the member.  Open, delete, or create donation records.

5.2.1 The Toolbar

The Member Window's main toolbar provides buttons for the most common functionality. Other toolbars
might appear in the tabbed pages for additional functionality for the selected page.

The table below describes what each button on the toolbar does.

Icon Action Description

Close Closes the Member window without saving current changes.

Save and
Close

Saves the changes and then closes the Member window.

Save Saves the changes and leaves the Member window open.

New Member Opens the Member Window with blank/default values to create a new
member (clubber or leader).

New in Hh Opens the Member Window with some pre-filled values to create a new
member (clubber or leader) in the selected household. This is the most
efficient way to add members to an existing household.

Assign to Hh Assigns the selected member to a different household based on selection
from a list of all households.

Delete
Member

Removes the current member and closes the window. This process
requires a confirmation.

Open E-
Contacts

Opens the E-Contacts dialog to enter contact information for the
household.

Add a Visitor Opens the Add a Visitor dialog to add a visitor brought by the current
member.

View/Edit
Photos

Opens the Photo dialog to manage photos.  Defaults to the current
member.

Open
Household
Ledger

Opens the Household Ledger for the selected member's family to manage
fees and payments.
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Icon Action Description

Begin Reg.
Process

Opens the Registration Window dialog for the member's family to manage
registration related events.

Print Member
Profile

Opens the Member Profile report dialog to print a member profile for the
current member.

Print Reg.
Form

Opens the Registration Form report dialog to print a registration form for
the selected member's family.

Refresh Refreshes the data in the window.

Stay on Top Toggles whether or not the window stays on top of the main window.

5.2.2 Main

The Main tab of the Member Window tracks basic Member, Household, and Contact information and
provides a list of Household Members.
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Member

(Optional) Member External ID - ten character text field to reference an ID from an external source
(such as other software used to track church members). To make it visible, under Admin > Options
> Members, choose "Show the external ID fields on the Member form".

The external IDs can be printed using the Household and Member ID List report.  They can also be
included on the Household List - Contact Information report. The individual external IDs can be shown
on the main Clubbers and Leaders grids by making the column visible.

Member Type - Clubber or Leader.

Status - Active, Archived, Graduated, Inactive, Prospect or Visitor. Setting a member's status
is useful when filtering grids to show only selected members.

Title - selection options are determined by Admin > Generic Lookups > Titles.  Selecting a gender
specific title automatically sets the Gender field.

First Name, Last Name, Suffix, Nickname, Preferred - self explanatory! 

Pronunciation - text box for a phonetic spelling of a difficult-to-pronounce name.

Mailing Name - filled automatically as other name fields are completed, but can be edited. Choose to
"Use a member's Title when deriving the Mailing Name" under Admin > Options > Members.

Photo - displays the primary photo. Multiple photos can be kept for a member. Use the navigation
buttons below the frame to view other photos or add a photo.

Double click the frame to open the Photo Manager for more photo options.

Birth Date - Age will be calculated and is read-only.

Grade - calculated using the birth date, but can be selected manually or changed if needed.

Gender - set automatically if a gender specific title is used, but can be selected manually.

Code - five character text field to discretely categorize or tag members. Any unique codes can be
used, but it is important for leaders to know what they mean. For example:

"M" to indicate there are medical issues

"B" to represent all clubbers who come with the bus ministry

"L" to represent someone in law enforcement (leaders obviously) that could be called on if there
was a security concern

In addition to being a column on the main Clubber grid, it is used on many Report dialogs to enhance
selection criteria. It can optionally be printed on the Name Tags.

Club Name - automatically assigned based on grade and gender, but can be selected manually.
Selection options are determined by Admin > Club Setup > Club Names, Logos, Dues and Points.

Try to always enter a Title and Birth Date. Selecting "Miss" or "Mr" derives the Gender.  A Birth Date
calculates the Age, which then derives the Grade. With Grade and Gender, Club Assignment is made.

Team Name - selection options are determined by Admin > Club Setup > Team Names.

Team Color - twelve colors are provided (or select None to indicate no team color).
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Clubber Specific Fields

The following fields are only visible if the Member Type is set to Clubber:

Club Loc - read-only field displaying where the club meets as set up under Admin > Club Setup
> Club Names, Logos, Dues & Points.

Team Loc - read-only field displaying where the team meets as set up under  Admin > Club
Setup > Team Names.

Net Points - read-only field derived by calculating all of a members points for attendance, visitors,
sections, etc. Spent points (entered through the Club Store) are deducted from the running total.

Leader Name - selection options are based on active leaders.  Selection list shows if the leader is
an LIT, the leader's Club Name and Team Color to facilitate leader assignments.

LIT for Club - indicates a clubber who serves as a LIT (Leader in Training, or Student Leader) in
another club (such as a Trek or Journey clubber serving in Cubbies). This enables selection of a
club where the LIT serves. It also creates the following changes to the record:

adds attendance records for the new (LIT) Club

adds a Leadership tab to track leadership service roles and training.

Leader Specific Fields

If the Member Type is set to Leader, the Leadership Roles grid shows in the lower left of the
Member window and the Leadership tab is visible.
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Household

(Optional) Household External ID - ten character text field to reference an ID from an external
source (such as other software used to track church members). To make it visible, under Admin >
Options > Members choose "Show the external ID fields on the Member form".

The external IDs can be printed using the Household and Member ID List report.  They can also be
included on the Household List - Contact Information report.  The household external IDs can be shown
on the main Households grid by making the column visible.

Filing Name, Mailing Name, Parent Name(s) - filled automatically using the following defaults, but
can be edited.

Household Filing Name: Last Name followed by a dash and a list of all Preferred (First)
Names.  Example: "Green - Sandy, Michael, Tina". In households that have persons with
different last names, the last names are listed in alphabetical order, separated by "/".  Example:
for Rebecca Brown, Chad Smith and David Smith: "Brown/Smith - Rebecca, Chad, David".

To re-derive the Household Filing Name, delete the current value and TAB out of the field.

Mailing Name: Last Name + "Family".

Parent Name(s): Mr. and Mrs. + Last Name.

Address Line 1 - street address.

City, State, Zip - defaults to the City, State and Zip of your church, but can be modified.

To turn off this default, go to Admin > Options > Members.  Uncheck the box next to "Use the
Church's City, State and Postal Code as the default values when creating new members".

Also under Admin > Options > Members, choose to "Overwrite City and State values when the
Postal code changes and a match is found in the lookup table". If City, State, and Postal Code values
are specified under Admin > Generic Lookups > City, State, Zip, the City and State fields can be
skipped to type a zip code. The City and State values will then be filled in. To make this the default,
choose "When tabbing through the address fields, skip the City and State and go directly to the
Postal Code field".

Family Church - selection options are determined by Admin > Generic Lookups > Church Names.
 It defaults to your church. Selecting <new> invokes a dialog to add a new Generic Lookup value.

Select to not "Use our Church Name as the default Church Name value when creating new
members" under Admin > Options > Members.

Contact Info

Cell Phone, E-Mail, Emergency, Home Phone, etc - to add or edit contact information, double click
a row in the Contact Info grid or click the Phone/E-mail button in the Member Window toolbar.

Driving Directions - opens a dialog with a text box to track directions. Click Print Preview for a
formatted report that includes contact information. This can be useful for a bus ministry.

Persons authorized to pick up the children - name(s) of person(s) authorized to pick up the
clubber(s) from Awana. This field is only visible if the Member Type is Clubber.
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Household Members

This grid lists any other members in the database associated to the household.

To open another member's record, double click a name in the grid or use the right click pop-up menu.

To add a new Household Member, use the New in Hh button in the toolbar.

5.2.3 Misc

The Misc tab of the Member Window tracks other useful information about the member, such as
Permissions and Registration details, Medical and Visitor information, Notes and Miscellaneous items.

Permissions and Registration

Permissions - indicate consent has been given to: participate in Activities (such as Game Time),
Travel, use a Photo, or Release Medical information.  Other allows for an additional custom
permission related item.  When checked, a description can be entered.

Registration current, registered - when checked, the date field is enabled. (It defaults to the
current club date, but can be changed.)

When the member record is saved after setting the registration to current, the database ensures that the
member's status is "Active" and that a fee record exists for annual dues, if applicable.

The Registration current check box is marked automatically when using the Register and Post Payment
dialog or the Registration Window dialog.  To choose which permission related check boxes are set
automatically when the registration is set to current, go to Admin > Options > Registration Form and
Reports > Permission Defaults.
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Has uniform - if the uniform has not been earned yet, the description field can still be used to track
the size for future use. Using the Assign Uniform button opens the Assign Uniform dialog to assist in
creating a uniform fee.  It will also set the Has Uniform fields.

Updating a uniform fee's description also updates the Has Uniform text field.  Also, deleting the fee
clears the Has Uniform check box and text field.

Medical Information

Special Needs - Additional details can be entered in the memo field under the medical information
section.

Last Tetanus Shot - tracks the date.

Include on Medical List report - will list medical information along with contact information for the
member when generating the formal report.

"Allergic To" - text field. Any additional information related to allergies or other medical information
can be entered in the memo field directly below the listed allergy.

Doctor, Dentist and Insurance - text fields for doctor and dentist contact information as well as
insurance company and policy number.

For each field, the list of options in use for the family are displayed in the drop-down for easy access.

When any of these fields are changed for one member of the household, an option is given to also use
the new information for other members of the household that have the same current information.

Notes

This section provides a memo field to track any additional information for the member.

Visitor Information

This section has two grids: one for recording when this member visited and one for when this member
brought visitors. To record data, right click in a grid and select from the pop-up menu.

These grids are intended for viewing visitor/visiting history or editing existing data.  A more direct
method of creating visitor records is to click the Add Visitor button in the Check-in Module.

Miscellaneous

School Name - selection options are determined by Admin > Generic Lookups > School Names. 
Select <new> to add a new generic lookup value without switching to the Admin Module.
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Hobbies - text field.

1st Language, 2nd Language - selection options are determined by Admin > Generic Lookups >
Languages.

Date Joined - tracks when a clubber first joined.  A member's Status can change from time to time,
and the Registration Date changes for each club year; but this field doesn't change, so it allows
tracking how long a member has been involved in the club.

Flag - 6 color options. This is a custom way to categorize or "flag" particular members.  Like the Code
field on the Main tab, this provides a discreet way to identify members.  For example, a Red Flag could
be used to identify clubbers from a broken home where there might be a security concern. A Blue Flag
could be used to identify clubbers with a learning disability or behavioral problem.  Members who need
a new name tag printed, who owe money or are missing paperwork could be flagged. Note: unlike the
Code field, this field is not used on report dialogs to enhance selection criteria. The Flag column can be
made visible on the Clubber, Leader or Check-in grids.

Set flags for multiple members at once using Action > Set Flag on the Clubber or Leader grids.

Preferred Bible Translation - ESV, KJV, NIV, NKJV, Spanish; used to filter the selection list when
assigning a handbook to the member.

Christian - when checked, the Re-Birth Date and Baptism Date fields are enabled.

5.2.4 Attendance

The Attendance tab provides an overview of the member's club attendance (as well as other
attendance related items), handbook sections completed and points for each week. The attendance and
other categories are usually entered through the Check-in grid during club time, but can also be entered
or edited here. For easier data entry, maximize the window.
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As with most grids in AWdb, this grid is customizable.

When a check box is marked, the Total Points field for the selected week is adjusted according to the
points assigned under Admin > Club Setup > Clubs, Logos, Dues and Points.

This grid provides a big picture view of a clubber's entire club year. It shows the complete history of
attendance and all other categories including sections completed and points spent. There are totals for
most columns in the grid footer. Use the Preview/Print button to get a hard copy.

There is a right click pop-up menu available on this grid to help with situations where unwanted
attendance records exist. With a row selected, right click and choose one of the following:

Delete all session records in the grid

Delete all session records for (Club Name) in (Club Year)

Delete the selected session record(s).

If there are two records for each date, use the option to Select every other row, starting with this row and
then choose Delete selected session record(s).

Be cautious when using this selection.  Do not delete any records that have data entered unless you are
certain it isn't needed.  Once session records are deleted, the process cannot be reversed!

5.2.5 Handbooks

 The Handbooks tab provides an overview of all of the handbooks assigned to a member. Marking
completed sections is usually done from the Check-in grid; however, this page is useful to enter historical
information such as handbooks completed in a prior club year or sections completed on a prior club date.
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Toolbar

Besides the Member Window toolbar, there is another toolbar that is specific to the Handbooks page.

Icon Action Description

Assign Handbook Opens the Assign Handbook dialog to assign a new handbook to
the selected member.

Open Handbook Opens the generic handbook window for the selected handbook to
show details about the book and the award triggers.

Delete Handbook Removes the selected handbook from this member's records.

Open Inventory Item Opens the selected handbook's related inventory item in the 
Inventory Item Window.

Entry Mode - controls what happens as sections are marked.

o Normal - points are tallied as sections are marked.  If an award is earned upon completion of a

section, it is automatically created.

o History - no point calculations and only book level awards are generated. Completed sections

must be marked one at a time. Use this when entering historical data for a small number of
sections done prior to the current club year.

o Speed - no point calculations and only book level awards are generated. Sections do not need

to be marked one at a time. Instead, simply mark the last completed section and ALL of the prior
sections are marked automatically.  Use this when entering historical data for a large number of
sections completed prior to the current club year when actual completion dates are not
significant.

use date of - the date used when a section is marked.  It defaults to the current club date, but can
easily be modified when marking sections from a different date.

Handbooks Grid

All handbooks that have been assigned to the clubber are shown along with the following information:

Current - indicates the clubber is actively working in the handbook. There can be more than one
current book (for example, a clubber might still be working on Review or Extra Credit work in
another book, or completing an unfinished book from a previous club.)  All current books are
available as a choice in the Check-in Module's Sections Grid for marking sections.

Primary - indicates the clubber's main handbook. This book is displayed in the Primary Book column
of the Clubbers and Check-in grids.

Name - of the handbook.

Award Set - available award sets for books where more than one type of award can be earned.
This determines the type of award to trigger (for example, to use up an inventory of old awards
instead of a new set to be associated with the book).
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Done - indicates a book is completed.

A handbook is normally marked as Done automatically when the last required section is completed. 
Manually select this check box only when entering historical data.  Doing so requires a confirmation
to continue and asks for a Completion Date which is used for all blank required sections of the book.
 An option to assign the next handbook is also given.  Answering "yes" invokes the Assign Handbook
dialog.

When entering historical data for BOOKS that were completed PRIOR to the current club year, do
NOT tediously mark all of the sections completed.  Instead, use the Done check box to indicate the
book was completed.  If the actual Completion Date is known, enter it.  If not, enter a date that is
PRIOR to the current club year. Otherwise, the clubber will get credit for completing the book in the
current club year.  If the exact date of completion is not known, a good rule of thumb is to select the
last date of the prior club year.

% Complete - shows the percent of required sections completed in the handbook.

Date - of completion. This defaults to the current club date when the Done check box is marked,
but can be modified.  For the clubber to get credit for completing the book during the current club
year, select a valid club date in the current club year. (See Tip under "Sections Grid" below.)

Calculate button - fills in the statistic fields below the grid for the selected handbook. This is
especially useful near the end of the club year to estimate if the clubber will be able to complete a
handbook before the end of the year.

To view this information for multiple clubbers, use the formal report "Current Handbook Status" and
select the Type of "Summary". This will help in planning an end of year award supply order.

Sections Grid

The right side of the Handbook page contains a Sections Grid which displays the sections applicable to
the selected handbook.  The Sections Completed Grid of the Check-in module is generally used to enter
sections completed during club time, but completed sections can also be entered here.

Handbook / Percent Complete - displays information about the handbook currently selected in
the main grid

Required, and Review/Extra Credit tabs - Sections in the required group must be completed to
get a book award. Sections in the review or extra credit group are optional. Click on the desired
tab to show the relevant Sections Grid:

o Section Name - description matching the section in the handbook.

o Points - amount added to the member's total when the section is marked in Normal mode.

o Done - indicates a section has been completed.

o Date - of completion for the section. This defaults to the use date of: selection in the toolbar,

but can be modified.

Notes tab - trakcs any additional details pertaining to the specific handbook for this member.

When entering historical data for SECTIONS (in an incomplete book) that were completed PRIOR to the
current club year, be sure each Completion Date is PRIOR to the current club year.  Otherwise, the clubber
will get credit for the completed sections in the current club year.  If the exact date of completion is not
known, a good rule of thumb is to select the last date of the prior club year.
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5.2.6 Awards

 The Awards tab provides an overview of a clubber's awards. It is helpful for reviewing and
managing the awards for the specific member. See the Awards Module for additional information.

Toolbar

Besides the Member Window toolbar, there is another toolbar that is specific to the Awards page.

Icon Action Description

Open Award Opens the selected award in the Award dialog.  (Pressing the Enter key
with a row selected or double clicking the row also opens the award.)

New Award Opens the Award dialog with blank/default values to create a new award.

Delete Award Removes the selected award.

Show Filters the data in the grid. Choose to show All Awards, Not Received or
Received awards. Earned in Year limits records to awards earned in the
selected club year.

Rcvd Marks the selected award(s) as having been received by the member.

When marking awards Received, set Date Rcvd to: defaults to the
current club date. When working with awards received on a different date,
change the date before clicking the Rcvd button.

Not Rcvd Marks the selected award(s) as not being received by the member yet.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout,
or exporting data.
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5.2.7 Events

  The Events tab provides an overview of events the clubber has attended. See the Events Module
for additional information.

Toolbar

Besides the Member Window toolbar, there is another toolbar that is specific to the Events page.

Icon Action Description

Open Event Opens the selected event in the Event dialog.  (Pressing the Enter
key with a row selected or double clicking the row also opens the
event.)

New Event Opens the Event dialog with blank/default values to create a new
event. 

Delete Event Removes the selected event.

Show Filters the data in the grid based on Club Year.  Defaults to the
current club year but can be changed.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.
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5.2.8 Contacts

  The Contacts tab provides an overview of leader contacts with the clubber outside of club
sessions. See the Contacts Module for additional information.

Toolbar

Besides the Member Window toolbar, there is another toolbar that is specific to the Contacts page.

Icon Action Description

Open Contact Opens the selected contact in the Contact dialog. (Pressing the
Enter key with a row selected or double clicking the row also
opens the contact.)

New Contact Opens the Contact dialog with blank/default values to create a new
contact.

Delete Contact Removes the selected contact.

Show Filters the data in the grid based on Club Year. Defaults to the
current club year but can be changed.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.
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5.2.9 Fees

The Fees tab provides an overview of a member's fees. See the Ledger Module for additional
information.

Toolbar

Besides the Member Window toolbar, there is another toolbar that is specific to the Fees page.

Icon Action Description

Open Fee Opens the selected fee in the Fee dialog. (Pressing the Enter key with a row
selected or double clicking the row also opens the fee.)

New Fee Opens the Fee dialog with blank/default values to create a new fee for this
member.

Delete Fee Removes the selected fee. This process requires a confirmation.

Show Filters the data in the grid. Choose to show All Fees, Paid Fees, or Unpaid
Fees. In Year: limits records to fees in the selected club year.

Waive
Fee(s)

Waives any balance on the selected Fee(s). This creates a payment record of
type "Waived" and lists your club name as the Payor.

Hh Acct.
Statement

Opens the Household Account Statement report dialog. The selection criteria
defaults to the member's household.

Rcvd Marks the selected fee item(s) as having been received by the member. Set
Date Received to: defaults to the current club date. For items received on a
different date, change the date before clicking the Rcvd button.

Not Rcvd Marks the selected fee item(s) as not having been received by the member yet.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout, or
exporting data.
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5.2.10 Donations

The Donations tab provides an overview of donations a clubber has made. See the Donations
Module for additional information.

Toolbar

Besides the Member Window toolbar, there is another toolbar that is specific to the Donations page.

Icon Action Description

Open Donation Opens the selected donation in the Donation dialog.  (Pressing the
Enter key with a row selected or double clicking the row also
opens the donation.)

New Donation Opens the Donation dialog with blank/default values to create a
new donation for the member.

Delete Donation Removes the selected donation.

Show Filters the data in the grid based on Club Year. Defaults to the
current club year but can be changed.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.
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5.2.11 Leadership

 This tab is only visible if the Member Type is Leader or if LIT for club is marked for a Clubber. It
tracks the details of a leader's service and training, as well as listing clubbers assigned to the leader.

At the top are check boxes to indicate: the Training has been completed and the leader has been
Approved for Leadership.

Service History

Service History records are created automatically as leader records are created and roles are assigned.

Icon Action Description

Open Service Record Opens the selected service record in the Service dialog. 
(Pressing the Enter key with a row selected or double clicking
the row also opens the service record.)

New Service Record Opens the Service dialog with blank/default values to create a
new service record.

Delete Service Record Removes the selected service record.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

Credit for service (for year counts) are triggered based on the attendance requirement set under Admin >
Awards > Leadership Service Awards. 
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Training History

AWdb can automatically create user-defined Training records when adding a new leader based on
settings under Admin > Generic Lookups > Leadership Training.

Icon Action Description

Open Training Record Opens the selected training record in the Training dialog. 
(Pressing the Enter key with a row selected or double clicking
the row also opens the training record.)

New Training Record Opens the Training dialog with blank/default values to create a
new training record.

Delete Training
Record

Removes the selected training record.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

Assigned Clubbers

If clubbers have been assigned to a leader, either from the Clubbers Module Action menu or the Member
Window's Main page, all of the assigned clubbers are listed in this grid.

5.3 Working with Inventory

The Inventory module contains all of the items in the Awana Ministry Supply Catalog. It helps track the
quantity of items in stock. If re-order levels are set, items will be added to an order when the stock gets
low. The Order form makes it easy to build and track supply orders. When a shipment is received,
marking the items as received in the Order form replenishes the Inventory Quantities in Stock. Below is
an example with links to related topics. See additional information in the Inventory Module.

Example Scenario

With the inventory set up and Inventory Tracking preferences set, here's what happens:

When an award is triggered, the award item's Quantity in Stock is reduced. The item's new quantity in
stock is now low enough to trigger it being added to an order. If there is not currently an open order, a
new order is created and the item is added. When a new handbook is assigned, the quantity in stock for
the book is reduced by one. If the new quantity in stock matches the re-order level, the book is added to
the open order. This process happens for every award that is generated, book or uniform that is assigned
or Fee that is manually entered.

After club, open and review the Order under Inventory > Orders. Add additional items and adjust the
quantities if needed. Place the order, using one the following:

a) print the Order form and mail it or fax it to Awana headquarters

b) print the Order form to a PDF file, then e-mail it to Awana headquarters

c) print the Order form and use it as a worksheet to enter the items through Awana's Online Store
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Then, change the Order Status to Submitted so it can no longer be modified. When the supply order
arrives, reopen the Order and set the status to Received. This causes check boxes to appear in the Line
Items grid. Mark each item as received as the shipment is verified. Marking items as received increases
the item's Quantity in Stock by the appropriate amount. After all items are marked as received, the 
Awana Order Number and Invoice fields are updated, and all work on the Order is complete, change the
Status to Closed.

5.3.1 Initial Inventory Setup

For Inventory Tracking to work correctly, the database inventory needs to match your current inventory
and be set up with your preferences.

To get the inventory set up correctly, in the Inventory Module, select the Items tab, then:

1. Limit the number of items in the grid by indicating which items you use as follows:

Select Show: Items we use. For items you DON'T use, select the record(s) and choose Mark
the selected record(s) as Not In Use from the Action menu or the right click pop-up menu.

Select Show: Items we don't use. For items you DO use, select the record(s) and choose
Mark the selected record(s) as In Use.

To speed up the process, manipulate the records in the grid in ways that limit the records, then select
multiple records at once before marking as in use or not in use.

We recommend that you do NOT delete inventory items.  Simply set them to 'not in use' so they do
not initially show in the grid.

2. Add additional items to the inventory that you use that are not in the Awana Catalog.

3. Modify the Sell Prices. This is the price you charge for items. It may differ from the Awana Catalog
price (for example, rounding up to cover shipping costs). The Sell Price is used when creating a fee.

4. Enter how many of each item you have on hand in the Quantity in Stock field.

5. Enter the Quantity in Stock threshold and Order Qty of details for automatic ordering.

6. Set the Inventory Tracking preferences.

With all of this set correctly, as awards and fees are created and orders are received, the inventory
quantities are adjusted automatically and accurately!

5.3.2 Inventory Tracking

The Inventory Tracking preferences determine how the inventory quantities are managed.

1. Under Admin > Options > Inventory and Ordering, choose from the following options:

a. Automatically reduce the Inventory count of related items when a new Award or a Fee is created

Awards are triggered automatically. With this set, the Quantity in Stock will be adjusted.

b. Automatically increase the Inventory "Quantity in Stock" when orders are marked as
"Received" and the line items are checked in

c. Automatically add line items to an open supply order when the Inventory Item's Order Level
Quantity is reached
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d. When adding new Line Items to an Order, display the Expense Category column and populate
it with the default value as set in the related Inventory record

2. Under Admin > Options > Misc, choose default values to use to Reduce the Inventory Qty in
Stock when a handbook or uniform is assigned.

In addition to reducing the Qty in Stock, choose default settings to automatically Create a Fee for each
book or uniform assigned (if the Inventory Sell Price is more than one cent), and to Mark each book or
uniform as having been received.

5.3.3 Placing an Order

If the Inventory Tracking preferences are set to automatically add line items to an open supply order
when the Item's Order Level Quantity is reached, there might be an existing, open order that was already
created.  Otherwise, click the New Order button above the Orders grid in the Inventory Module. Here is
an overview of the process:

1. Open - the default Status when an order is created. Each item to be ordered should have a line
item entry in the grid in the lower section. To add items to the order:

Click the New Line Item button above the grid. A new row will be displayed.

Either select from the drop-down menu or type an Item Number or Description.

Update the Qty Ordered if needed. Line #, Pkg Qty, Cost, and Extension are filled
automatically.

2. Submitted - use when the order has been placed as desired with Awana (via internet, phone, e-
mail, etc.).
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Here is an example of a printed Order form:

3. Received - use when the order arrives. The Rcvd, Qty Rcvd and Qty B/O columns show in the
grid. As the Rcvd box is marked, the Qty Rcvd defaults to the total Qty Ordered and Qty B/O
defaults to zero. Update these values as needed to reflect the correct quantities received.

4. Closed - use after the invoice paid check box is marked and the corresponding Paid Invoice # is
entered.
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5.4 Working with the Ledger

The Ledger Module shows the big picture of the financial records. Use the flexibility of its Fees, Payments
Received, and Unapplied Payments grids to filter or group the records to view relevant data and totals.

To view financial records for a single household, use the Household Ledger. To view financial records for
a single member, use the Member Window's Fees tab.

The main types of records in the ledger are fees and payments. Having accurate records of purchases
and payments helps instill confidence in parents that the program is run well. This section explains the
basics of maintaining these records and points to other sections for more details.

Fees

Besides fees for dues, a fee should be created whenever a member receives an item for which payment
is expected. Fees for dues, handbooks and uniforms can be automatically created. Fees for items such as
bags and replacement books or awards need to be created manually. Fees for awards are generally not
necessary since they are given to clubbers free of charge, but if a clubber repeatedly loses his award
badges, a Fee record can be created. Fees can be created or opened from the Ledger Module or The
Household Ledger.

A fee can be created for any item in the Inventory Module. The fee amount is determined by the item's 
Sell Price.  If the item is not in the Fee Dialog's item list, open the item and click the Club Usage tab.
Ensure the item is marked as 'in use' and that it should be displayed as a choice in any Fee list.

Payments

As members pay for dues or purchased items, post the payments and apply the payments to applicable
fees.  If an over-payment occurs, part of the payment is "unapplied" as a credit on the account.  When
another Fee record is created, "apply" the unapplied payment amount to the new Fee.

During registration it can be common to receive payments but not have fee records yet.  Post the
payment in the Household Ledger. It is tracked as an "Unapplied" payment that can be applied later.

Payments can be viewed in the Ledger Module or Household Ledger, but the Household Ledger must
be used to create/post payments.

Waiving a Fee

Most Awana programs allow kids to attend who are unable to pay for dues, books or uniforms. Even if a
fee is expected to be unpaid, create the fee record anyway so the inventory is maintained as well as
accounting for where items were used. Zero-out the household balance by waiving the fee. This helps
track expenses the club has to cover and determine how much money is needed for the Scholarship
Fund. Totals can be viewed in the Ledger > Fees and Ledger > Payments grid footers.

When a balance is waived, a payment record is created of Type "Waived" with your club name as the
Payor. From the Ledger tab's Fees grid, waive a fee by selecting one or more records. Use the Waive
button in the toolbar or right click and select Waive from the pop-up menu. Confirm by clicking Yes.
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From the Household Ledger, there are two different ways to waive a fee balance:

1. Select "Waived" as the Payment Type. Check boxes appear in the first column of the Fees grid to
select which fee records to waive. As Fees are selected, the Total amount of the waived payment
is calculated. When finished, click Post the Payment.

2. Select the fee record to be waived. Use the Waive Fee button above the grid, or right click and
select Waive Fee from the pop-up menu. Confirm by clicking Yes.

Example Scenario

A mother realizes that her child received a new book and says, "If you tell me how much I owe, I'll bring
the money next week." You reply, "A book costs $10.00, but let me check your balance." Since you are in
the Check-in Module, you type a few characters of the clubber's last name in the Search field and then
press Enter. This hides all other names in the grid except for her child(ren). In the Status bar below
the grid, you check the Household Balance which shows $6.00. You click the link to open their
Household Ledger for more details. You explain that she paid extra when she paid for a uniform. (The
unapplied payment of $4.00 was then applied to the book fee.) Using the button in the toolbar, you print
a Household Account Statement for her to take home as a reminder.

She is a bit surprised and impressed that you keep such accurate records and decides to make a
payment of $10. The next week her daughter turns in the money with the Account Statement which has a
note to donate the extra money to the scholarship fund. You open the Household Ledger, post a payment
for $10.00, and apply it to the book fee.This results in a $4.00 unapplied payment. Since you know this is
a donation and you want to zero the Household balance, you click the Fees tab and click New Fee to
open the Fee dialog. You type "donation" as the Item Number and press Enter. Then you enter $4.00 as
the Amount and click Save and Close. Under the Unapplied Payment tab you select the record and
click Use the Payment Amount then click Post the Payment. This results in the $4.00 payment being
applied to the $4.00 "Donation" Fee and thus a zero household balance.  

Then in the Donations Module, you create a new donation for $4.00 and use "Scholarship Fund" as the
Purpose/Fund. As you click OK, you say a quick prayer, thanking God for families who can afford to help
support your church's Awana ministry, then focus on your next task!

Future functionality will eliminate this last step of creating a new record under the Donations Module, as
this will be done automatically when you create the Fee record representing a "Donation" and post a
payment to it.

5.5 Using AWdb to track VBS

AWdb can be used to track participants and attendance for a summer Bible School or Camp. The
Registration Form can be customized for VBS/Camp use. Other reports such as Clubber Lists, Mailing
Labels, Name Tags, etc. might also be helpful.

 For Camp, follow the same instructions below, but substitute "Camp" for "VBS".

To set up the database:

1. Update to the newest version of AWdb.

2. Finish out the current Awana Club Year.

Do not proceed setting up VBS until the current club sessions are completed!
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3. Go to Admin > Generic Lookups and select Club Years. Add a new record to represent the
specific VBS year. For example, use Club Year "VBS 2019", Logical Order one greater than what
is shown for the existing 2018-2019 Club Year, and "1" as the Meeting Interval value. Click the
check mark at the bottom of the grid to post the new record.

4. Go to Admin > Database Utilities and run the Backup Utility.

5. Click New Year Setup (also under Admin > Database Utilities) and follow these steps:

Step 1a: select "VBS 2019" as the Club Year and enter VBS Starting and Ending Dates.

Step 1b: review/add/edit the specific "Club Names" to use for VBS.  Note: all records should
have a Base Club value of "VBS".  Keep in mind that, just like Awana, a specific Grade and
Gender can only be assigned to a single specific club name.

Step 2, Promotions: be careful about whether or not to "Promote each clubber's School
Grade to the next level".  It's OK to do it for VBS; but if you DO, then DO NOT PROMOTE
AGAIN when the New Year Setup is run for the next Awana club year.

Step 3, Club Assignments: select the appropriate Club Name for each Grade and Gender.

Step 4: review each field to decide how to handle each of the resets.

Step 5, click the Begin Processing button to generate the VBS weekly attendance records.

5.6 Using AWdb in Kiosk mode

AWdb can be set up to handle basic check-in of members at a kiosk. Kiosk mode opens a simplified
check-in dialog in full-screen mode. There are three simple steps to checking in members:

Step 1: Search for the family: type a family name, or part of the name; press Enter or click
Search.  Matching family records are displayed for selection.

Step 2: Select a family: click a row to select the family with members to check-in; click Next.

Step 3: Select the family members who are present on the Current Club Date.  Click Back to
return to the previous screen if needed. Click Done when finished.



Beyond the Basics 91

© 2021 Leffler Systems

Setting up Kiosk mode

In order for kiosk mode to be launched, there must be a User record with an Account Type of "Kiosk". 
The user record can be for a person who is authorized to set up the kiosk, or one can be created for a
specific computer that will be used as the kiosk. (For example, user name "Lobby" or "Lobby 1").

When logging in with an account where the type is set to "kiosk", the kiosk dialog opens in full-screen
mode. Once logged in, preferences can be set by using the menu button in the upper right corner and
selecting Admin Options from the drop-down list.

To access the admin options, the name and password of either an Admin or Kiosk user must be
provided.
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The following items can be customized:

Instructions/Announcements - the text that will be displayed at the top of the kiosk screen.

Color Theme Style - this value is saved for each Kiosk User account.

Number of seconds before automatic reset - after the set number of seconds of inactivity, the
screen is reset to Step 1, clearing any other data from the screen.

Exiting Kiosk mode

Exit kiosk mode by using the menu button in the top right corner and selecting one of the following:

Exit Kiosk mode and Switch Users - exits kiosk mode and launches the log-in dialog to allow log in
as a non-kiosk user

Exit the application - closes the kiosk dialog and shuts down the database

To prevent the database from being shut down by an unauthorized person while in kiosk mode, a user
name and password must be provided from an Admin or a Kiosk user to exit.
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6 The Log-in Dialog

The Log-in dialog checks credentials before allowing access to the database. Each person that is allowed
to access the database should have a separate user account.

Do not create generic accounts with generic passwords that everyone knows!  Even with a single-user
license, multiple user accounts can be created under Admin > Users.

This section explains the details of the Log-in dialog.  For an overview, see Logging in to AWdb.

License Info - displays the church and club names that were given when registering the software.

User Name / Password - credentials that allow access for a user.  For a Trial database, the User
Name and Password are both "demo". An admin user can add users and assign passwords.

Having unique user accounts allows each person to have customize grid layouts and select a theme/
skin.  When records are added or modified, the timestamp and user ID will be more accurate. Also,
some users should be 'regular' non-admin users, while others should have full Administrator access.

Log In - verifies the User Name and Password are valid. If a user is already logged in to the
database and attempts to log in again, a warning message appears asking to reset the account
(thus closing the program that is already running).

If the maximum number of users (based on number of licenses) are already logged in when a user
attempts to log in, a message will be displayed.  If the database thinks YOU are already logged in, a
different message will be displayed and provide an option to reset the account. Only use this option if
you are certain no one else is using your account. In that case it is OK to reset your account, otherwise
click No and exit the Log-in dialog.

Note: If the database was not able to shut down and log a user out properly (for example, the
computer locked up, or there was an error message that forced AWdb to shutdown), this message will
appear. In this case, reset the account and continue with the log in.
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Utilities - provides access to some utilities to reset accounts or run a database Restore or Repair. 
See the Utilities section for more details.

Exit - closes the AWdb application without attempting to log in.

Primary Database/Secondary Database - the Primary Database displays an icon showing a "1"
and a label of "Primary Database".  When using the Database Check-out/Check-in feature to get
non-networked multi-user functionality, there might be additional information in this section. When
logging in to the Primary Database when clubs are checked out, the names of all checked out clubs
are listed. When logging in to a Secondary database, it displays an icon showing a "2" and a label of
"Secondary Database" followed by the names of the clubs checked out to that specific Secondary
database.  If the Secondary database has already been checked back in to the Primary, it displays a
label indicating "(All Clubs Are Locked)".

Version Number - AWdb developers periodically release updates to fix defects and add features. 
When an update is applied, a newer version number will be displayed.

The AWdb version is also displayed in the Main Window's status bar and under Help > About .

If the maintenance and support plan is up-to-date, periodically check for updates in order to get the
latest features and fixes!  After logging in, click Help > Check for Updates.

Local Data Path - location of the data folder. Typically, this never needs to be changed. However,
after restoring a backup into a different location, it should be changed to access the restored
database. Click the ellipsis button at the end to invoke a Browse for Folder dialog to select a
different data folder.

Photo - personalize AWdb with a photo from your own club.

6.1 Customizing the Photo

It's fun to see familiar faces when starting AWdb!  Add a favorite photo for the Log-in dialog as follows:

1. Start the AWdb application.

2. Right click on the existing photo. Select Load... from the pop-up menu. An Open dialog appears.

3. Navigate to the photo of choice. Select it, then click Open. The new photo is displayed.

If the image does not exist as a file, but is from a website or document, right click and "Copy" the image. 
Then right click in the Photo frame of the Log-in screen and select "Paste".

6.2 Utilities

The Utilities button provides access to some utilities directly from the log-in screen:
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Log off all users and reset my account (requires admin name / password) - used to
handle the clean up when the database was unable to properly shut down and log off the current
user (a computer or application locked up that forced AWdb to close unexpectedly, for example).

Open the Database RESTORE utility after log in - used to restore from a backup when file
corruption prevents access to the Admin > Database Utilities screen. Select this option and then
log in as normal. The Backup/Restore dialog opens immediately after logging in.

Open the Database REPAIR utility after log in - used to repair data files when the file
corruption prevents access to the Admin > Database Utilities screen. Select this option and then
log in as normal. The Repair dialog opens immediately after logging in.

Select the folder for the local temp files - used in some special cases to specify a particular
folder that can be excluded from anti-virus scans. When this option is selected, the current Temp
folder appears at the bottom of the Log-in dialog along with a Browse for Folder dialog.  Select the
desired temp folder (such as the Approved Workman folder) and click OK.  The new folder will be
displayed. Log in as normal.
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7 The Home Page

The Home Page is initially selected in the Main Window after successfully logging in.  It provides useful
summary information for the current club year and current club date.  The page is divided into panels
that can be resized by dragging the splitter that separates them.  Save these settings for the page to
default to the preferred layout.

Calendar - defaults to the current Club Date / Year.  Use the arrows to scroll to the previous or
next month(s). The calendar panel can be resized by dragging the splitter at the right side or
bottom. The number of months that are shown adjusts depending on the available space.

Birthdays - lists which members have birthdays during the upcoming week.  

The date range used in the Birthday section is the current club date through the next scheduled club
date.  Thus, if a week or two is skipped, such as for Christmas break, a two or three week span will be
used so birthdays that  fall during the break are not missed.

For a printed list of birthdays, use the Birthday List report in the Report Module.

Visitors - lists visitors on the selected club date, including number of visitors, name of the visitor,
who brought the visitor and what club was visited.

For a printed list of visitors, use the Visitor List report in the Report Module.
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Club Attendance Chart - displays attendance totals. Display options are available.  See
Customizing the Attendance Chart for more details.

Clubber Handbook Alerts - lists members who completed a handbook on the selected Club Date
and those who are close to completing a book.  This is a great tool for checking inventory for the
next handbooks those clubbers will need and making sure any needed awards/prizes are available. 

Club Calendar - provides a summary of each club on each club night.  Learn more in The Club
Calendar section. Statistics are displayed in the status bar beneath the Club Calendar.  These
include Low, High and Average attendance numbers for both clubbers and leaders, and also a
Clubber to Leader ratio.

Notes - provides an area to keep notes.  Instead of jotting something down on a sticky note, jot it
down in the Note tab instead, so that it doesn't get lost!

The same notes are available no matter which Club Year or Date is selected and are not reset during
the New Year Setup.

Photo - customize this photo and then save the layout with the Photo tab selected to personalize
the database!

7.1 Setting the Home Page's Layout

On the Home Page, there are several panels that can be resized by dragging the edges.

Once the panels are resized and the preferred layout is setup, including which tab to display by default,
save the selections by going to the Main Window's Menu bar and choosing View > Save Home Page
Layout.

To go back to the original layout settings, from the Main Window's Menu bar select View > Reset
Home Page Layout.

7.2 Customizing the Attendance Chart

  There are several options available to customize the Chart on the Home Page. These are available
either by selecting View > Chart Settings from the Main Window's Menu bar or by right clicking the
Attendance panel on the Home Page and using the right click pop-up menu.
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Choose from the following:

Type - select from:

o Bar Chart (default) -

o Line Chart

 

Use 3D Style - applies to bars or lines within the chart

Show Leaders - hide or show the leader statistics on the chart.

Show Legend - hide or show the Legend for Clubber and Leader representation.

Legend Position - select from:Top, Bottom, Left or Right.



The Home Page 101

© 2021 Leffler Systems

7.3 The Club Calendar

The Club Calendar tab includes a summary of each of the clubs on each club night for the Current Club
Year.  Statistics are displayed in the Status bar beneath the Club Calendar.  These include Low, High and
Average attendance numbers for both clubbers and leaders, and also a Clubber to Leader Ratio.

Preview/Print the grid and/or manipulate it as explained in working with grids.  This grid is probably most
useful when grouped by the Date column, so all of the clubs are grouped together for each club date.
This shows the number of Clubbers, Leaders, Visitors and Sections not only broken down by club, but
also totaled in the group's footer.

Using this grid is the easiest way to determine in which Quarter a given club night falls.  With the grid
grouped by Date,  expand the row of a given date to see the value in the Qtr column for a particular
club.  (Because different clubs could start and end on different dates, the Quarters could differ per
week.)

The records shown in the Club Calendar are read-only. Admin users can edit the records under Admin >
Club Setup > Club Calendars. Themes and Responsibilities, and Notes can also be added/edited there.

7.4 Customizing the Photo

Personalize the graphic to display a photo of your own beloved clubbers on the Photo tab. There is no
practical purpose for this, it's just fun to have a friendly photo! 

To add a photo:

1. Select the Home tab on the Main Window.

2. Select the Photo tab in the lower, right panel of the Home Page.

3. Right click on the existing photo and select Load... from the pop-up menu.  An Open dialog will
appear.

4. Navigate to the photo of choice, select it, then click Open. The new photo will now be displayed.

If the image does not exist as a file, but is within a website or document, "Copy" the image from outside of
AWdb then select "Paste" from the pop-up menu.
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8 The Clubbers Module

 The Clubbers Module provides a very flexible high level view of all clubbers.  Initially, the grid
displays only clubbers with a Status of "Active", but other status values can be selected, such as "Visitor",
"Archived", "Inactive", "Graduated", or "Prospect".  The toolbar buttons or right click pop-up menu items
provide a wide range of actions such as setting a clubber's Status, setting Registration to Current, setting
Team Color or Team Name, or Assigning a Leader.

Ad-hoc reports can be created to analyze club data by using the powerful features of the grid. Records
can be filtered, sorted, and grouped. Hide bands and/or columns and print or export the data.

Most actions on this grid, including opening member records, opening household ledgers,  printing
Member Profile reports and printing Registration Forms, can be applied to multiple clubbers (up to 10) at
one time using the multi-select ability. 
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Icon Action Description

Open
Clubber

Opens the selected clubber(s) whose individual data is then displayed in the 
Member Window.  (Pressing the Enter key or double clicking the row also
opens the member record.)

New Clubber 
(Ctrl-N)

Opens the Member Window with blank/default values to create a new
clubber.

Delete
Clubber(s) 
(Ctrl-D)

Removes the currently selected clubber(s). This process requires a
confirmation.

Perform
Search

Filters the grid to show only the clubbers whose names match the search
criteria entered in the text field.  (Pressing the Enter key also performs the
search/filter.)

Show Filters the data in the grid based on Status. Select the boxes in the drop-
down list to indicate the status(es) to display.

View/Edit
Photos

Opens the Photo dialog to manage photos.  Defaults to the selected member.

Open
Household
Ledger

Opens the Household Ledger for the selected clubber's family to manage
fees and payments.

Begin
Registration
Process

Opens the Registration Window Dialog for the clubber's family to manage
registration related events.

Assign
Handbook*

Opens the Assign Handbook dialog to assign a new handbook to the selected
clubber(s).

Assign
Uniform*

Opens the Assign Uniform dialog to assign a new uniform to the selected
clubber(s).

Assign a
Leader*

Opens a dialog to assign a leader to the selected clubber(s).

Set Status* Sets the status of the selected clubber(s) to one of the following: Active,
Archived, Graduated, Inactive, Prospect, Visitor.

Set Team
Color*

Sets the Team Color for the selected clubber(s).

Set Flag* Sets a colored Flag for the selected clubber(s).
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Icon Action Description

Set Team
Name*

Sets the Team Name for the selected clubber(s).

Register and
Post
Payment*

Opens the Register and Post Payment Dialog to mark the Registration as
current for the selected clubber(s).

Copy E-mail
Addresses*

Copies the e-mail addresses of all selected rows into clipboard memory so
they can be pasted into an e-mail client. The addresses are separated by
either semicolons or commas as indicated under Admin > Users.

Calculations must be turned "On" in order to populate the Primary E-mail
Address column.

Don't paste - e-mail addresses into the usual "To:" field; instead, use the
"Bcc" (blind) field so that every recipient doesn't get a list of all addresses.

Copy
Textible
Phone
Numbers*

Copies the textible phone numbers (that are then converted to e-mail
addresses) of all selected rows into clipboard memory so that they can be
pasted into an e-mail client. The addresses are separated by either
semicolons or commas as indicated under Admin > Users.

Don't paste e-mail addresses into the usual "To:" field; instead, use the
"Bcc" (blind) field so that every recipient doesn't get a list of all addresses.

Print
Member
Profile

Opens the Member Profile report dialog to print a member profile for the
selected clubber(s).

Print
Registration
Form

Opens the Registration Form report dialog to print a registration form for the
selected clubber's family.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout, or
exporting data.

* These items are available from the Action drop-down menu on the Toolbar.

Many of the actions are also available through the right click pop-up menu.
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9 The Leaders Module

 The Leaders Module provides a flexible high level view of volunteers. Initially the grid displays only
leaders with a Status of "Active", but other status values can be selected, such as "Archived", "Inactive",
"Graduated", "Prospect", or "Visitor".  The toolbar buttons or right click pop-up menu items provide a
wide range of actions such as setting a leader's Status or Club Name and Leadership Role, or setting
Team Color or Team Name.

Ad-hoc reports can be created to analyze club data by using the powerful features of the grid.  Records
can be filtered, sorted, and grouped.  Hide bands and/or columns and print or export the data.

While the Leaders Module works much like the Clubbers Module, there are a few differences.  For
example, the Leaders Module contains more than one grid, each displaying a different set of leader
information such as Service and Training History, as well as Leadership Roles. 

 Most actions on this grid can be applied to multiple members using the multi-select ability.

Leaders

 The Leaders page is displayed by default and provides general information about the leaders.
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Icon Action Description

Open Leader Opens the selected leader whose individual data is then displayed in
the Member Window.  (Pressing the Enter key or double clicking the
row also opens the member record.)

New Leader (Ctrl-N) Opens the Member Window with blank/default values to create a
new leader.

Delete Leader(s) 
(Ctrl-D)

Removes the currently selected leader(s). This process requires a
confirmation.

Perform Search Filters the grid to show only the leaders whose names match the
search criteria entered in the text field.  (Pressing the Enter key also
performs the search/filter.)

Show Filters the data in the grid based on Status. Select the boxes in the
drop-down list to indicate the status(es) of leaders to display.

View/Edit Photos Opens the Photo dialog to manage photos.  Defaults to the current
member.

Open Household
Ledger

Opens the Household Ledger for the selected leader's family to 
manage fees and payments.

Set Status* Sets the status of the selected leader(s) to one of the following:
Active, Archived, Graduated, Inactive, Prospect, Visitor.

Set Team Color* Sets the Team Color for the selected leader(s).

Set Flag* Sets a colored Flag for the selected leader(s).

Set Team Name* Sets the Team Name for the selected leader(s).

Set Training* Completed - marks the 'Training has been completed' check box on
the Leadership tab of the member record for the selected
member(s). Not completed - clears the check box for the selected
member(s).

Set Approved for
Leadership*

Approved - marks the 'Approved for Leadership' check box on the
Leadership tab of the member record for the selected member(s). 
Not approved - clears the check box for the selected member(s).

Set Club Name and
Leadership Role*

Opens the Leadership Roles dialog to set the Club Name and
Leadership Role for the selected leader. (Can't use multi-select.) 

Register and Post
Payment*

Opens the Register and Post Payment Dialog to mark the
Registration as current for the selected leader(s).
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Icon Action Description

Convert Leader to
LIT Clubber*

This is a one-time special-use function that is explained in the
confirmation message dialog.

Copy E-mail
Addresses*

Copies the e-mail addresses of all selected rows into clipboard
memory for pasting into an e-mail client.  The addresses are
separated by either semicolons or commas as indicated under 
Admin > Users.

Calculations must be turned "On" to populate the Primary E-mail
Address column.

Don't paste e-mail addresses into the "To:" field. Use the
"Bcc" (blind) field so that every recipient doesn't get a list of all
addresses.

Copy Textible Phone
Numbers*

Copies the textible phone numbers (that are then converted to e-
mail addresses) of all selected rows into clipboard memory for
pasting into an e-mail client. The addresses are separated by either
semicolons or commas as indicated under Admin > Users.

Don't paste e-mail addresses into the"To:" field. Use the
"Bcc" (blind) field so that every recipient doesn't get a list of all
addresses.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

* These items are available from the Action drop-down menu on the Toolbar.

Many of the actions are also available through the right click pop-up menu.

Service History

  The Service History tab displays the service history details of each leader.

Service History records are created automatically as leaders are created and assigned roles.

The Optimize procedure also provides the option to "Verify the Service History records.......".

Enter historical records for leaders to have an accurate count of total years served by using the
New Service button on the toolbar.

The most common roles are provided. The list of options can be customized under Admin >
Generic Lookups > Leadership Roles.
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Icon Action Description

Open Service
Record

Opens the selected service record in the Service dialog.  (Pressing the
Enter key or double clicking the row also opens the record.)

New Service
Record (Ctrl-N)

Opens the Service dialog with blank/default values to create a new
service record.

Delete Service
Record (Ctrl-D)

Removes the selected service record(s). This process requires a
confirmation.

Show Filters the data in the grid based on Status. Select the boxes in the drop-
down list to indicate the status(es) of leaders to display.

Open Member Opens the member record associated with the selected service record.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout,
or exporting data.

Training History

 The Training History tab displays the training history details of each leader. It is easy to see which
leaders have completed (or not completed) the required basic training and background checks.

Enter Historical records for prior club years using the New Leader Training button on the toolbar.

Some common training descriptions are provided. The list of options can be customized under 
Admin > Generic Lookups > Leadership Training.
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Choose to "Automatically Add" selected training items when a leader record is saved or when
choosing "Verify the auto-add Leadership Training records ....." during an Optimize. Training
items can also be set as Required. Set preferences under Admin > Generic Lookups >
Leadership Training.

Customize the grid for ad-hoc reports.

Icon Action Description

Open Training
Record

Opens the selected training record in the Training dialog.  (Pressing
the Enter key or double clicking the row also opens the record.)

New Training
Record (Ctrl-N)

Opens the Training dialog with blank/default values to create a new
training record.

Delete Training
Record (Ctrl-D)

Removes the selected training record(s). This process requires a
confirmation.

Show Filters the data in the grid based on Status. Select the boxes in the
drop-down list to indicate the status(es) of leaders to display.

Open Member Opens the member record associated with the selected training
record.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.
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Leadership Roles

The Leadership Roles tab displays all role records for each leader.

Icon Action Description

Show Filters the data in the grid based on Status. Select the boxes in
the drop-down list to indicate the status(es) of leaders to
display.

Open Member Opens the member record associated with the selected role
record.

Grid Tools Lists actions related to the grid such as: saving or resetting a
grid layout, or exporting data.
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9.1 The Service Dialog

  Opening or creating a service record opens the Service dialog to view, modify or enter details of a
leader's service history.

Service history records are created automatically for current roles.

To speed the process of entering past service history, instead of selecting a specific club year from the
drop-down list, type in a span of club years such as "2010-2018" to represent 8 years of service.

Member Name - the leader who served

Church Name - where the service was completed. Use <New> to add additional entries.

Leadership Role - selection options are determined by Admin > Generic Lookups >
Leadership Roles.

Club Name - if the actual club name the leader served in is not listed, the generic "Awana" club
may be used and a note added to the record with the specific club name.

Club Years - a range of years may be entered. Examine Count as # Year(s) to be sure it is
calculated correctly.

From Date - To Date - specific dates (optional).

Service Pin - indicates if This service qualifies for a Service Pin.

Each time attendance is recorded for a leader, AWdb checks the attendance criteria (Admin > Awards >
Leadership Service Awards). When the criteria is met, the Service record is updated.

Note - any additional information related to the service record.

Actions

Save and Close - saves the record and closes the dialog.

Cancel and Close - exits without creating a new record or saving changes to an existing one.
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9.2 The Training Dialog

  Opening or creating a new training record opens the Training dialog to view, modify or enter details
of a leader's training history.

Training history records can be created automatically.

Member Name - the leader who received training.

Description - selection options are determined by Admin > Generic Lookups > Leadership
Training.

Required - indicates if a leader must have the training.

Completed - indicates if the leader has finished the training.

Date Completed - when Completed is set to Yes, the Date Completed field is enabled.  Once
entered, ensure that the Club Year was calculated correctly.

Note - any additional information related to the training record.

Actions

Save and Close - saves the record and closes the dialog.

Cancel and Close - exits without creating a new record or saving changes to an existing one.
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9.3 The Leadership Roles Dialog

From the Main tab of a leader's Member Record, right click on the Leadership Roles grid and select Open
the Roles Dialog.  This dialog shows the assigned roles for the current club year. Roles can be added or
deleted using the buttons on the toolbar. Existing roles can be edited directly in the grid.

To add a role record, click the New button. A new row will be added to the grid. Directly enter the
following fields:

Leadership Role - selection options are determined by Admin > Generic Lookups >
Leadership Roles.

Club Name, Team Color, Team Name - Club Name and Team Name selection options are
determined by Admin > Club Setup records.

Primary - indicates which role is primary (if more than one is listed).  If a leader serves in multiple
clubs on the same meeting day, only one club assignment should be designated as Primary. 
However, if a leader serves in multiple clubs that meet on different days, one club assignment per
meeting day should be designated as Primary.

Meeting Day - populated automatically based on the settings under Admin > Club Setup > Club
Names, Logos, Dues and Points.
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10 The Households Module

The Households Module provides a view of all members grouped by family.
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Icon Action Description

Open Member Opens the selected member whose individual data is then displayed
in the Member Window.  (Pressing the Enter key or double clicking
the row also opens the member record.)

Show Filters the data in the grid based on Household Status. Select the
boxes in the drop-down list to indicate the status(es) to display.

Open Household
Ledger

Opens the Household Ledger for the selected family to manage fees
and payments.

Open Registration
Window

Opens the Registration Window Dialog for the selected family to 
manage registration related events.

Print Registration
Form

Opens the Registration Form report dialog to print a registration form
for the selected family.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

Many of the actions are also available through the right click pop-up menu.

The right click pop-up menu provides an option to "Rederive the Household Filing Name".  It will be derived
from the Last Name followed by a dash and a list of all Preferred (First) Names of household members. 
Example: "Green - Sandy, Michael, Tina". In households that have persons with different last names, the last
names are listed in alphabetical order, separated by "/".  For example, for Rebecca Brown, Chad Smith and
David Smith: "Brown/Smith - Rebecca, Chad, David".
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11 The Check-in Module

 The Check-in Module provides a way to quickly and easily track Attendance, Dues, Offerings, and
other categories, like: Uniform, Bible, Book, and Bonus, as well as add visitors and mark completed
handbook sections.  With each click, the section counts and point totals are updated and awards are
automatically triggered when appropriate.  The Check-in module efficiently handles the weekly
recordkeeping tasks that would otherwise be a very tedious and time consuming job.  

Customizing the Check-in Grid

The Check-in grid can be customized to meet the different needs of each specific Awana Program to help
maximize productivity.

One-time customizations:

1. Start by showing or hiding the columns based on which are used. For example, if Church
Attendance is not tracked, hide the "Attend Church" column header. If weekly Dues payments
aren't tracked, hide the "Dues" header band and all of the dues-related columns will be hidden.

When choosing to hide columns, be sure to understand the difference between a header band and a
column header.  In the above graphic, one header band is labeled Misc.  Beneath Misc there are
individual column headers labeled Uniform, Bible, Book, etc.  Hiding a header band causes all of its
column headers to also be hidden.



The Check-in Module 121

© 2021 Leffler Systems

2. To use the Custom1 and Custom2 check box columns, make them visible and then customize the
Display Names under Admin > Club Setup > Custom Fields.  Set the Custom check box columns'
point values under Admin > Club Setup > Club Names, Logos, Dues and Points.

3. Resize column widths as desired by dragging a column header or a header band's right edge to the
left or right.  For example, if the Church Attendance column is hidden, the Attend header band
can be resized so it is more narrow.

4. Save the desired settings!  After adjusting the grid, click the Grid button in the toolbar and select
Save the current grid layout.  This ensures AWdb sets things up the same way after the next
log in.

The customized grid settings are saved per user. Each individual user can (and should) set preferred
grid layouts.  Each person using AWdb should have an individual User Account with a unique name
and password.

Weekly customizations:

There are additional customizations that can be made each week to accomplish specific tasks. Here
are a couple of examples:

1. When entering data from worksheets that are organized by Club Name, use the Show: club name
drop-down check list to select only one club at a time to display. For example: To record attendance
and handbook sections only for Sparks clubbers, reduce the number of rows in the grid by selecting
"Clubbers" and "Sparks" in the Show: drop-down lists in the toolbar.  Once data entry for Sparks is
completed, select another club name, like T&T, to continue data entry for the next group.

If you always limit the records displayed to a single club, try hiding the Club Name column in the grid
to reduce horizontal scrolling.

2. When entering data from worksheets that are organized by Team Color for a single Club, after
selecting the specific club to Show, group the records by Team Color.

Grouping by Team Color makes it easy to enter Game Points (if those are tracked).  Also, statistics are
shown for each node (in this case, each Team Color).

3. When entering data from worksheets for handbook section completion, filter the grid to show a
selected Primary Handbook (like Grace in Action, or Appleseed).  Further filter the grid to show
those who attended on the given club date (Attend = true).  This makes it it easy to multi-select
records and mark the same handbook section for all of the members at once.

When the specific task is completed, use the Grid button and select Reset Grid Layout to return to
your custom grid settings.

The Check-in Module is discussed in more detail by dividing it into three sections:  The Toolbar, The
Check-in Grid, and The Sections Completed Grid.

11.1 The Toolbar

The toolbar in the Check-in Module provides functionality that is generally needed during check-in time.
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Icon Action Description

Open Member Opens the selected member whose individual data is then displayed in the 
Member Window.  (Pressing the Enter key or double clicking the row also
opens the member record.)

New Member 
(Ctrl-N)

Opens the Member Window with blank/default values to create a new
member.

Add a Visitor Opens the Add a Visitor dialog to add a visitor brought by the selected
member.

Perform
Search

Filters the grid to show only those members whose names match the
search criteria entered in the text field.  (Pressing the Enter key also
performs the search/filter.)

Speed Check This is a toggle button that can be turned on or off. When on, other check
boxes are automatically selected when a member's Club Attendance is
marked. Set preferences under Admin > Options  > Check-In.

Assign
Handbook

Opens the Assign Handbook dialog to assign a new handbook to the
selected member(s).

Assign
Uniform

Opens the Assign Uniform dialog to assign a new uniform to the selected
member(s).

View/Edit
Photos

Opens the Photo dialog to manage photos.  Defaults to the selected
member.

Open
Household
Ledger

Opens the Household Ledger for the selected member's family to manage
fees and payments.

Begin
Registration
Process

Opens the Registration Window Dialog for the member's family to manage
registration related events.

Set
Attendance*

Present - marks the attendance check box for the selected member(s).
Not present - clears the attendance check box for the selected
member(s).

Use this with the multi-select ability of the grid to quickly mark (or clear)
attendance for multiple members at one time.

Set Status* Sets the status of the selected member(s) to one of the following: Active,
Archived, Graduated, Inactive, Prospect, Visitor.

Set Flag* Sets a colored Flag for the selected member(s).

Set Team
Name*

Sets the Team Name for the selected member(s).
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Register and
Post
Payment*

Opens the Register and Post Payment Dialog to mark the Registration as
current for the selected member(s).

Excuse* Marks the club and/or church attendance for the selected member, or all
members, as excused. If a club night is canceled, the date can be deleted
(under Admin > Club Setup > Club Calendars) instead.

Clear
excused*

Marks the club and/or church attendance for the selected member, or all
members, as unexcused.

Clear all Team
Colors for this
week*

Clears all the Team Color values in preparation to reassign new ones.
When using Team Colors to group clubbers only for games (and not
handbook time), this helps keep track of who has/has not been re-
assigned.

Reset all
Team Colors
for this
week*

Resets all current Team Color values according to each member's base
color (from the Member's  Main tab.)

Print Member
Profile

Opens the Member Profile report dialog to print a member profile for the
current member.

Print
Registration
Form

Opens the Registration Form report dialog to print a registration form for
the selected member's family.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout,
or exporting data..

Offering Displays how offerings will be credited if a specific Offering Fund is set for
the current club date (under Admin > Club Setup > Club Calendars).

Show Filters the data in the grid based on Status, Member Type and/or Club
Name. Select the boxes in each of the drop-down lists to indicate the
status(es), member type(s) and/or club(s) to be displayed in the grid.

Theme Displays the theme if a particular Theme is set in the club session records
for the current club date (under Admin > Club Setup > Club
Calendars).

Show/Hide
Handbook
Sections

This is a toggle button that can be turned on or off.  When on, the
Handbook Sections grid is displayed making it easy to record completed
sections.  When off, the grid will be hidden to allow more space for the
Check-in Grid.  (The panel can be manually re-sized by grabbing and
dragging the edge.)

* These items are available from the Action drop-down menu on the Toolbar.

Many of the actions are also available through the right click pop-up menu.
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11.2 The Check-in Grid

Use the Check-in grid to perform data entry tasks related to tracking Check-in items such as: Club and
Church Attendance, Dues Pd, Offering Amount, Uniform, Bible, Book, Bonus, Visitors, Game
Points, etc.  Most columns are check boxes for quick and easy data entry.  Some columns, like Game
Points and Other, allow numeric values to be typed directly in the grid.

Key Points

Remember to customize the grid as desired.

Use the Show: components in the toolbar to get a custom view for a specific data entry task.  For
example, set the grid to show only Active clubbers in Sparks.

Use the incremental search capability to quickly locate a specific clubber.  For example, click anywhere
in the Last Name or First Name column then start typing a few characters and the focused row will
move to the matching record.  To release the incremental search, press ESC.

Turn on the Speed Check feature to avoid constantly repeating clicks for Uniform, Bible, and Book,
so those columns are automatically checked as soon as the Attend Club column is checked. Configure
which check boxes are affected under Admin > Options  > Check-In.

Mark (or clear) attendance for multiple members at once by multi-selecting records and using the
Action drop-down menu or right click pop-up menu option of Set Attendance > Present/Not
present.

Click in the Game Points cell and type the actual numeric value to enter points earned for Game Time.

To award points to everyone on a particular Team Color, drag the Team Color column header into the
area above the grid to group the records.  All of the Blue Team members are together, then Green
members, etc.  Type  the number of points to award in the Game Points cell, then press the down arrow
and type the point value and then press the down arrow until all of the rows for that team are
completed. (You might first want to filter the attend column to show only those who attended.)
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Change the Team Color assignment by clicking the cell and selecting a different color.  A change in
Team Color applies to the current week or all future weeks, depending on the response to the pop-up
dialog.  The Team Color value for prior weeks is not changed in order to preserve historical data. To
change the Team Color for a prior week, adjust the Current Club Date in the main toolbar prior to
making the change or open the Member record and make the change on the Attendance tab for the
desired week.

Excuse an absence by selecting a clubber/s and then using the Excuse > item under the Action menu
(or from the right click pop-up menu).

View valuable statistics by grouping on Team Color, Team Name, or Leader Name.  Drag the
appropriate column header into the grouping area above the grid and notice the statistics shown for
each node:  Number of Members, Number Present, Total Points, Average Points Per Clubber,
Total Required Sections completed, and Average Number of Sections per Clubber.

Create ad-hoc reports using the Preview/Print feature.

Dues and Posting payments

Hide the Dues header band if weekly dues payments are not collected.

If weekly dues payments are collected, click the Dues Pd check box when a single weekly dues amount
is received.  However, if weekly dues are $0.50 but a clubber pays $1.00 or more, type over the
default Dues Amt Pd and change it the received amount.

Any amount entered in the Dues Amount Pd cell is assumed to be cash and is applied exclusively to
the dues for the selected clubber only.  Thus, if dues money is paid that is for more than one clubber,
mentally divide up the amount and apply it to each clubber separately.

For money received for books and uniforms, do NOT check the Dues Pd check box or type any value in
the Dues Amt Pd field.  Instead, open the Household Ledger and post the payment there.  Any money
applied to Fees representing Dues will cause the Check-in grid's Dues related check boxes and fields to
be automatically filled in.

A quick way to open the Household Ledger is to use the money sign button in the toolbar, or use the link
below the Check-in grid in the status bar.

11.3 The Sections Completed Grid

The Sections Completed grid, located in the Check-in Module, is one of two ways to record completed
handbook sections.  It is useful for marking sections complete during club since it is faster than opening
each member’s record and marking sections completed on the Handbook page.

If the Sections Completed grid is not showing, select the Show/Hide the Handbook Sections toggle
button near the right side of the toolbar.

Select a row in the Check-in grid.  The member’s Sections Completed grid is displayed on the right
side of the screen.

For quicker data entry for clubs that all work on the same section, like Cubbies or T&T, select multiple
members that all completed the same section and then mark the section completed.  All of the selected
members' handbooks will be updated. Showing the Primary Handbook in the grid for each member and
filtering or grouping the grid will help with selection.
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Member name, current handbook(s), handbook percentage completed - displayed above
the handbook section grid. If there is more than one handbook, select which handbook to show.

If the correct handbook is not displayed, open the Member record. Under the Handbooks tab, mark an
already assigned book as "Current" or Assign a new handbook.

Required tab - sections a clubber must complete to earn a book award.

o The Sections Completed grid automatically scrolls to display the incomplete sections.

o Mark the Done check box to indicate a section has been completed. The current club date is

used as the Date of completion, but can be changed.

For the clubber to be credited properly and weekly statistics to be accurate, be sure to select a valid
club date.

o Clear the Done check box to remove a completed section. Related awards will also be removed.

o An Award Message dialog opens when an award is earned by completion of a section. Select

whether or not the Award was Received then click OK.  (Set a default for Award was
Received under Admin > Options > Misc.)

Review/Extra Credit tab - additional sections that a clubber can complete. This grid operates like
the required sections grid.

Notes - any additional information related to the assigned handbook for this member.
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12 The Ledger Module

Dealing with all the fee and payment transactions can be a cumbersome and confusing job. The Ledger
Module eases that burden by providing a way to track all fees and payments and see the big picture view
for the entire club.  It also provides a detailed view of the financial records for each individual and
household. The Household Account Statement report can be used as an invoice to keep families informed
of purchases and balances. The Receipts Report can provide a detailed accounting of the monies received
for the church treasurer.

The Ledger Module includes tabs for Fees and Payments as well as access to a selected member's
Household Ledger.  For an overview, see Working with the Ledger.

 Most actions on these grids, including marking items as received or not received, can be applied to multiple
rows at once using the multi-select ability. 

12.1 Fees

 The Ledger > Fees tab shows fees for all households in the database.  This shows at a glance the
money received on a particular night (or for the entire year) and also how much money is still due.  The
grid can be sorted by Item Rcvd to see which members are still waiting to receive a book or uniform
that had been ordered.  This grid is also helpful when monitoring a budget.  As an example, if
scholarships are provided, apply a filter to show Dues? = False and Waived = true in order to show
how much the church spent for books and uniforms of scholarship kids.  (The payment type of "Waived"
is used to indicate that the balance on a particular Fee was paid by the club, often through the use of
Scholarship funds.)

There are lots of other ways to use the grid to analyze your data.
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Icon Action Description

Open Fee Opens the selected fee in the Fee dialog. (Pressing the Enter
key with a row selected or double clicking the row also opens
the fee.)

New Fee (Ctrl-N) Opens the Fee dialog with blank/default values to create a new
fee.

Delete Fee(s) (Ctrl-D) Removes the selected fee(s).

Show Filters the data in the grid. Choose to show All Fees, Paid
Fees, or Unpaid Fees. Show In Year: limits records to fees
in the selected club year.

Open Member Opens the member record for the person who incurred the
selected fee.

Waive Fee(s) Waives any balance on the selected Fee(s). This creates a
payment record of type "Waived" and lists your club name as
the Payor.

Open Household Ledger Opens the Household Ledger for the selected member's family
to manage fees and payments.

Hh Account Statement Opens the Household Account Statement report dialog. The
selection criteria defaults to the selected member's household.

Rcvd Marks the selected fee item(s) as having been received by the
member.

When marking items as "Received", set Date Received to:
defaults to the current club date.  When working with items
received on a different date, change the date before clicking
the Rcvd button.

Not Rcvd Marks the selected fee item(s) as not having been received by
the member yet.

Grid Tools Lists actions related to the grid such as: saving or resetting a
grid layout, or exporting data.
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12.1.1 The Fee Dialog

 Opening or creating a fee displays the Fee dialog to view, modify or enter the details of a fee.

Member Name - member who incurred the fee.

Item Number and Item Description - selection can be done using either Item Number or
Description. The lists are populated with any items marked to be used in Fee lists in the Inventory
record.  When one is selected, the other field is filled in automatically. If an image exists, it is shown
in the area below.

If needed, use the Search button to locate an item from a pop-up dialog that includes a search field
and photos to help select the correct item.

If an item isn't listed, but it IS in AWdb's main Inventory List, open the item from the Inventory
Module and click the Club Usage tab.  Ensure the appropriate Use this item as a choice in any...
drop-down list options are selected.

For new book or uniform fees, an option to assign the book or uniform will be given.

Received - selecting Yes enables the Date Rcvd field. Verify the Club Year is correct.

Amount - total money the member should pay for the item. It is initially set by the item's Sell
Price in the Inventory records, but can be edited. To update the Sell Price so future Fees are
correct, use the Item Number link in the lower right to open the Inventory Item.

Due Date - when the fee should be paid by the member.

Note - any additional information related to this fee.

Total Paid and Balance - read-only fields; calculated based on payment(s) applied to the fee.
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Actions

Save and Close - saves the record and closes the dialog.

To create other fees, instead of clicking Save and Close, click Save and New to save the fee then clear
the fields of the dialog to quickly create another fee.

Cancel and Close - exits without creating a new record or saving changes to an existing one.

Household Ledger button - opens the Household Ledger for the member who incurred the fee. 
The Fee dialog automatically saves and closes, then the Household Ledger opens.

The item's Qty in Stock is reduced when the fee is saved, if the automatic inventory reduction feature is
turned on and a matching Inventory record exists.

12.2 Payments

  The Ledger > Payments tab shows payments for all households in the database.  The payments
are shown in three different grids, as described below, to easily analyze data.

Received Payments

The Received tab grid shows all payments that have been received. It defaults to showing only
payments received for the Current Club Date.  A different date can be selected or choose to show "All
Dates". 

To the left of each payment row is a symbol (a plus sign or arrow).  Click this to expand a payment. This
shows all the fees to which the payment was applied.  The applied payments are also listed on the 
Applied tab. If any part of the payment amount has not been applied, it is listed on the Unapplied tab.



Approved Workman Database 5.9 - User Guide132

© 2021 Leffler Systems

Icon Action Description

Delete Payment Removes the selected payment(s). A confirmation is required.

Show Filters the data in the grid based on Club Year and Club
Date. The Club Year defaults to the current club year, but can
be changed. Select a specific club date within that year or
choose to show All Dates.

Open Household Ledger Opens the Household Ledger for the selected member's family
to manage fees and payments.

Receipts Report Opens the Receipts Report dialog to set parameters for a
report listing payments grouped by Date Received and Type.

Grid Tools Lists actions related to the grid such as: saving or resetting a
grid layout, or exporting data.

On the Payments grid, group records into meaningful batches that will include item counts and
subtotals.  For example, drag the Type column header into the grouping area above the grid to see a
count of cash payments, checks, and waived payments.  The grand total of all payments is also listed in
the grid footer. 

Applied Payments

If a payment, or part of a payment, was applied to a fee, it is listed on the Applied tab.
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UnApplied Payments

If a payment, or part of a payment, has not been applied to a fee, it is listed on the Unapplied tab.

12.3 The Household Ledger

 The Household Ledger displays the fees and payments for all members of a specific household.  This
makes it easy to instantly see the bottom-line total a family owes.  It also provides details for any fee and
the payments that have been applied to it.  Conversely, it shows payment records and all of the fees to
which the payment was applied.

Open a selected member's Household Ledger from the:

Check-in Module toolbar:  Household Ledger button

Check-in Module status bar: link beneath the grid

Clubbers Module, Leaders Module, Households Module, Ledger > Fees or Ledger > Payments
toolbar:  Household Ledger button

Member Window toolbar:  Household Ledger button

Fee Dialog: Household Ledger button

Use the top section of the Household Ledger to post payments.  The lower section contains three tabs: 
Fees, Payments, and Unapplied Payments.  See the Fees and Payments topics below for details. 
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Icon Action Description

Close Closes the window.

Show Club Year (in
the topmost
toolbar)

Filters the items in the ledger based on Club Year.  Defaults to the
current club year, but can be changed.

Show Household Filters the items in the ledger based on the selected Household. To
switch to another household's data, select a household name from
the drop-down list.

Account Statement Opens the Household Account Statement report dialog. The
selection criteria defaults to the selected household.

Refresh Refreshes the data that is displayed. This is not normally needed,
but can be used when running the database over a network to be
sure that edits made by other users are reflected in the current
data.  

Stay On Top Toggles whether or not the window will stay on top of the main
window.

To quickly filter the contents of all the grids in the three tabs, use the Club Year drop-down list to
determine which club year's ledger information is displayed.  Use the Household drop-down list to
quickly switch to a different household.
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Fees

 Besides fees for dues, a fee should be created whenever a member buys or earns an item for which
payment is expected.  Fees for dues, handbooks, and uniforms are usually automatically created when a
clubber's registration is set as current and when a new handbook or uniform is assigned.  However, other
fees, like bags and replacement books and awards, need to be created manually.  Fees for awards are
generally not necessary, since they are given to clubbers free of charge.  View a list of all fees by clicking
the Fees for [club year] tab.

Fees Toolbar:

Icon Action Description

Open Fee Opens the selected fee in the Fee dialog. (Pressing the Enter key with a
row selected or double clicking the row also opens the fee.)

New Fee Opens the Fee dialog with blank/default values to create a new fee for this
member.

Delete Fee Removes the selected fee. This process requires a confirmation.

Show Filters the data in the grid. Choose to show All Fees, Paid Fees, or Unpaid
Fees. In Year: limits records to fees in the selected club year.

Open
Member

Opens the selected member whose individual data is then displayed in the 
Member Window.  (Pressing the Enter key or double clicking the row also
opens the member record.)

Waive
Fee(s)

Waives any balance on the selected Fee(s). This creates a payment record
of type "Waived" and lists your club name as the Payor.

Not Rcvd Marks the selected fee item(s) as not having been received by the member
yet.

Open
Inventory
Item

Opens the selected item in the Inventory Item window.  (Pressing the Enter
key with a row selected or double clicking the row also opens the inventory
item.)

In the grid, expand a fee's row to see all of the payments that have been applied to it.

Manipulate the grid as explained in working with grids.
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Payments

  When members bring money for items like dues, books, and uniforms, keep track of exactly who
paid and for what. Use the top section of the Household Ledger to post payments.  Fee records are not
required before posting a payment.  If a payment is posted that is not applied to a fee, it will be tracked
as an "Unapplied" payment amount that can be applied later when fees are created.  This is common at
the beginning of a club year when registrations and payments might be accepted before fees are created.

Posting a Payment

1. Enter the following information in the top portion of the Household Ledger window:

Payment Type - Cash, Check, Credit Card, Debit Card, Discount, Money Order, Online,
Other, Waived

If a member cannot afford to pay for any item, or if your Awana Program routinely purchases items
for clubbers, waive the fee by applying a payment to a fee and setting its Payment Type to Waived.

Amount - total money paid.

Date Received - defaults to the current date.

Reference - any additional information that is useful in referencing the payment.  For example,
a Check #.

Payor - person making the payment.

Payors in each household will be remembered and displayed in the drop-down list.

Note - any additional information related to the payment.
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2. Select how to Apply the payment. Choose one of the following:

 to ALL unpaid fees - AWdb will logically consider all unpaid fees and apply the payment to
any non-dues fees first.  It will continue applying a payment to each fee until the money is spent.
 If all fees are paid and there is money remaining, an Unapplied Payment will be created.

STARTING with the fee(s) selected below - From the Fees for [club year] tab, select at
least one fee for the payment to cover.  If there is money remaining after the selection(s), AWdb
uses the same logic as above to cover the other fees.

ONLY to the fee(s) selected below - From the Fees for [club year] tab, explicitly select
the fees to which the payment will be applied.  If there is money remaining, an Unapplied
Payment is created.

EVENLY distributed to the fees selected below - From the Fees for [club year] tab,
explicitly select the fees to which the payment will be distributed.

The amount to be applied to each payment is shown in the top section of the dialog under the
payment type field.

to NONE of the fees (just post the payment) - The entire amount of the payment is used
to create an Unapplied Payment.

3. Click Post the Payment. The Total Paid and Balance at the bottom of the Fees grid are
adjusted.  The payment is added to the Payments grid. If there is money remaining after paying
the fee(s), an unapplied payment is added to the Unapplied Payment grid.
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Payments Toolbar

Icon Action Description

Save Saves changes made to payment details. There is no Payment
dialog. Payment details can be edited directly in the grid. The
following fields are editable: Date Rcvd, [Payment] Type,
Reference, Payor, Note

If one of those columns is not showing, learn how to show/
hide columns.

Delete Payment Removes the selected payment(s). A confirmation is required.

Unapply Payment Removes the association(s) of the payment to all fees.

Unapply Payment on
selected Fee

Enabled if a single fee is selected. Removes the association of
the payment to only the selected fee instead of all of the fees.

In the grid, expanding a payment's row shows all of the fees to which it was applied.

Unapplied Payments

The Unapplied Payments tab displays any payments (or portions of payments) that have not been
applied to a specific fee.  This could occur if a member pays more than the fee amount due in order to
set the extra aside for future fees or when posting payments at the beginning of the club year before fees
are created. The fee can then either be used as a payment or applied as a donation.
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To use an unapplied payment for an existing fee:

1. Select the unapplied payment to use.

2. Click Use the payment amount.  The top portion of the window is filled in with information
from the payment. Continue as explained for Posting a Payment.  Once the Post the Payment
button is clicked, the Total Paid and Balance are adjusted on the Fees grid, the Unapplied
amount is adjusted on the Payments grid and the selected unapplied payment is removed from
the Unapplied Payments grid.

Click Clear the pre-filled values from payment area above to cancel the use of the payment
amount if needed.

To apply an unapplied payment as a donation:

1. Select the unapplied payment to use.

2. Click Apply this amount as a donation and answer "Yes" in the confirmation dialog. A Fee
record will be created with an Item Number of "Donation" for the unapplied amount. The
payment will then be applied to the new "Donation" fee.

This is an easy way to handle an unapplied amount when a parent overpays and says to keep the
additional amount.
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13 The Awards Module

  The Awards Module provides a big picture view of awards earned by all members. The default view
limits the records displayed to those earned on the Current Club Date. A different club date can be
selected or choose "All Dates".  New award records can be created from here, but manually creating
awards is not generally necessary since awards are generated automatically during recordkeeping.

If the default for the Awards Message Dialog is set to the award is not received, then after handing out
the awards, multi-select records in the Awards Module grid and click the Rcvd button.

While the Awards list is convenient for on-screen viewing, a more formal Awards report can be
generated from the Reports Module for Directors or Commander to use when presenting awards.

Icon Action Description

Open Award Opens the selected award in the Award dialog.  (Pressing the Enter
key with a row selected or double clicking the row also opens the
award.)

New Award (Ctrl-N) Opens the Award dialog with blank/default values to create a new
award.

Delete Award(s) 
(Ctrl-D)

Removes the selected award(s).
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Show Filters the data in the grid. Choose to show All Awards, Not
Received or Received awards. Earned in Year limits records to
awards earned in the selected club year.

Open Member Opens the member record for the person who earned the selected
award.

Rcvd Marks the selected award(s) as having been received by the member.

When marking awards Received, set Date Rcvd to: defaults to the
current club date. When working with awards received on a different
date, change the date before clicking the Rcvd button.

Not Rcvd Marks the selected award(s) as not being received by the member
yet.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

13.1 The Award Dialog

Opening or creating an award opens the Award dialog to view, modify or enter the details of an
award.

Most awards are triggered and created automatically so do not need to be manually entered.  This is
especially true for Cubbies, Sparks, and T&T clubs.  Trek and Journey clubs usually only have book-level
awards triggered, along with cumulative book awards such as Excellence, Timothy, Citation etc. 
However, other awards can be added using the Award dialog.
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Member Name - person who earned the award.

Award Name -selection includes items marked to be used in Award lists in the Inventory record.  If
an image exists, it is shown in the area below. The Item Number is displayed to the right of the
image. 

If the correct award is not available in the drop-down list, open the award item from the Inventory
Module and click on the Club Usage tab.  Select Use this item as a choice in any AWARD related
drop-down list.

Award Source - what caused the award to be earned: Achievement, Book, Church
Attendance, Club Attendance, Donation, Event, Other, Section, Section Group, Service,
Training.

Book Name - enabled when the Award Source is set to Book, to indicate the relevant book for
the award

Date Earned - defaults to the current club date but can be changed.

Club Year - filled in automatically. Verify that it is correct or make changes if needed.

Received - if Yes is selected, the Date Received field is enabled.

Note - any additional information related to the award.

Action Buttons

Save and Close - saves the record and closes the dialog.

If additional awards need to be created, instead of clicking Save and Close, use either New Award
Same Member or Same Award New Member, as mentioned below.

Cancel and Close - exits without creating a new record or saving changes to an existing one.

New Award Same Member - saves the award then selects the same Member Name and resets
the other fields to blank to begin entering another award.

This is especially useful when entering historical records when getting started.

Same Award New Member - saves the award and leaves all of the award information the same
except for the Member Name which is left blank. Select the Member Name and edit any of the
other fields as needed.

The award item's Qty in Stock is reduced when the award is saved if the automatic inventory reduction
feature is turned on and a matching Inventory record exists.
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14 The Events Module

  The Events Module provides a way to track the events members have participated in.  Add, delete,
view or modify records.  Some popular events are provided by default. Customize additional event names
under Admin > Generic Lookups > Events and associate awards with those events under Admin >
Awards > Event Awards.

Icon Action Description

Open Event Opens the selected event in the Event dialog.  (Pressing the
Enter key with a row selected or double clicking the row also
opens the event.)

New Event (Ctrl-N) Opens the Event dialog with blank/default values to create a
new event. 

Delete Event(s) (Ctrl-D) Removes the selected event(s).

Show Filters the data in the grid based on Club Year.  Defaults to the
current club year but can be changed.

Open Member Opens the member record for the person who participated in
the selected event.

Grid Tools Lists actions related to the grid such as: saving or resetting a
grid layout, or exporting data.
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14.1 The Event Dialog

  Opening or creating an event opens the Event dialog to view, modify or enter details of an event.

Member Name - person who participated in the event.

Event Name - selection options are determined by Admin > Generic Lookups > Events.

Awards associated with the event are shown in the lower section of the dialog.

Location - where the event took place.

Event Date - date the event took place.

Club Year - filled in automatically. Verify that it is correct or make changes if needed.

Note - any additional information related to the event.

Awards

When creating a new event, if an award was earned, indicate the following:

Awards earned by this member for this event - selection options are determined by Admin >
Awards > Event Awards.

Award Received: selecting Yes enables the Date Received.

For existing events, use the Awards Module to add an event award or edit details of the event award.

Action Buttons

Save and Close - saves the record and closes the dialog.

If additional events need to be created, instead of clicking Save and Close, use either New Event
Same Member or Same Event New Member as mentioned below.
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Cancel and Close - exits without creating a new record or saving changes to an existing one.

New Event Same Member - saves the event then selects the same Member Name and shows
any previous event awards earned by the member to begin entering another event.

Same Event New Member - saves the event and leaves all of the event information the same,
except for the Member Name, which is left blank.  Select the Member Name and edit any of the
fields as needed.
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15 The Contacts Module

  Sometimes leaders contact clubbers outside of regular club time, such as making a home visit, a
phone call, or sending a “Get Well” card to a sick clubber.  The Contacts Module tracks all these contacts.

Icon Action Description

Open Contact Opens the selected contact in the Contact dialog.  (Pressing the Enter
key with a row selected or double clicking the row also opens the
contact.)

New Contact 
(Ctrl-N)

Opens the Contact dialog with blank/default values to create a new
contact.

Delete
Contact(s)   
(Ctrl-D)

Removes the selected contact(s).

Show Filters the data in the grid based on Club Year.  Defaults to the current
club year but can be changed.

Open Member Opens the member record for the person who was contacted in the
selected record.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout,
or exporting data.
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15.1 The Contact Dialog

  Opening or creating a new contact opens the Contact dialog to view, modify or enter details of a
contact.

Member Name - person who was contacted.

Contact By - person who made the contact.

Contact Type - selection options are determined by Admin > Generic Lookups > Contact
Types.

Purpose - selection options are determined by Admin > Generic Lookups > Contact
Purposes.

Contact Date - defaults to the current date but can be changed.

Club Year - filled in automatically. Verify that it is correct or make changes if needed.

Contact Code - a short "tag" to identify particular records as needed.  This Code column can be
made visible in the main Contact list grid.

Note - any additional information relevant to the contact.

Actions

Save and Close - saves the record and closes the dialog.

If additional contacts need to be created, instead of clicking Save and Close, use either New Contact
Same Member or Same Contact New Member as mentioned below.

Cancel and Close - exits without creating a new record or saving changes to an existing one.

New Contact Same Member - saves the contact then selects the same Member Name to begin
entering another contact.

Same Contact New Member - saves the contact and leaves all of the contact information the
same, except for the Member Name, which is left blank.  Select the Member Name and edit any
of the fields as needed.
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16 The Donations Module

 The Donations Module provides a way to track donations to your club, adopted clubs, or other funds
as well as associated awards. Customize the funds under Admin > Generic Lookups > Donation
Purpose/Funds.

Icon Action Description

Open Donation Opens the selected donation in the Donation dialog. 
(Pressing the Enter key with a row selected or double
clicking the row also opens the donation.)

New Donation (Ctrl-N) Opens the Donation dialog with blank/default values to create
a new donation.

Delete Donation(s) (Ctrl-
D)

Removes the selected donation(s).

Show Filters the data in the grid based on Club Year.  Defaults to
the current club year but can be changed.

Open Member Opens the member record for the person who made the
selected donation.

Grid Tools Lists actions related to the grid such as: saving or resetting a
grid layout, or exporting data.
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16.1 The Donation Dialog

 Opening or creating a new donation opens the Donation dialog to view, modify or enter details of a
donation.

When the Check-in Module's Offering field is used to track an amount given by a member, a Donation
record is created for the member and fund. When a Donation record is opened that was automatically
created, a message will be displayed (as shown in the screen capture below).

Set the Fund to be used for a particular club date under Admin > Club Setup > Club Calendars.

Member Name - person who made the donation.

Amount - the total money donated.

Received - defaults to the current club date but can be changed.

Club Year - filled in automatically. Verify that it is correct or make changes if needed.

Purpose/Fund - selection options are determined by Admin > Generic Lookups > Donation
Purpose/Funds.

Note - any additional information to track for the donation.

Awards

When creating a new donation, an award can be assigned to the member as follows:

This feature is especially useful for participation in Adopt-a-Club.

For existing donations, use the Awards Module to add a donation award or edit details of the donation
award.
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Awards earned for this Donation - select the award from the drop-down list. Awards previously
earned are shown at the bottom of the dialog to aid award selection.

If the correct award is not available in the drop-down list, open the desired award item in the 
Inventory Module and click on the Club Usage tab.  Select This item is a donation-related Award
under Use this item as a choice in any AWARD related drop-down list.

Award Received - when Yes, enter the Date Received.

Actions

Save and Close - saves the record and closes the dialog.

If additional donations need to be created, instead of clicking Save and Close, use either New
Donation Same Member or Same Donation New Member as mentioned below.

Cancel and Close - exits without creating a new record or saving changes to an existing one.

New Donation Same Member - saves the donation then selects the same Member Name to
begin entering another donation.

Same Donation New Member - saves the donation and leaves all of the donation information the
same, except for the Member Name, which is left blank. Select the Member Name and edit any of
the fields as needed.

16.2 Adopted Clubs

  The Adopted Clubs page of the Donation Module maintains the list of clubs supported by your
Awana Program.
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Icon Action Description

Open Adopted Club Opens the selected club in the Adopted Club dialog. 
(Pressing the Enter key with a row selected or double
clicking the row also opens the club record.)

New Adopted Club (Ctrl-N) Opens the Adopted Club dialog with blank/default values to
create a new Adopted Club.

Delete Adopted Club (Ctrl-
D)

Removes the selected adopted club.

Grid Tools Lists actions related to the grid such as: saving or resetting
a grid layout, or exporting data.

16.2.1 The Adopted Club Dialog

  Opening or creating a new adopted club record opens the Adopted Club dialog.  This is a simple
dialog for collecting the information about a club that your Awana Program has adopted.  Once the data
is filled in, click OK to save the Adopted Club, or Cancel to close without saving the changes.
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17 The Reports Module

The Reports Module provides access to predefined formal reports that can be generated for leaders, club
directors, commanders and pastors. Although the options for each report are slightly different, the steps
for generating them are basically the same. This chapter provides basic instructions. Experimentation
with the options is the best way to learn how to maximize the information from the reports.

1. Click on the Reports tab in the Main Window to display the report titles in alphabetical order along
with detailed descriptions of each report.

If the descriptions are no longer needed, click the Hide Descriptions button. The size of the columns
can also be adjusted.  Use the Grid menu to Save the Current Grid Layout.

2. Click Open the Selected Report on the toolbar or double click a report name to open the Report
Dialog.

The Report Dialog along with examples of each generated report are shown in the following sections. 
Each report type has different options that are applicable for running that report.  The options used in
the dialog are saved when the dialog closes and are reloaded the next time it is opened.

3. Set the Selection Criteria - options for what groups to include in the report. This varies by report,
but many include: Club Name, Team Name, Member Type, and Member Status. For some
reports, the selection criteria includes a Date Range.

4. Select Grouping and/or Sorting Options - many reports provide radio buttons on the right to
indicate how results should be grouped and/or sorted.

5. Choose Additional Options - some reports have additional unique options.  For example, several
reports allow for shaded rows, and provide a color selection option for selecting the shading color.
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6. Click Preview - displays the report results to ensure that the desired data set is generated.

The Preview and Print buttons are disabled until necessary options are chosen.

7. Click Print - opens a typical Print dialog.

Select which printer to use, which pages to print and the number of copies.

When the Printer settings are complete, click OK.  The report will print.

Any report output can be sent to an external file suitable for e-mailing.
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17.1 Achievement Report

This report provides information on number of completed sections and points earned (for both required
and extra credit sections) within a specified date range. There are three types of achievement reports:

1. Individual members are listed for each club date within the range specified.

2. Individual members are listed only once along with their grand total of sections and points.

3. Individual members are not listed, only the bottom line totals for each group are shown.

Report Dialog
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Example Output

Report Type # 1

Report Type # 2

Report Type # 3
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17.2 Attendance Report

This report shows a chart of Total Club Attendance (year-to-date) as well as a detailed breakdown of
attendance counts (clubbers, leaders and visitors) by club for each week.

Report Dialog

Example Output
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17.3 Attendance and Dues Worksheet

This report uses check boxes to show Club and/or Church Attendance. Information about Dues payments
can also be included.  It can be used as a worksheet to collect information or a report to reflect history.

Report Dialog

Example Output
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17.4 Award List

This report lists information related to awards earned by members such as award name, earned date,
received status and received date as well as a note explaining what was completed to earn the award.

Report Dialog

Example Output
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17.5 Birthday List

This report provides a list of members with birth dates in a selected range and includes the member's
club, gender, birth date, age and address.

Report Dialog

Example Output
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17.6 Check-in and Progress Report Worksheet

This report produces a customizable worksheet for recording attendance and check-in information as well
as completed sections.

Report Dialog

Example Output
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17.7 Clubber List - Contact Information

This report provides detailed contact information for clubbers including Clubber Information, Parents/
Guardian Information and Household Contact Information. It can also be used to get contact information
for visitors from a specific club date while the Member Status is still set to "Visitor".

Report Dialog

Example Output
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17.8 Completed Handbooks

This report lists active members who have completed handbooks within the club year or date range
specified. It also includes information pertaining to any corresponding awards.

Entrance Booklets are excluded from the report output.

Report Dialog

Example Output
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17.9 Current Handbook Status

This report provides a way to evaluate progress in currently assigned handbooks.  There are three types:

1. Summary - No individual sections are listed. Statistics such as Required Sections Complete and
Average per Week are shown for each current book. Estimated completion dates and awards due
upon completion are also given to assist in year end planning and ordering supplies.

2. Detail - Lists all sections in the member's current handbook along with the date completed.  A
separate page is printed for each member.  This can be used as a report or a worksheet.

If there is an entrance booklet and main handbook both marked as "current", with the option to
"Include Entrance Booklets" checked, sections for both will print on the same page.

3. Quick View - shows each member's club and current book followed by a bar graph representing
progress in completing the required sections.

Report Dialog
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Example Output

Report Type: Summary

Report Type: Detail

Report Type: Quick View
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17.10 Household Account Statements

This report provides a summary of household Fees and Payments suitable to use as an invoice.

Customize the opening paragraph text under Admin > Options > Fees and Dues > Account Statement.

Report Dialog

Example Output
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17.11 Household List - Contact Information

This report provides address and contact Information for Households. It includes the Family Church and a
list of all members in the Household.  (External IDs can optionally be shown.)

The External IDs are optional fields on the Member Window's Main tab.  To make them visible , go to Admin
> Options > Members and check the box next to "Show the external ID fields on the Member form".

Report Dialog

Example Output
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17.12 Household and Member ID List

This report lists user-assigned External IDs and household names along with parents and others
authorized to pick up clubbers. All Household members are listed. It can be used as a sign-out sheet.

To enter External IDs, under Admin > Options > Members, check the box to "Show the external ID fields on
the Member form".  The Member Window's Main tab will then display the external ID fields.

Report Dialog

Example Output
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17.13 Leader List - Contact Information

This report provides detailed contact information for leaders including Mailing Name and Address as well
as other (phone and e-mail) Contact Information.

Report Dialog

Example Output
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17.14 Leader Service History

This report provides information pertaining to a leader's history of service.  There are two types of
Leader Service History reports available:

1. Detailed - Includes Name, Total Years of Service and Service Pin years with details for each year.

2. Summary - Includes Name, Total Years of Service and Service Pin years.

Report Dialog
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Example Output

Report Type: Detailed

Report Type: Summary
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17.15 Leader Training History

This report provides information pertaining to a leader's training and qualifications including descriptions,
completion status and dates.

Report Dialog

Example Output
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17.16 Mailing Labels

This report will produce mailing labels for either: Households, All Members, Clubbers Only, or Leaders
Only. The output is formatted for 1" x 2 5/8" 30/page sheets of mailing labels (such as Avery 5160 or
8160). It provides flexibility in selecting members (even visitors) that were either absent on a given club
date or present within a particular date range. This makes it very quick and easy to generate labels for
postcards to send to absentee clubbers or new visitors.

Report Dialog

Example Output
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17.17 Medical List

This report lists information that might be needed for members with medical concerns including name,
contact information, medical notes, as well as doctor and dentist info.

To be included in this report, the "Include on Medical Listing" check box must be selected on the
Member's Misc. tab.

Report Dialog

Example Output



The Reports Module 179

© 2021 Leffler Systems

17.18 Member List with Photos

This report provides a directory style list of members.  In addition to the photo, the following is included:
name, address, phone numbers, club and team names. For clubbers, age, date of birth, grade and
parent names are also included.

Report Dialog

Example Output
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17.19 Member Profile

This report includes some member details and contact information followed by a list of all assigned books
and awards earned.  Attendance data and detailed handbook status pages for "current" books can also
be included. This report can be used to share information when a clubber transfers to another club.

Report Dialog

Example Output
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17.20 Name Tags

This report prints Name Tags/Badges according to the specifications selected.

The Code field is useful as a subtle way to identify clubbers with food allergies, special needs or if there are
security concerns.

Report Dialog

Example Output  
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17.21 Point List and Worksheet

This report lists net points earned by members. It can be especially useful for Store Night since it can be
used by the Store Keeper as a worksheet to track the number of points spent, and then returned to the
Club Secretary for data entry.

To enter the number of points spent, select Tools > Club Store from the Main Menu bar.

Report Dialog

Example Output
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17.22 Receipts Report

This report provides a listing of Payments grouped by Date Received and Type. The Report Summary
shows how much was applied to Dues related Fees versus all other Fees. It also includes amounts for
Offerings/Donations.

This report can be useful to the Treasurer to account for monies received.

Report Dialog

Example Output

Report Type: Summary
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Report Type: Detail
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17.23 Registration Form

This report creates blank or pre-filled forms for registering clubbers and/or leaders for a new club year.

Customize parts of the Registration Form under Admin > Options > Registration Form.

If printing pre-filled registration forms for a new club year, run the New Year Setup first.

On the report dialog under Options, choose a custom report title for VBS, Camp or other registration.  See
the information about how to use AWdb to track VBS or other summer programs.

Report Dialog



Approved Workman Database 5.9 - User Guide186

© 2021 Leffler Systems

Example Output

Pre-filled Clubber Registration Form
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Pre-filled Leader Registration Form

17.24 Visitor List

This report lists visitor information including name, date of the visit, club visited and the name of the
member who brought the guest.  There are three types of Visitor Reports:

1. List each member that brought a visitor, followed by the name of the visitor and the date of the
visit.

2. List each visitor, followed by the "brought by" member and the date of the visit.

3. List each club date along with the total number of visitors (no member or visitor details).
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Report Dialog

Example Output

Report Type #1
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Report Type #2

Report Type #3
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18 The Inventory Module

  The Inventory Module contains records for all items in the Awana Ministry Supply Catalog. It helps
track supplies of books, uniforms, awards, store items, game supplies, etc. By setting re-order levels, the
Inventory Module will proactively add items to an Order when the quantity in stock gets low.

The Order is not automatically transmitted to Awana ordering.  You will still need to submit it.

Example of automated inventory: with Inventory Tracking preferences set, when an award record is
generated, the award item is deducted from the item's quantity in stock.  If the item's quantity is low
enough to trigger an order, it is added to an open order or a new order is created.  After placing the
order, when the item is received, the item's quantity in stock is increased.

The Inventory page manages Items and Orders.  For an overview, see Working with Inventory.

18.1 Items

  Click on the Inventory > Items tab to open, add, or delete inventory items.

AWdb periodically updates the inventory, so it’s unusual to need to add a new item.  However, it could
come in handy for adding an item not issued by Awana Clubs International.
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For items that you don't use,  use the search tool or filters to find them and mark them as Not In Use. 
(To speed up the process, select multiple items and mark them all with one action!) 

Toolbar

Icon Action Description

Open Item Opens the selected item in the Inventory Item window.  (Pressing the
Enter key with a row selected or double clicking the row also opens the
inventory item.)

New Item      
(Ctrl-N)

Opens the Inventory Item window with blank/default values to create a
new inventory item.

Delete Item(s) 
(Ctrl-D)

Removes the selected item(s). We recommend not deleting items.
Instead, set the item as being "Not in Use".

Search
Inventory

Filters the grid to show only those items whose Description or Item #
matches the search criteria entered in the text field.  (You can also press
the Enter key to perform the search/filter.)

Show Filters the data in the grid based on All Items, Items we use, or
Items we do not use.
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Add Item to
Order*

Adds the selected item to an open order.  A new Order will be created if
there is not one currently open.

Mark Item(s)
as In Use*

Marks the selected item(s) as one(s) that your Awana program uses.

Mark Item(s)
as Not In Use*

Marks the selected item(s) as one(s) that your Awana program does not
use.

Set Expense
Category*

Sets the expense category for the selected item(s).

Grid Tools Lists actions related to the grid such as: saving or resetting a grid layout,
or exporting data.

* These items are available from the Action drop-down menu on the Toolbar.

Many of the actions are also available through the right click pop-up menu.

18.1.1 The Inventory Item Window

  Opening or creating a new Inventory Item opens the Inventory Item window to view, modify or
enter details of an item.
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Toolbar

Icon Action Description

Close Closes the Item Window without saving current changes.

Save and Close Saves the changes and then closes the Item Window.

Save Saves the changes and leaves the Item Window open.

Add to Order Adds the selected item to an open order.  A new Order will be created if
there is not one currently open.

Open Order Opens the relevant order if the item is On Order. The button is disabled
if the current item is not On Order.

Delete Item Removes the item(s). We recommend not deleting items. Instead, set
the item as being "Not in Use".

Sort Determines the sort order by Item Number or Item Description
based on selection from the drop-down list.

Navigation
Buttons

Provides navigation options to other items in the same window.

Located in the top right corner.  Changes made to the current record
will be automatically saved. 

Refresh Refreshes the data currently displayed in the Item Window.

Stay On Top Toggles whether or not the window stays on top of the main window.

General Item Information

The general information is located above the tabbed panel and includes:

Item # and Description - for items from Awana Clubs International, these fields match the
information in the Awana catalog. For items you buy elsewhere, set as desired. The search box
works on these fields.

Pkg Qty - number of items that come in a package. For example, if there are 5 in a package, an
order of 1 of that item results in 1 package with 5 items in it. The default is set to 1.

Cost - amount used when an item is placed in an order.  It should match Awana's current catalog
price, if applicable.

Sell Price - amount used when a fee is created.

If your club does not have a large budget, consider slightly increasing the Sell Price of items like
uniforms and books to help cover shipping costs.
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Qty in Stock - number of the item you currently have.  The default is 0.  If Inventory Tracking
preferences are set, this value is adjusted automatically as items are depleted by assigning books,
when awards are earned, or when manually creating a fee (such as for a book bag).  It is increased
when the Status of an Order is set to Received and individual items are marked received.

Category - drop-down list which is populated based on Admin > Generic Lookups > Inventory
Categories. 

This is especially useful when filtering the Item grid.

Image -  for items from the Awana Catalog, the image will be provided.  It can be modified by right
clicking on it to paste or load an image from a file.

Detailed Description

The main area in this tab is for a detailed description of the item.  This will normally match the text found
in the Awana Catalog.

It is not unusual for Awana Clubs International to introduce new items in their catalog. Some items will
replace older items, making the older item obsolete.  It could get confusing to maintain, but by renewing
the AWdb Support Plan each year, these details will all be maintained.  Otherwise, this is where to enter
the Status in the catalog, Supersedes Item #, and Superseded by # information.

Ordering

The Ordering tab provides information related to the ordering of an item.

Vender Name - selection options are determined by Admin > Generic Lookups > Vendors.

A multi-pack is available if ordered using the following Item # - indicates a multi-pack should
be ordered instead of single items, when available. Fields for the details of the multi-pack are
enabled when the option is selected.

Obsolete do not order - indicates an item is no longer available. When checked, the fields below
it are disabled.

When Qty in Stock of Item # is:, Order a Qty of: - for items that are not obsolete, with
Inventory Tracking options turned on, these fields indicate when the item should be added to an
order and how many to order.
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Club Usage

The Club Usage tab includes information on if and how an item is used in your club.

This is an item we use in our club - indicates the item is one you use.

Items can also be marked as 'in use' or 'not in use' on the Main Inventory Items grid by selecting items
and using the Action menu or right click pop-up menu. Multi-selecting records speeds up the process.

Use this item as a choice in any AWARD related drop-down list - indicates the item will be
included in any drop-down list used for choosing awards. When checked, selection of a Book-level
Award or Donation-related Award can also be indicated.

Use this item as a choice in any FEE related drop-down list - indicates the item will be
included in any drop-down list used for choosing fees, such as the Fee dialog.

Use this item as a choice in any UNIFORM related drop-down list -indicates the item will be
included in any drop-down list used for choosing uniforms, such as the Assign Uniform dialog.

This is used for the Annual Dues for Club Year: - indicates payments for dues for the specified
year should go towards this item.

The Fee for dues will generally be added during an update so this would only be necessary if you add
a fee for dues yourself.

The relevant Base Club Name (if any) is: - indicates the club that generally uses the item.

This is especially useful when filtering the Item grid.

The default Expense Category Name is: - selection options are determined by Admin >
Generic Lookups > Expense Categories. 

This helps in filtering and/or grouping Fee and Line Item records to get Expense Category totals.

The expense category can also be set on the Main Inventory Items grid by selecting item/s and then
using the Action drop-down, or the right click pop-up menu.

Notes

Use this area to track any additional information related to the item.
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18.2 Orders

  The Inventory > Orders tab tracks past orders, allows creation of new orders and modification
of "Open" orders. The grid's footer shows details about orders placed, items ordered and money spent
on all orders. [Also, amount spent on shipping. (There's an eye-opener!)]

By managing your inventory closely, you can be proactive with orders, reducing the number of orders
and thus saving a significant amount on shipping over a club year.

Creating an order in AWdb does not actually place the order with Awana Clubs International.  It is only a
tool to help in the process.

Icon Action Description

Open Order Opens the selected order in the Order window.  (Pressing the Enter
key with a row selected or double clicking the row also opens the
order.)

New Order (Ctrl-N) Opens the Order window with blank/default values to create a new
order.

Delete Order (Ctrl-D) Removes the selected order.

Show Filters the data in the grid based on Club Year.  Defaults to the
current club year but can be changed.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.
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18.2.1 The Order Window

  Opening or creating a new Order opens the Order window to view, modify, or enter details of an
order.

Creating an order within AWdb does not actually place the order with Awana Clubs International, but
can assist in placing the order.

Toolbar

Icon Action Description

Close Closes the Order Window without saving current changes.

Save and Close Saves the changes and then closes the Order Window.

Save Saves the changes and leaves the Order Window open.

Delete Order Removes the current Order.

Print Preview Displays the order in a format appropriate for e-mailing or faxing to
Awana Clubs International. It uses the information under Admin >
General > Supply Order - Default Values page. Printing is done
from the Preview window.
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Edit Contact Info Opens a dialog to edit the Contact and Ship To information for this
order which will override the Admin > General > Supply Order -
Default Values.

Refresh Refreshes the data currently displayed in the Order Window.

Stay On Top Toggles whether or not the window stays on top of the main window.

Order Information

The general information about the order is located just below the toolbar and includes:  

Club Year - defaults to the current club year but can be changed.  The Inventory's Order grid can
be filtered on the Club Year to list only orders within the selected club year.

Order Date - defaults to the current date but can be changed.

Purchase Order, Order Method, Shipping Method, Vendor Order #, Invoice # - details
relevant to the order.

The Shipping Method values are customizable under Admin > Generic Lookups > Shipping
Methods. Set a default for the Order Method and the Shipping Method under Admin > General
> Supply Order - Default Values.

Order Status - defaults to Open when a new order is created. Options include: Open,
Submitted, Received, or Closed.  The status determines what functionality is available. See the
Line Items section below for details on changes based on status.

Submitted date - set automatically when Order Status changes to Submitted, but can be
changed.

Comments - notes to be printed on the order form. This is useful if the order is mailed, e-mailed or
faxed.

Invoice Paid - indicates the invoice has been paid.  Enter additional information in the Payment
Reference field.

Notes - additional information related to the order that does not need to be printed on the form.

Sales Tax and/or Shipping/Handling costs - enter the amounts. The Total for the order is
automatically calculated.



Approved Workman Database 5.9 - User Guide200

© 2021 Leffler Systems

Contact and Ship To Information

 The default Contact and Ship To information used on most orders should be set under Admin >
General > Supply Order - Default Values. To use different contact and shipping information on the
current order, click Edit Contact Info to display a dialog for setting those values.

Line Items

  The line item grid behaves differently depending on the Order Status value as follows:

1.  Open - indicates the order has not yet been placed. This is the default when the order is created.
Line items can be added to the order. Each item should have a line item entry in the grid. The
following tools are used while the Order is Open to add the line items:

Icon Action Description

New Line Item Creates a new row. Either select from the drop-down list or type an
Item Number or Description. Update the Expense Category and
Qty Ordered fields if needed. The Line #, Pkg Qty, Cost, and
Extension are filled in automatically.

The Item Number or Description must match an item in the
Inventory Module.  As you type, the list will be filtered accordingly. If
no match is found, a Warning dialog appears.

Changing the Cost value in the line item will change the Cost in the
Inventory Item also! This makes it easy to keep up with mid-year
price changes.

Save Line Item Saves the changes to the Line Item.

Delete Line Item Removes the selected Line Item from the Open Order.

New Inventory
Item

Opens a blank Inventory Item Window to create a new item if an item
does not exist that needs to be added to an order.  Once the item is
created, then click the New Line Item button to add it to the order.
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Open Inventory
Item

Opens the selected item in the The Inventory Item Window in order
to see more details.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

2. Submitted - indicates the order has been placed. Setting this status fills in the Submitted date. It
prevents line items from being added, changed or deleted.

3. Received - indicates the order has been delivered. Setting this status adds the Rcvd, Qty Rcvd
and Qty on B/O (Quantity on back order) columns to the grid. As an item is marked as Rcvd, the
Qty Rcvd defaults to the total Qty Ordered and the Qty on B/O defaults to zero.  If an item was
back ordered, update these values as needed. As each Line Item is marked as received and posted,
the quantity received is automatically added to the Item's Qty in Stock.

Inventory item cost values can be updated by making corrections to the Cost field for a Line Item on the
Order Form. If adjustments need to be made to a cost while checking in received orders, make the
correction on the line item and the new cost will be updated in the matching Inventory Item record.

 

4. Closed - indicates everything related to the order is completed. Setting this status prevents the line
items from being modified.
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Expense Categories

The Expense Category field identifies a budget category for each item. The default value is based on the
corresponding Inventory Item record's Expense Category value, but can be changed in the Line Items
grid.  The selection options are determined by Admin > Generic Lookups > Expense Categories.

To quickly get a total of how much is being spent on an order from various budget categories, drag the
Expense Category column header into the grouping area above the grid. (Note: If the Group By box isn't
showing, click the Grid button in the toolbar and select "Show Group by box".)

If not using the Expense Category feature, go to Admin > Options > Inventory and Ordering. Clear
the check box for "When adding new line items to an Order, display the Expense Category
columns and populate it with the default value as set in the related inventory record".



Chapter

19



Approved Workman Database 5.9 - User Guide204

© 2021 Leffler Systems

19 The Admin Module

Since there are many ways to run an Awana Program, there are many ways to customize AWdb. The
Admin Module provides lots of customizing options. Be sure to explore each tab!

When using Check-out/Check-in, all tabs are not shown in a Secondary Database.  Also, only "Admin"
users will see all the tabs. Non-Admin users will only have access to some Database Utilities.

General - pages for Club and Church Info, Local Awana Missionary, Supply Orders and Notes

Generic Lookups - custom values used in many drop-down lists throughout the application

Awards - settings for Book, Attendance, Event, Leadership Service and Journey Pin award triggers

Options - customizable settings that affect how the database works in a variety of situations

Curriculum - details for all generic handbooks including specific Section Group Awards; includes the
Set Point Values utility used to globally modify handbook section point values

Users - user accounts for all persons who will be granted access to the database

Club Setup - overview of Club Names, Logos, Dues and Points; Club, and Grade Assignments; Team
Names, and Custom Fields. The New Year Setup process creates the Club Calendar records. Themes,
Offering Funds, Notes and Responsibilities for each week can be set under the Club Calendars tab.

Database Utilities - tools for managing the database
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19.1 General

  The General tab includes information about your Church, Awana program, and Local Awana
Missionary, the default values of Supply Orders and a place for Notes. Some of the information is for
reference purposes only.  The fields in these tabs are pretty self-explanatory.

Club and Church Info

The church's contact information given on this page is used when generating reports and creating orders.

Local Awana Missionary

The Awana Missionary information is for reference.
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Supply Order - Default Values

This information is used when creating orders from the Inventory Module.

Notes

This page is for keeping any additional or miscellaneous information you need to track.

19.2 Generic Lookups

  The Generic Lookups tab contains a list of categories of drop-down lists used throughout AWdb. 
Select a category on the left to display the selection options on the right.

Use Click here to add a new row, or the '+' (plus) below the grid, for a new record. In the
blank row, type the new value then press Enter or click the checkmark at the bottom of the grid.

Use the '-' (minus) below the grid to remove a record. Click OK to confirm deletion.

To modify a record, select the value and type the new value. Press Enter or use the checkmark to
accept the changes. Use the 'X' to cancel the changes.
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19.3 Options

 The Options tab provides a variety of customizations. These options have defaults that reflect the
most common uses among Awana programs, but allow changes to meet specific needs.

When getting started, if all of the options are a bit overwhelming, just start with the defaults.  If you ever
wish something was done differently, check back here to see if it can be changed!

Members

This tab provides options related to Member windows.

Check-in

This tab provides options that deal with the Check-in Module.

Registration Form and Reports

This tab provides options related to the Registration Forms. There are several tabs. The Clubbers and
Leaders Registration Forms can be customized individually. If the Clubbers / Leaders radio button is
available, use it to switch between each form.
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Terms and Conditions

This tab provides customization of the text in the Terms and Conditions section of either the Clubbers
or Leaders Registration Form.

Instructions and Background Check

This tab allows personalization of the instructions or background check notices to be included.

Office Use

This tab allows customization of the office-related information to include on the Registration Form.
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Alternate Medical Text

This tab provides the option to use a customized alternate text on the Clubber Registration Form.

Permission Defaults

Tis tab allows selection of which permission fields to update (on the Member form's Misc. tab) when
the registration is set to 'current'.

.

Paths

This tab allows modification to the data paths for storing various files.
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Inventory and Ordering

This tab provides options related to the Inventory Module.  See Inventory Tracking for more details.

Misc

This tab includes various options that were not included in the other tabs.

Fees and Dues

This tab contains two sub-tabs:

Main

This tab provides options related to fees and dues.
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Account Statement

This tab allows customization of the text used at the top of the Household Account Statement.

System Reminders

This tab provides options for controlling the reminder dialogs that appear during startup and shutdown.

19.4 Awards

  The Awards tab includes award triggers for handbook completion, by attendance or event
participation, and Journey Pin requirements.  By staying current with the support plan and applying all of
the AWdb updates as well as using awards offered by Awana Clubs International, these should not need
to be modified. In the rare case that updates are needed, follow the instructions below.

If an award item isn't in the drop-down list, open the corresponding item in the Inventory Module and
ensure the Use this item as a choice in any AWARD related drop-down list is selected.  Also, if
needed, select This item represents a Book-level Award below that.

If your club gives awards that are different than those purchased from Awana Clubs International, add
those items to your inventory then refer to them as instructed below. 

Book Awards

This tab manages the awards that members earn when a handbook is completed. Some book awards
are associated with a specific book, while others are based on the number of books completed.
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Book-specific Awards for all grades

This tab manages awards that are related to a specific handbook. For each Base Club selected, the
associated books are listed. When a Book Name is selected, the associated awards are displayed. 
Use the buttons below the grid to add, remove or modify these awards.

Cumulative Book Awards for grades Pre-2 (& 3-12)

When a book award is not associated with a particular book, but with how  many books have been
completed, the award association should be done on one of these pages.  Select the Club Name and
# of qualifying books then add, remove, or modify the awards in the grid on the right.
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Attendance Awards

This tab manages the awards given to clubbers when they attend Awana or Church consistently. The
awards are generated by using Tools > Attendance Awards from the Main Window's menu bar. The
grids in both the Club and Church tabs work the same way but refer to different awards.

Check the box next to each Base Club to Include it in the calculations for Attendance Awards.

Set the Term to either Quarter or Semester.

Set the number of Absences Allowed Per Term.

Select an Award Name from the drop-down list. The Award Item # will be filled automatically.

Clubs can be added or removed by using the buttons below the grid.

Event Awards

This tab manages awards earned for participate in an event. The Event Names are determined by
Generic Lookups > Events. Select an event, then use the grid on the right to add, modify, or remove
associated awards. The awards appear as options in the Event dialog when using the Event Module.
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Leadership Service Awards

This tab provides a setting for the number of times a leader must attend to earn a full service year credit
(and count toward a Service Pin).  The default is 24, but can be changed.

This requirement is evaluated each time a leader is marked 'present'.  If the leader meets the attendance
requirement, the Leader Service History record for the current club year is updated to show the service
"counts" for 1 year of service and the leader qualifies for the Service Pin Award.

Journey Pin Awards

Journey clubbers earn Achievement Pin awards for completion of requirements during each year in
Journey. This is independent from the cumulative book awards (Excellence, Timothy, etc.). This tab
provides the details for these awards.

The requirements in a given club year have changed over time.  For a while, there were 2 Study books
that needed to be completed along with Bible Readings and Service/Training items.  Later, the
curriculum returned to a single handbook. AWdb has been updated to handle those changes, but given
the number of ways an Awana club can implement the changes, there could be clubbers whose time in
Journey spans the change and makes evaluation difficult. You should be aware of the specific situation
for any given clubber to verify all requirements set by Awana Clubs International are met. 

The grid includes details for the awards based on credits for each year the requirements are met. It is
similar to the Cumulative Book Awards tab, but is limited to completed Journey items. Under the older
curriculum, completion of 2 Study guides and a Bible Reading plan (which includes the Service/Training
items) counts as 1 year credit. Under the newer curriculum, handbooks include the Bible Reading plan
and the Service/Training items so count as 1 year credit without additional requirements. The relevant
pin is awarded based on the total number of credits a clubber has earned.
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19.5 Curriculum

  The Curriculum tab displays the handbooks and other forms of curricula used in Awana.  Besides
the normal grid manipulations, there are two buttons available on the toolbar:

Open Handbook Opens the Generic Handbook Window to view or modify
information about the selected generic handbook.

Set Point Values Opens the Section Point Values Dialog to set the default point
values for sections within selected handbooks.

While the Section Point Values dialog allows modifying all of the point values for an entire book's
required and/or extra credit sections, to modify individual section point values in a handbook, use the
Handbook window.

Books

This tab displays the various handbooks used by each base club. To view a Base Club’s handbooks, click
the '+'(plus) toggle at the left of its row to expand the group. To view or modify a handbook's details,
either double click a handbook or select the row then click Open Handbook to open the generic
handbook window.

19.5.1 Generic Handbook Window

Opening a book from the Admin > Curriculum list opens the Generic Handbook window.  It can also be
opened by clicking the Open Handbook button on the Member Window > Handbooks toolbar.  This
form displays the detailed data for each handbook that can be assigned to members.  It has three tabs,
as described below.  
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General Book Information

Under the General Book Information tab, some fields are read-only and are presented for
informational purposes.  Though changes are rarely needed, the following fields do allow editing:

Inventory Items - lists inventory records for the various translations of the handbook. Any
translations "In Use" are included in the initial display of books in the Handbook Assignment
dialog.

Handbook Assignment Dialog Note - this appears in the Handbook Assignment dialog. It can
help users make the correct selection, especially if there are multiple revisions of the same
book.

This is an Entrance Booklet - indicates the book is used as an entrance booklet.

Counts toward the Cumulative Book Awards - indicates the book should be counted toward
major book awards, such as Excellence, Timothy, Citation, etc

Required Book - indicates whether or not the book is required.

Used by Grades - tracks which grades use this book.

Verse Count - shows the number of verses included in the required sections of the handbook.

Base Club Name -  the PRIMARY base club that uses the book.

Base Clubs Using this Book - all base clubs currently using the book.
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Units and Sections

The Units and Sections tab displays all the handbook sections in the book. The following fields are
editable:

Required - required sections appear on the "Required" sections tab wherever handbook
sections can be marked as completed, such as the handbook panel of the Check-in module, or
the Handbook tab of the Member form.  Sections that are NOT required are considered Review
or Extra Credit sections, and appear on the Review/Extra Credit tab.

Points - value to be awarded when the single section is completed. The maximum point value
for any one section is 100. Keep in mind that the Set Point Values utility will overwrite
individually customized point values.

Group Name - indicates what group the section belongs to. We recommend not making
changes to the Group Name values as this might impact award triggers.

Changing the required status of a section from 'Yes' to 'No' does require removing the Group
Name for that section so AWdb does not include that section when evaluating the sections for the
group award.  To remove the Group Name, click into the cell and then press the Delete button.

1st Award for completing the Single Section / 1st Award Item# - award to trigger when
the specific single section is completed.  Generally only Cubbies have values here because they
get a sticker for everything they do.

2nd Award for completing the Single Section / 2nd Award Item# - works the same as
corresponding 1st Award fields but allows a second award to be triggered when the single
section is completed.
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Section Groups and Awards

The Section Groups and Awards tab includes a grid containing the records used to trigger awards.
 Under the Units and Sections tab, each handbook section has a Group Name.  When all of the
sections with the same Group Name are completed, the corresponding award (as defined by any
records in this grid) is triggered.  When using the common award system recommended by Awana,
these should never need to be changed.

The Default Award Set might have more than one choice.  This field allows selection of which
Award Set to use when assigning books.  For many years the T&T club used the oval badges with the
bubble-like seals.  They later changed to the Streamwood badge and Bones for 3rd and 4th graders
and various patches for 5th and 6th graders. Choosing the default award set allows use of a supply of
older awards before switching to a new award set.  The default award set here determines the award
set to use when a book is assigned. Award sets for individual member's books should be managed by
opening the Member record and clicking the Handbook tab and then clicking in the Award Set field of
the assigned handbook.  

19.5.2 Section Point Values Dialog

To set the default point values for sections within selected handbooks, click the Set Point Values button
on the Admin > Curriculum toolbar to open the Section Point Values dialog.  It is best to set the
handbook section point values before the start of a new club year, but this utility can be run mid-year and
assigned handbooks will be updated. This will affect the total points already earned by all clubbers who
have completed sections, so there might be some explaining to do when the point values change!
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Step 1 – Select the generic handbooks to update

This grid displays all the Awana curricula. Click the '+' (plus) button to expand a base club and view
its handbooks. Check the box next to all handbooks to include in updating the section point values.

Step 2 – Set the point values

Use the check boxes to indicate which group of sections (Required and/or Review/Extra Credit
Sections) to modify.  Adjust the Point Values as desired for each.  The maximum point value for any
one handbook section is 100.

All Required Sections will have the same point values within a handbook, just as all Extra Credit Sections
will have the same point values.  To set the point value for a particular section of a generic handbook,
use the Open Handbook button on the Admin > Curriculum toolbar.  Then, under the Units and
Sections tab, edit the individual section point values.  Keep in mind though, that running the Set Point
Values utility shown above will overwrite any individually customized section point values.

Step 3 – Select a synchronization option

Besides updating the point values in the Generic Handbook Sections (the records used as a template
when assigning a book), this utility will update the sections for the handbooks already assigned
depending on the selected options:

All Sections - All section records, whether completed or not, will be updated, including those from
prior club years.

Some Sections - All incomplete sections, as well as those completed within the date range you
provide, will be updated.

Click Run.  The point values will be updated in the generic handbook records, and in all existing assigned
handbooks as selected in Step 3.

Since the section points have been modified, the Total Points earned by each clubber needs to be
recalculated.  After running this utility, a prompt will be given to run the Point Recalculation utility in
order to recalculate all points for all members.  Be sure to run it!
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19.6 Users

  The Users tab manages the names and account information of those authorized to use AWdb.  The
first admin user is created during the Purge Sample Data process. The admin can then set up additional
user accounts.

We recommend creating as many user accounts as there are individual persons who will have access to
the database.  Each user will be able to select a unique style (skin) and have saved customized grid
layouts.  Most records are user time-stamped when they are created and/or modified.  Having separate
user accounts for each person provides a way to investigate changes made to the data.

Do NOT use generic user accounts that are shared by more than one person.  Otherwise, users could
overwrite other user's settings and grid layouts.  You will also lose valuable information related to
creation and modification of records.

Icon Action Description

Open User Opens the selected user in the User Account dialog.  (Pressing the 
Enter key with a row selected or double clicking the row also opens
the user record.)

New User (Ctrl-N) Opens the User Account dialog with blank/default values to create a
new user.

Delete User (Ctrl-D) Removes the selected user.

There must always be at least one active admin account. Trying to
remove the last one will result in a reminder.

Instead of deleting user accounts, we recommend setting the 
Active Status to No to preserve historical user timestamps.

Log User Out Logs the selected user out of the database.



The Admin Module 221

© 2021 Leffler Systems

User Account dialog

Creating a new User record or opening an existing record opens the User account dialog.

The following fields are shown on the Main tab:

User ID - a system assigned ID. This is a read-only field.

User Name - name used to log in.  We strongly recommend using the person's First Name for
this. Generic names like "commander", "sparks", or "FBC" should NOT be used.  The User Name is
not case-sensitive so "Matthew" is the same as "matthew" as far as the log in screen is concerned.

Password - password for the user to log in.  The password IS case-sensitive, so "PassWord" is
not the same as "password" to log in.  Whatever the password is set to here, the exact same value
must be entered on the log-in screen.  Don't use "awana" for your password, everybody
guesses that one!

Confirm Password - confirmation of the password entered above.

Screen Name - unique short name, usually a user's First Name.

Full Name - user's First Name and Last Name.

Account Type - determines access to some parts of the database. Select "Administrator", "Kiosk"
or "User" from the drop-down list.  An account type of "Administrator" has full access to every
screen and function, including the ability to add or edit User records. An account type of "Kiosk"
only allows access to the Kiosk screen. An account type of "User" has full editing privileges, but will
not be able to view or access User records as well as some of the functionality under the Admin
module.  All users can change their own passwords by selecting Tools > Change Password from
the Main menu bar.

Active - indicates the status of the user account. If a user no longer needs access to the
database, instead of deleting the account, set the active status to "no" (inactive).
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Inactive Date - date the account became inactive.

E-mail Separator - determines the separator to use between e-mail addresses during the
Gather E-mail Addresses and Textible Phone Numbers procedure.  Choose either semicolons
or commas, depending on the e-mail application requirements.

Note - any additional information or notes related to the user account.

19.7 Club Setup

  To begin a new club year, follow the instructions in the New Year Setup section before continuing
here.  Once the new year is setup, or if adjustments need to be made in the middle of a club year,
continue to follow the instructions below. Each section below describes a Club Setup tab.

Club Names, Logos, Dues and Points

This tab provides an overview of the settings for each club.  It displays the general club information, such
as the Start and End Dates, the Weekday each club meets, Weekly and Annual dues, and Point Values.

Make sure the correct new Club Year is selected in the main toolbar and in the Club Setup Tab.

The first six rows contain information set by the New Year Setup process and are read-only.
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Club Name - Click in the cell to edit it. When the change is saved, all records using the old club
name will be updated to the new name.

Keep club names brief so they will be easier to read in the narrow columns of the grids.

Logical Order - numeric value to ensure that club names are sorted in logical order rather than
alphabetical. (Most users prefer a logical order of: Puggles, Cubbies, Sparks, T&T, Trek, Journey,
instead of: Cubbies, Journey, Puggles, Sparks, Trek, T&T.)

Club Status - Use the drop-down menu to change the default setting of “Active” to “Inactive”.  If it
is decided to not offer a certain club after running the NYS, inactivate it.  (Or select the club’s entire
column and click the Delete Club button.)

Logo - personalize the logos by copying any image into clipboard memory then pasting it in the
image cell or by loading an image file. To activate the image pop-up menu, first click in an image
cell, then follow with a right click in the same cell.

Weekly Dues Amt - default amount credited toward dues when the Dues Paid check box on the
Check-in grid is marked.

Annual Dues Amt - default amount for a new Fee record representing Annual Dues.

A new Annual Dues fee record is created automatically when a clubber's Registration becomes
current or when a Dues Paid check box is checked the first time.

If dues are NOT collected, enter “$0.00” for both weekly and annual dues.  If dues ARE collected, but
there are no weekly dues, hide the Dues header band on the Check-in Module's grid so it does not
cause confusion and take up valuable space.

Room Location - room number or location where the club meets for handbook time.

Points for: attending club, attending church or Sunday School, wearing a uniform,
bringing a Bible, bringing a handbook, paying weekly dues, bringing a visitor, or earning a
Bonus as well as the two Custom fields - values credited to a member when the various items are
marked (on the Check-in grid or the Attendance tab of the Member record).

Set the Display Names for Custom Fields on the Custom Fields tab (also under Club Setup).

The maximum value of Total Points is 32,000 so keep point values modest (1-50)!

Set Point Values for handbook sections under Admin > Curriculum.
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Actions

Save - saves changes and applies them to the database. Be sure to click this to save changes!!

New Club - for mid-year club additions; opens the New Club dialog:

If you are just preparing to run a New Year Setup and need to create a new club name, do not use this
dialog. Instead, add a new row in the club names grid in New Year Setup > Step 1.

Under the Name section, enter the new Club Name and select the appropriate Base Club. Under
the Club Calendar section, choose to:

Copy point values and dates from an existing club, with additional options for including
non-club dates and/or Themes, Notes, and Responsibilities

Create a new set of dates: enter Starting / Ending dates and dates to be excluded.

Delete Club - Removes the selected club.

In order to preserve historical accuracy, do not delete a club that was used in prior club years.

A club's status can be set to Inactive in order to keep it from appearing in various drop-down lists.

Merge Clubs - Merges the members from one club into another club.  Use this mid-year to
combine two clubs like "T&T Boys" and "T&T Girls" into a single club named "T&T". 

In order to proceed with the merge, both clubs must be of the same Base Club and must be using the
same session dates (club calendars).  Only records in the Current Club Year will be affected.
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Club Assignments

This tab shows the records AWdb uses when automatically assigning clubbers to a club based on grade
and gender. These are defaults. A club assignment can be changed in the individual's member record.

If a gender or grade has been incorrectly associated to a specific club, click the cell under the Club
Name column and select the correct club name from a drop-down menu.

Only the Club Name field is editable on this page. For each new club name created under the Club
Names, Logos, Dues and Points tab, be sure a Club Name on this page matches it.

Club Calendars

Use this page to review and edit each club’s calendar for the current club year.

To access a particular club’s calendar, click  next to Club Year and then click  next to the
desired Club Name.  Each club has its own calendar for each club year.
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Quarter, week, and date - of the session. The Quarter designation can be changed. The initial
Club Session Dates are created by the New Year Setup procedure. Dates cannot be added or
deleted directly in the grid. The Add or Delete Dates button in the toolbar opens the Club Date
Modifications dialog:

Theme/Event - relevant to the specific date. Click in the cell and type the details. If multiple clubs
use the same themes, enter the themes for one club (such as the standard "Awana" club), then
click Copy Themes on the toolbar to open the Copy Themes dialog:

Choose a club to Copy Themes from; optionally include Theme/Calendar Note,
Responsibilities, Offering Fund, and/or non-club dates, then choose a club or clubs to
update the records.

The Copy button is disabled until both club names are selected.
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Responsibilities - for leaders on a specific club date (such as a leader substituting for an absent
leader or bringing cookies for a party).

Offering Fund - indicates the designated use of offerings for the specific date, such as: Missions,
Adopt-a-Club, Scholarships, etc. Make the  column visible on the Check-in grid and any money
entered will be credited to the particular fund designated for the given week.

Grade Assignments

Use this page to assign default grades based on a clubber’s age. The grade assignments are the defaults.
A clubbers's grade can be changed on the member's record.

Reference Month / Day - serves as the “cutoff point” for each grade division. The member must
be the age specified in the grid by the reference month/day to be assigned to the listed grade.

Grade - default grade assignment for a clubber with the specified age.

Team Names

If your club is organized using team names (in addition to or instead of custom club names), use the 
Team Names page to define the team names related to each club.
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To add a Team: click on the empty row at the top of the grid or click '+' (plus) below the grid.

1. Club Year - defaults to the current club year, but can be changed.

2. Club Name - Awana club name associated with the team.

3. Team Name - unique name to use for the team.

4. Location - room # or location where the team meets (usually for handbook and/or council time).

Custom Fields

There are three customizable columns that can be used on the Check-in grid and the Check-in and
Progress Report Worksheet.  Set each column's Display Name here.

The fields labeled "Custom1" and "Custom2" can be defined specifically for your club.  Keep the display
names short since they are used in narrow grid and report columns.  To assign the related point values,
go to the Club Names, Logos, Dues and Points tab (also under Club Setup).

The field labeled "Church" is used to calculate Church or Sunday School attendance and must be used
for this purpose; however, the Display Name can be changed.

19.8 Database Utilities

  The various tools found on the Database Utilities page help maintain the data. To learn more about
each utility, read the corresponding section.
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19.8.1 Backup and Restore

  These utilities protect your data so you won't lose everything if the computer crashes, the data is
erased or corrupted, or any other unforeseen calamity occurs. Visit the forum to watch a video about the
Backup and Restore utilities.

Backing up your Database

On the Backup tab, fill in the information required to create a single backup file. This file will have a .bkp
extension and can only be opened with the AWdb Restore feature.

Backup Path - automatically populates with a location to create the backup file, but can be
modified using the ... button at the end of the field and navigating to a different location.

Make sure the backup path is not the same as the installed Approved Workman folder so the main
database and the backup won’t be confused. If the database is run from the local C: drive, select a
USB flash drive or an external drive for the backup file.  If the database is run directly from a USB flash
drive, select the local C: drive or an external drive.

File Name - automatically populates with a default name, but can be modified by typing in the field.

The current date will automatically be added to the file name.

Description - notes that might be helpful when selecting backups to restore, such as “Backup
before running New Year Setup."

Options - choose to include a copy of the current Approved Workman executable file. 
Also choose to exclude the Inventory Photo files to create a smaller file. In general, accept the
defaults unless instructed otherwise.

After reviewing the information, click Start to begin the backup utility. The window switches to the Log
tab to show the progress. Click Save the log… if desired.

http://www.approvedworkman.com/forum/index.php?topic=1193.0
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Restoring your Database

On the Restore tab, fill in the information required to restore data that was previously backed up using
the AWdb Backup feature.

If file corruption prevents logging in to the database to access the Restore tab, it can be accessed from
the Utilities button on the Log-in Dialog.

Restoring a database will overwrite all existing data in the specified Restore Path with a copy of the data
from the selected Backup File.

Backup File - the AWdb backup file (ends in .bkp) to be restored.  Either type in the name of the
backup file, or use the ... button at the far right of the field to browse and find the file.

Restore Path - defaults to “C:\ApprovedWorkman\Data.”  If  the database is installed elsewhere,
edit the field or use the ... button at the far right of the field to browse for a location.  A different
path can be used if you do not want to overwrite your existing data.

This folder must already exist.  If it doesn't, create it before starting the Restore process.

Description - If the Backup File is selected using the ... button, this field will show the description
used when it was created.  If no description was given, it will remain blank.

After reviewing the information, click Start to begin the restore utility.  The window will automatically
switch to the Log Tab to show the progress.  Click Save the log… if desired.

After restoration is complete, a dialog will prompt you to restart the database.  Click OK to close the
database, then log back in as normal.
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19.8.2 Optimize

  Use this utility to make sure the data is organized correctly and that no redundant, void, or
corrupted data exists in the database that might cause confusion or problems. It also performs a number
of housekeeping tasks such as deleting old temp files and files that might have been left over from a prior
update. It looks for potentially inaccurate club assignments and missing data and draws attention to these
issues in the resulting log.

It is a good idea to run the Optimization once a month.

1. Read all the text on the Optimize tab to know exactly what this utility does.

2. Change selections for the additional options if desired. Typically the default settings are adequate.

3. Click Start. The utility goes through the database files and optimizes them. The Log Tab displays
the optimization’s progress.

4. When the optimization is complete, review the log. To save a log that contains recommendations,
click the Save the log… button.
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19.8.3 Repair

  This utility attempts to repair any damage caused to files by malfunctions such as improper
shutdowns of the application, or bugs and errors which occurred while running the application.

1. Read all the text on the Repair Tab before starting the utility.

2. Click Start. The utility attempts to repair any damaged database files. The Log Tab displays the
repair’s progress.

3. When the repair is complete, the log will remind you to immediately exit AWdb and then log in
again to confirm that your data is intact.  Click Close.

4. Exit AWdb by selecting File > Exit from the main menu.

5. Restart AWdb and log in.

6. Review the database records (especially the major modules such as Clubbers, Leaders, and Check-
in) to confirm that the records are intact.  If they are not, use the Restore utility to restore your
recent backup of the database.
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19.8.4 Misc Procedures

  While not used often, the following Miscellaneous Procedures could occasionally be helpful.

Before running any of these procedures, create a backup of the database.  There is no way to undo the
changes except to restore from a backup!

For any procedures that affect records for the Current Club Year,  the Current Club Year can be changed
prior to running the procedure by adjusting it in the Main Window’s toolbar.

Delete All assigned Handbooks from All Members - also removes all related Awards.

Reset Inventory Qty in Stock, Order Level, and Order Qty to Zero  - also sets the “Qty on Order”,
“Last Order Date” and “Last Order ID” to null.

Reset Inventory Last Order ID and Last Ordered Date to blank

Reset Net Points to Zero for All Members - each member’s total net points are "spent".  The
database tracks the points spent for each week, so the expenditure will be counted on the Current Club
Date when the procedure is run.

Check All Assigned Handbooks for Missing Awards [currently unavailable, contact customer
support] - reviews all assigned handbooks for all members and confirms the existence of appropriate
awards. (Missing awards could be due to a bug in a previous version or from entering books in “History”
or “Speed” mode.) If awards are missing, they are created.  At the end of the procedure, the log will
show which awards, if any, were created.

Running this procedure will not create duplicate awards.

For best performance, temporarily disable any anti-virus software.  Be advised, this procedure can take
several minutes to run, depending on the number of clubbers and PC speed.

Set Trek Guidepost sections to “Done” if Lesson is “Done” - reviews all Billboard Series handbooks
and sets the Guidepost sections as “Completed” if the related main lesson is completed (using the same
completion date).
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Recalculate the Balance Due on All Fees - recalculates the Balance Due on all Fee records for all
Club Years, unlike the Admin > Database Utilities > Optimize procedure, which recalculates the Balance
Due only for the Current Club Year. Use this if there are several Fees from a prior year that are displaying
an inaccurate Balance Due and it isn't practical to edit them individually.  

Clear the Team Color for All Members - affects each Member record and all Person Session records
for the Current Club Year.

Clear the Team Name for All Members - affects each Member record and all Person Session records
for the Current Club Year.

Clear the Leader Assignment for All Members - affects each Clubber record and all Person Session
records for the Current Club Year.

Clear the Code field for All Members - sets each Member Record’s Code to null.

Set All Active and Visitor Clubbers to Inactive - affects each Active and Visitor Clubber's record,
along with the Person Session records for the Current Club Year.

Set All Active Leaders to Inactive - affects each Active Leader's record and all Person Session
records for the Current Club Year.

Delete Clubber Role records and recreate for Current Club Year - fixes any blank Club Names
(possibly resulting from a problem during the New Year Setup).

Leaders will not be affected.

Advanced Procedures - these should only be run if instructed to do so by Customer Support.  For
questions about these procedures, please contact Customer Support.

19.8.5 Check-out / Check-in

  This utility provides non-networked multi-user functionality to use AWdb in multiple places at the
same time. For example, a T&T director could Check-out the T&T club to have those records on his
computer for the night to mark attendance and sections for the T&T clubbers (this would be a Secondary
Database).  Meanwhile, someone else would use the Primary Database to mark attendance and sections
for Cubbies and Sparks.  At the end of the night, the T&T director would check the Secondary Database
back into the Primary Database so the information is again all in one place.

A multi-user license is required to use this feature.

How it works...

While logged in to the Primary database, select one or more clubs (or households) to be "checked out". 
In this example the "Sparks Boys and Sparks Girls" clubs will be checked out. The Primary database will
replicate itself in a special way to create a Secondary database and then put all of the needed files in a
newly created Approved Workman folder on a USB flash drive.  At this point, all records in the Primary
database that have been checked out (Sparks Boys and Sparks Girls) will be locked.  They can still be
viewed and reports run for those clubs, but they cannot be edited.  In the Secondary database that is
now on the USB flash drive, the opposite is true... all of the checked out records (Sparks Boys and Sparks
Girls) are unlocked and fully editable, while all of the records that have not been checked out will be
visible but locked, in a read-only state. 
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After using the proper technique to shut down the USB storage device, the USB flash drive can be given
to another user who can plug it into any other computer (running Windows XP, Vista, 7, 8 or 10).  They
can then open the Approved Workman folder and launch and run AWdb directly from the USB flash drive.
 They do not need to download any software or be connected to any network since all of the work will be
done directly on the USB flash drive.  They will have complete recordkeeping capabilities for the Sparks
Boys and Sparks Girls clubs that has been checked out to them.  At the same time, someone else can
keep working in the Primary database, editing records for all of the clubs that are not checked out.  At the
end of club night, or whenever the USB flash drive is given back, check IN the Secondary database and all
of the work that was done in it will be imported and synchronized back into the Primary database.

It is critical that a USB flash drive not be removed from the computer
until it has been shut down properly; otherwise there is a serious risk
of file corruption. Be sure to use the correct technique to tell
Windows to shut down the USB drive, and then wait for the
confirmation that it is safe to remove the device, BEFORE removing it
from the computer. 

Checking Out a Club

In the Primary Database, click Admin > Database Utilities > Check-out/Check-in:

1. Check the computer’s Date & Time, then select Check-out.

2. Select the USB drive letter where the Secondary Database will be created - use the drop-down list
to navigate to the drive.  It must be different than the drive letter of the Primary database.
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This document always speaks of and assumes users are using USB flash memory drives.  Technically
however, any USB external drive would work.

3. Select records based on: Clubs, Existing Groups or Households.

Checking out records based on Households can be useful for registration to process information for
families with members in multiple clubs.

4. Complete selection details: select the club name(s), groups or alphabet letters.

For selection by Club, optionally specify which Team Colors to Include and/or which Team
Names to include. Choose to Exclude Archived Member Records for faster processing
(recommended) and to Exclude clubbers who are LITs in the selected club(s).

Secondary Database Name - read-only field shows the name that will be used under the Existing
Groups tab for quick access when creating secondary databases in the future.

For selection by group or alphabet, an open padlock  indicates a group available to check out.

5. Click “Run”. The window switches to the Log tab and displays the progress. Choose to Print or
Save the log if desired. A confirmation dialog indicates which groups were successfully checked

out. Checked out groups will have a closed padlock  indicating that it is locked in the Primary
Database and no longer available to check out.

6. Use the proper technique (as described above) to safely shutdown and remove the USB flash drive
containing the Secondary Database.

Starting the Secondary Database from the USB flash drive

Insert the USB drive with the Secondary database into a computer. Usually a dialog appears showing the
drive letter that was assigned. From here, select the choice of viewing folders and files on the device. If
this dialog does not appear, click Start > Computer and double click the icon representing the USB
flash drive to see its folders and files. Open the Approved Workman folder on the USB drive and double
click the ApprovedWorkman.exe file to launch the Secondary database. The log-in screen will open, but
with a few changes.

Notice that the Data path is correctly pointing to the USB flash drive letter. Also the words
"Secondary Database" are displayed and the checked out clubs are listed.
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Locked Records

The Check-in module has an indicator to show whether or not a member's record is locked.  The most
obvious way to tell is by attempting to check the attendance box and nothing happens.  That might seem
confusing at first, but the status bar will show a closed padlock symbol.  

If a locked member record is opened, "Locked" is shown in the title bar and in the status bar.  An Unlock
button is also added to the toolbar of locked member records.

The Unlock feature provides a way to override the lock for situations where a clubber is locked (in either
the primary or a secondary database) but the person with the database having the locked record should
have 'ownership' of the record. (For example, a visitor who has previously attended but whose record is
archived, so is not available - locked - in a secondary database.) It is not intended to be used to make
changes to a locked record that is known to be in active use in another database. The person who has
'ownership' of the record should make those changes. The best way to know if the unlock feature should
be used is to consider "should I have ownership of this record or does the person who currently has the

unlocked record need to keep ownership?"

If a locked record in a primary database is unlocked using this feature, any changes made in the secondary
database will NOT be checked in. Likewise, if a locked record in a secondary database is unlocked using this
feature, the record WILL be checked in (over-writing any changes made in the primary database). 
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Checking a Secondary Database back into the Primary

Log in to the Primary Database and click Admin > Database Utilities > Check-out / Check-in.  On
the Database Check-out/Check-in dialog's Main tab, follow these steps:

1. Check the computer’s Date & Time, then select Check-in.

2. Select the USB drive containing the Secondary Database to be checked in:  If only one Secondary
Database is checked-out, the correct drive letter will likely already be selected. If it is not, select the
correct drive letter from the drop-down list of drives.

3. The selected club(s) or groups will be checked in - a club or group available for Check-in will be

indicated by a key symbol  next to it and will automatically be selected.

When multiple groups are checked-out, all of them do not need to be checked in at once.

4. Click “Run”.  The Database Check-out / Check-in dialog switches to the Log tab and display the
progress of the check-in.  Any data that was added or modified in the Secondary Database will be
transferred into the Primary Database.  (Records that were deleted in the Secondary database will
also be deleted from the Primary.)  Print or Save the log if desired.

Data entry Exceptions: 

Generally, a user in the Primary database can't make any changes to members who are in checked out
groups. There are a some exceptions, however:

Household data - such as: Address, Persons authorized to pick up clubbers, Phones and E-mails that
are shared by all members of a household. Primary and/or Secondary database users can change
these fields if they have at least one member editable in the household.

Payments - a user in either database can post payments to any fees in the Household Ledger.

NEW members - can be entered in either database regardless of the club assignment.
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What Happens if the USB flash drive with the Secondary Database is lost?

In the Primary Database, click Admin > Database Utilities > Check-out/Check-in. On the Main tab:

1. Check the computer’s Date & Time, then select Check-In.

2. In the Step 3 grid, right click on the club that needs to be checked-in to open the pop-up menu.

3. Click Reset all records in the selected club as being Checked In.  A dialog will ask for
confirmation to mark these records as "checked in" without running the check-in procedure. Click 
Yes.  This will unlock the records that were previously checked out.

Once a group is reset, it cannot be checked in later if the lost drive is found. 

19.8.6 New Year Setup

  The New Year Setup procedure (NYS) prepares the database for a new club year. There is no
formal process or work that needs to be done to close out the prior year. It makes getting ready for a
new club year something that can be done in just minutes.

Please read the following instructions carefully! They contain important reminders.  Not reading the
instructions might result in problems with the database in the future.

The Backup Procedure MUST be completed before running the NYS procedure.

The New Year Setup can be used to create session records to track VBS or other summer programs.

Introduction

The Introduction page explains the purpose of the NYS and gives an overview of the steps.
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Step 1 - Session Dates

Use this page to set up the club dates for the upcoming year.

a) Select the new club year and the starting and ending dates

1. Select the upcoming Club Year from the drop-down menu.  A note appears in the field next to
the Club Year stating “ONE Session Date will be created each week on the same weekday".

This will not be enabled unless the Backup Procedure has been run.

2. Select the Starting Date and Ending Date from the respective drop-down calendars.

Awards Night is generally not included in the Ending Date since records of sections, attendance,
points, etc.are not generally kept for that night.

b) Establish clubs that will be active in the new club year

During the initial setup, all clubs are listed by default. In future years, it will default to the clubs used
in the prior Club Year.

1. Edit the Club Names if desired.

2. Add any personalized clubs (“T&T Adventure,” “T&T Challenge,” or "Sparks Girls" and "Sparks
Boys" etc.) by clicking the '+' (plus) button and then entering the personalized name.

3. Remove any club that is not offered (Nursery, for example) by selecting that club’s row and then
clicking the '-' (minus) button to delete it.

We recommend keeping the "Awana" base club as this is the generic club name to assign leaders
to that don't belong in the other clubs  (Commander, Secretary, etc.).

For clubs that meet on a different day of the week, the starting and ending dates can be modified
in the grid. The Meeting Day field will be updated accordingly.
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c) Enter the dates that should be excluded

Indicate which dates there will be no club, such as Thanksgiving, Christmas and Easter breaks.

1. To schedule an excluded week, click in the blank grid and use the drop-down calendar or type in
the dates to exclude. Click the small checkmark below the grid. Repeat for additional dates.

2. To remove a date from the list, select the row and click the '-' (minus) button.

Step 2 - Promotions

Use this page to select options for the promotion of clubbers including when to 'graduate' a clubber.

Promote each clubber’s School grade to the next level?

1. Select whether or not to automatically have each clubber advanced one grade.

2. For most situations, clubbers are promoted to the next logical grade. For preschool age children,
promotion also considers the clubber's age. Select the date(s) to use as the cut-off for this
evaluation. The default is the date of the first club session, but can be changed.

3. When a clubber is promoted OUT of the last grade of the Awana program, the status is set to
“graduated”.  If your program does not run through 12th grade, choose to Set a clubber’s
Status to “Graduated” if promoted to grade… and indicate the grade.

Allow this procedure to automatically handle Club promotions?

Read the notes on the dialog and select from the drop-down menu.

Allow this procedure to archive clubbers? leaders?

Allowing the procedure to archive a person will set the person's status to "Archived".  The person is
NOT removed from the database and the status can be returned to "Active" if needed.

1. Check the appropriate box to archive clubbers, leaders, or both.
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2. A person will be archived based on how long it has been since they have attended.  Jan. 1 of the
current year will be used as the default, but another date can be selected.

Another good option for a date is the first meeting date for the club year so any member that has not
attended during the entire club year will be archived.

Step 3 - Club Assignments

The grid sets up the defaults used for Club Assignments.  All of the Club Names listed in the box on the
right should be included in the grid on the left (except Awana which is used for leaders). This grid limits
assignments to specific Grade and Gender combinations. There must be a single club assignment for a
specific grade and gender combination.

To change the defaults, click in a cell in the grid and select a different option from the drop-down
menu in that cell.

If you created personalized club names in Step 1, those clubs should be added to the grid. Click
'+' (plus) to create a blank row at the top of the grid. Select the grade, gender, club name and
meeting night from the drop-down menus. When finished, click the small checkmark below the grid
to save the record.
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Step 4 - Resets and Defaults

Use this page to automatically reset, clear or waive certain pieces of information from last year.

Resets; Waive Balance on Fees; Clear current values

Carefully read the detailed descriptions of each item and indicate Yes or No for each.

Offering Fund

Choose a default value. These can be customized under Admin > Generic Lookups > Donation
Purpose/Funds.
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Step 5 - Run the Procedure

Use this page once all of the setup is complete to run the process.

1. After reading any reminders on the screen, click Begin Processing.  A log showing changes,
updates, calendar settings, promotions and book assignments is generated.

Throughout the procedure some alert dialogs might pop up with notifications of certain areas in
which the updating of records is unnecessary.  If such notices pop up, simply click Yes to continue
the procedure.

2. Once the NYS is done, read the log to confirm that it updated records as expected.  As instructed at
the end of the log, print at least the last page to use as a check list of what to do next to prepare
for the new club year.

3. Complete preparation for the New Year by reviewing details under the Club Setup section.

19.8.7 SQL Workbench

  Even though AWdb is very robust and provides lots of ways to view and analyze data, there might
occasionally be times when you want to see data in a different way. The SQL Workbench provides an
interface for querying the database using SQL statements. To see ways other users use this feature, visit
the AWdb Forum and have a look at the SQL Workbench topic.

This tool should only be used with an understanding of SQL or with explicit instructions from Customer
Support.  Be cautious about modifying any records due to possible impacts on referential integrity and
validation.  And as always, before editing any data, create a backup of the database!

http://www.approvedworkman.com/forum
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Icon Action Description

Close Closes the SQL Workbench without saving current changes.

Save Saves any changes made in the "live result set".

The Save button is only enabled if the Request a live result set is
selected.

Save SQL Saves the SQL statement that is currently displayed to a file to easily
open it and run it again at a later time.

Open SQL Opens a SQL statement that was previously saved to a file.

Auto Width Automatically resizes the grid's columns to best fit the data that is
displayed.

Grid Tools Lists actions related to the grid such as: saving or resetting a grid
layout, or exporting data.

Stay On Top Toggles whether or not the window stays on top of the main window.

Run SQL Runs the current SQL statement and displays the results in the grid.

To edit the data, check the Request a live result set box then click Run SQL again. This allows
changes to be made in the grid and enables the Save button to keep the changes.
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Again, be cautious about modifying any records due to possible impacts on referential integrity and
validation.  And as always, before editing any data, create a backup of the database!

If the grid's data is going to be printed, specify a Report Title to use as the title of the printed
report.

19.8.8 Purge Sample Data

  The purpose of this utility is to delete the sample data from the trial version of AWdb in order to
start entering live club data.

If you are using the Data Purge Utility on your own records for some reason, make sure you run a
backup before the purge, in case you change your mind after erasing all the records from your database.
 If this happens, you will be able to restore the backed up data by using the Restore Utility.

If you have not spent some time playing around with AWdb using the sample data, you might want to
skip this section for now.  Come back to it when you are ready to begin entering your own data.

1. From the Admin > Database Utilities tab, click Purge Sample Data to open the Data Purge
dialog.

2. Read the information given in this window.

3. Click Print Instructions to use this as a check list to setup the database.

4. Check the box next to Yes, I am ready to run the purge procedure, which will enable the
Purge button.

5. Click the Purge button.

6. On the Confirmation dialog, when ready to continue with the purge, click Yes.  The Data Purge
utility deletes ALL data records.
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7. When all the data is purged, a notification will indicate that a new user account for the database will
be created.  Click OK to open the New Admin User dialog.

8. Enter the desired User Name, Password, Screen Name, and Full Name.

Make sure to note the new User Name and Password so you don’t get locked out of the database! 
The log-in/password of demo/demo will no longer work.

9. Click OK.  A notification will be given that the database must close.

10. Click OK to close the database.

11. Log in with the new admin user account. All data records will have been purged.

Set up a new club year before beginning to enter clubber or leader information.

19.8.9 Error Log

  Use this utility to view past errors in the program. This might be useful when working with Tech
Support to track down a problem. Unwanted records can be deleted by either clicking the Delete
Selected Errors or the Delete All button.

19.8.10 Update History

  Use this utility to view the history (log) of updates that have been applied to AWdb.  Select a row to
view the details of the fixes and enhancements for the selected update.  Also see whether the updates
were successfully applied or if there were any errors.
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19.8.11 Database Configuration

  Use this utility to alter the configuration of the database.

19.8.12 Data Import

  Use this utility to import data from an external file for either of the following two scenarios:

1. Initial Data Load: populate an empty database after purging the sample data and running the
New Year Setup. (For new users of AWdb.)
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2. Online Registration: add or update existing records with a data file from an online registration
website. (For existing users of AWdb.)

Before importing data from an online registration file, be sure that:
a. the New Year Setup procedure has been run for the current club year, and
b. that a backup that was created using AWdb's built-in backup utility, and
c. that no other users are logged in when this procedure is run.

Introduction

The Introduction page provides important information about File Types, Limitations and Club Names,
as well as tips For Best Results and format information for Addresses.

Please read this page carefully! Not reading the instructions could result in problems with your data.

Step 1 - Select the Source File

Use this page to identify the source file of the data to be imported.  After the file is loaded, review the
data in the grid and correct any typos and invalid or inconsistent values.  See the Field Mapping Notes
in Step 2 for specific requirements of each field.  Return to Step 1 to edit data as needed.
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Step 2 - Map the Fields

Use this page to map the source columns to the corresponding AWdb field names. On the left is a list of
the Unassigned Source Columns. In the grid, identify the Source Column for an AWdb Field Name.
Information about Data Type and Field Size are given as well as specific information about mapping the
source data to that field.

Please read the mapping notes for each field carefully to assure data is in the correct format and that
you understand how each field is used.
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Step 3 - Select Options

Use this page to select to import as an Initial Data Load or from Online Registration. Detailed
descriptions are included as well as Important Notes.

Step 4 - Run the Procedure

Once the setup is complete, use this page to run the Data Import Procedure.

1. After reading any reminders or warnings on the screen, click Begin Processing.  A log showing
the steps of the import process is generated.
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2. Once the Data Import is done, read the log to make note of any items that might need to be
reviewed.  Print or Save the log if desired.

3. Click Close when finished.



Chapter

20
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20 AWdb Terminology

Awana – In the context of entering records in the database and assigning Club Names, there is a
generic "Awana" club name in addition to the other club names like "Cubbies", "Sparks", "T&T", etc.
This generic "Awana" club name is intended to be used for leaders who do not serve exclusively in a
specific club; for instance, a Commander, Pastor, Games Director, Song Leader, Secretary etc.  If a
leader is serving in a specific club (i.e., a Sparks Director) it is appropriate to use a specific Club
assignment.

Awana® Clubs International – The central organization responsible for creating, organizing and
running the Awana program.  If you have an Awana program at your church, you must be chartered with
Awana Clubs International.

Awana Program – The running of a chartered club from Awana® Clubs International by a local church.
(Not the AWdb software program.)

AWdb – An abbreviation for the Approved Workman Database software application. 

Club – Individual clubs separated by age/grades and distinguished by uniform and curriculum levels/
design.  There are currently six clubs in Awana: Puggles, Cubbies, Sparks, Truth and Training (T&T for
short), Trek, and Journey.

Club Dates – The dates on which an Awana program is scheduled to meet.  For instance, if your Awana
program meets on Wednesdays, the Club Dates should be mainly Wednesdays (with the exception of
such Club Dates as Bible Quizzing, Awana Games, etc. which probably meet on weekends).

Member – A person involved in Awana, either as a clubber or as a leader.

Clubber – A child who regularly attends and participates in Awana.

Leader – An adult who helps in Awana after having gone through at least a preliminary training program
and a certification test.

Leader in Training (LIT) – An adult or teen who has not gone through a training program.  Usually
teens must go through two years of training before taking a certification test.  If Trek and Journey meet
on a separate night from the rest of Awana, it is not unusual for those clubbers to volunteer in younger
clubs such as Cubbies or Sparks. [Also referred to as Student Leaders.]

Section – In most Awana curricula, the books are separated into “sections.”  A section is distinguished
as what a clubber must complete all at once (for instance, a clubber must recite all verses within a
section to the leader in one sitting, with a maximum of two prompts or helps), and usually is comprised
of one to three verses, or a Bible Study or activity.  Sections are known by specific names according to
club: Cubbies have “Bear Hugs,” Sparks “Jewels”, and T&T “Discoveries.”
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